Enable lower resolution without scaling/stretching

Hi. I have a laptop with AMD Ryzen 7 PRO 4750U. I do not have a dedicated graphics card, I use the embedded gpu. Also I’m on Manjaro 21.0.4 with Gnome and Wayland.
In a game, when I decrease the resolution below my native one, I get a stretched image. Sometimes squeezed when the aspect ratio does not match. I want it to be displayed as is, without scaling, with black bars.
I know that it is possible, because it works as expected in Windows. And yes, the monitor setting for filling the screen is turned off.
So I don’t know what to look for. Is it some gpu, Wayland or Gnome setting, that does this?
Searching for answers I found some Xorg (xrandr) commands but nothing for Wayland. Besides I really don’t know, whether Wayland is the culprit here.

Any help is appreciated.

all that is good to know, but what is the actual problem app?

Well, I think it is in any game but I tried it with

  • Trackmania Nations Forever
  • Guacamelee
  • Quake
  • Strider
  • Team Fortress 2

if that helps.

So, there is no setting to turn this scaling off?

I think that option should be set on the monitor itself and not the software.