EFI firmware, do I need to keep windows?

I’ve been using Manjaro for a little while now after hopping over from ubuntu GNOME. It fills all my use cases perfectly, and I really want to get rid of windows off this computer, because I only really kept it around because in the past, ubuntu couldn’t play nice with my printers (Which I got manjaro to do). But there’s one thing keeping me from doing this for the time being.

My system uses EFI firmware, and to actually boot into GRUB, I first needed to boot into Windows 10 and use bcdedit to modify the boot manager path. The exact command I used is bcdedit /set {bootmgr} path \EFI\Manjaro\grubx64.efi.

Before I delete the windows partition and throw away its EFI stub, I want to confirm that deleting the 2 would leave my EFI boot process the same, except with no windows in the grub menu. I’m not sure if the fact that I used bcdedit to convince the computer to boot Manjaro means that the deletion of windows would change that fact.

Technical information if required:
My computer is an Acer V3-575T
I’m running Manjaro GNOME kernel 4.9.39-1-MANJARO

It seems possible (because you already have \EFI\Manjaro\grubx64.efi).

But to be sure, after booting up to Manjaro, provide

efibootmgr
sudo parted -l
cat /etc/fstab
cat /proc/cmdline
findmnt /boot/efi
ls /boot/efi/EFI/manjaro/

efibootmgr output

BootCurrent: 0005   
Timeout: 0 seconds  
BootOrder: 0005,0000,0001,2001,2002,2003                                        
Boot0000* Windows Boot Manager          
Boot0001* Linux     
Boot0002* Manjaro   
Boot0004* Unknown Device:               
Boot0005* Windows Boot Manager          
Boot2001* EFI USB Device                
Boot2002* EFI DVD/CDROM                 
Boot2003* EFI Network 

sudo parted -l output

Model: ATA TOSHIBA MQ01ABD1 (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name                          Flags
 1      1049kB  106MB   105MB   fat32        EFI system partition          boot, esp
 2      106MB   123MB   16.8MB               Microsoft reserved partition  msftres
 3      123MB   522GB   522GB   ntfs         Basic data partition          msftdata
 5      522GB   999GB   477GB   ext4
 4      999GB   1000GB  1074MB  ntfs         Basic data partition          hidden, diag

Contents of /etc/fstab

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=F411-2CFD                            /boot/efi      vfat    defaults,noatime 0 2
UUID=6c0d7cea-3008-4433-ba95-159247664aab /              ext4    defaults,noatime 0 1
/swapfile none swap defaults 0 0

Contents of /proc/cmdline

BOOT_IMAGE=/boot/vmlinuz-4.9-x86_64 root=UUID=6c0d7cea-3008-4433-ba95-159247664aab rw

findmnt output

TARGET    SOURCE    FSTYPE OPTIONS
/boot/efi /dev/sda1 vfat   rw,noatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro

Contents of /boot/efi/EFI/Manjaro
grubx64.efi

That output of efibootmgr worries me, It seems to imply that I am indeed first booting to Windows’ boot manager, and that the information I put into bcdedit simply gets it to delegate to GRUB

Very good. Perfect.
At Manjaro, do 2 commands.

sudo efibootmgr -o 0002,0001
sudo cp /boot/efi/EFI/Manjaro/grubx64.efi /boot/efi/EFI/boot/bootx64.efi

Cheers.

[edit] - sorry, didn’t answer your Q.
yes, you’re booting order to windows first; and correct, you let bcdedit ‘go to’ grub.

Hello,

I just add that you should be able, in the mother board firmware, to select on which system you want to boot. You should also have the possibility to choose when the system starts (using F11, F12 … depending on your PC) when it tests itself.
That may be a test to see if your windows is still required :slight_smile:

That does not prevent you to do what gohlip told you, of course :wink:

Alright. @gohlip I did what you said, and it appears to have f**ked up the boot order on my machine.

There are now 2 entries for windows boot manager in efibootmgr output. One at 0000 and one at 0005. The one at 0000 has precedence over anything else, and changes in efibootmgr are reverted when I reboot.

The windows boot manager on 0000 seems to ignore what bootmgr is set to in bcdedit, and ignores grub entirely. I can still boot into grub by selecting it in the f12 boot menu, but I can’t simply boot into it anymore. I followed all the steps you provided.

Boot into Manjaro [1] and at terminal

efibootmgr -v
sudo pacman -Syyu
sudo grub-install
sudo update-grub
sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi
efibootmgr -v

Please provide output of ‘the before and after’ “efibootmgr -v”

Reboot and let us know if bootorder has changed.

[1] If you cannot boot your way or using F12, boot up using this.

[edit] - for that I need your “sudo blkid” as well to check your booting partition.

Before

[redrield@redrield-Acer-V3-575T ~]$ efibootmgr -v
BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0000,0001,2001,2002,2003
Boot0000* Windows Boot Manager	HD(1,GPT,8e8273ed-3f47-4a26-8377-6ee8f93087ae,0x800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)RC
Boot0001* Linux	HD(1,GPT,8e8273ed-3f47-4a26-8377-6ee8f93087ae,0x800,0x32000)/File(\EFI\Boot\grubx64.efi)RC
Boot0002* Manjaro	HD(1,GPT,8e8273ed-3f47-4a26-8377-6ee8f93087ae,0x800,0x32000)/File(\EFI\Manjaro\grubx64.efi)
Boot0004* Unknown Device: 	HD(1,GPT,8e8273ed-3f47-4a26-8377-6ee8f93087ae,0x800,0x32000)/File(\EFI\ubuntu\shimx64.efi)RC
Boot0005* Windows Boot Manager	HD(1,GPT,8e8273ed-3f47-4a26-8377-6ee8f93087ae,0x800,0x32000)/File(\EFI\Manjaro\grubx64.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}....................
Boot2001* EFI USB Device	RC
Boot2002* EFI DVD/CDROM	RC
Boot2003* EFI Network	RC

After

[redrield@redrield-Acer-V3-575T ~]$ efibootmgr -v
BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0002,0000,0001,2001,2002,2003
Boot0000* Windows Boot Manager	HD(1,GPT,8e8273ed-3f47-4a26-8377-6ee8f93087ae,0x800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)RC
Boot0001* Linux	HD(1,GPT,8e8273ed-3f47-4a26-8377-6ee8f93087ae,0x800,0x32000)/File(\EFI\Boot\grubx64.efi)RC
Boot0002* manjaro	HD(1,GPT,8e8273ed-3f47-4a26-8377-6ee8f93087ae,0x800,0x32000)/File(\EFI\manjaro\grubx64.efi)
Boot0004* Unknown Device: 	HD(1,GPT,8e8273ed-3f47-4a26-8377-6ee8f93087ae,0x800,0x32000)/File(\EFI\ubuntu\shimx64.efi)RC
Boot0005* Windows Boot Manager	HD(1,GPT,8e8273ed-3f47-4a26-8377-6ee8f93087ae,0x800,0x32000)/File(\EFI\Manjaro\grubx64.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}....................
Boot2001* EFI USB Device	RC
Boot2002* EFI DVD/CDROM	RC
Boot2003* EFI Network	RC

EDIT: After these changes, when I reboot my system goes into “automatic repair”. when it prompts me to reboot, I’m booting back into windows by default
efibootmgr -v output after rebooting

BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0000,0001,2001,2002,2003
Boot0000* Windows Boot Manager	HD(1,GPT,8e8273ed-3f47-4a26-8377-6ee8f93087ae,0x800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)RC
Boot0001* Linux	HD(1,GPT,8e8273ed-3f47-4a26-8377-6ee8f93087ae,0x800,0x32000)/File(\EFI\Boot\grubx64.efi)RC
Boot0002* manjaro	HD(1,GPT,8e8273ed-3f47-4a26-8377-6ee8f93087ae,0x800,0x32000)/File(\EFI\manjaro\grubx64.efi)
Boot0004* Unknown Device: 	HD(1,GPT,8e8273ed-3f47-4a26-8377-6ee8f93087ae,0x800,0x32000)/File(\EFI\ubuntu\shimx64.efi)RC
Boot0005* Windows Boot Manager	HD(1,GPT,8e8273ed-3f47-4a26-8377-6ee8f93087ae,0x800,0x32000)/File(\EFI\Manjaro\grubx64.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}....................
Boot2001* EFI USB Device	RC
Boot2002* EFI DVD/CDROM	RC
Boot2003* EFI Network	RC

Okay reboot and let us know how it goes.
Provide efibootmgr -v again when rebooted.
Hope there’s is no error when you do the following…
sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi

If problem remains the same, (boot 0000 remains on top), I suggest a drastic procedure (but I note you wish to get rid of windows) and that is to rename your windows boot file bootmgfw.efi.

If you want to do this, when booted again to Manjaro,

sudo mv /boot/efi/EFI/Microsoft/Boot/bootmgfw.efi /boot/efi/EFI/Microsoft/Boot/bootmgfw.efi.old
sudo cp sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/Microsoft/Boot/bootmgfw.efi

Warning it may be risky and it will be the first time I’m suggesting this.
But I think it will work.
And if it doesn’t, rename back to the original. but risk is still valid.

Good luck.

???
You should have said this earlier.
Go to Acer website and see if we can disable this.

Try also this from Acer website.
You may need to go to ‘advanced’ section to do this beforehand.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.