Duplicate gajim package

It appears there is a duplicate of the gajim package in Manjaro. If I run pacman -Si gajim, I see a version 1.0.0-1 package in the extra repo, and the latest 1.1.3-2 in the community repo.

pacman wants to keep installing the extra repo version. Looking at the Arch repos, this package should be in the community repo. Can we remove the extra repo version of the package?

This indicates that you have an older install.
gajim has indeed been moved from extra to community repo.
You should remove the other one. Though that might get weird .. so you may need to remove both and reinstall gajim again.

I am surprised that a normal update did not catch it though .. then or now .. as it should normally ask to replace - especially with something the same name and higher version numbers ..

Maybe you can copy any error from

sudo pacman-mirrors -f && sudo pacman -Syyu

@cscs I'm not sure how I can remove it?

I've run a pacman -Syu and am fully up to date, but I still see both versions when I run pacman -Si gajim. If I do a pacman -S gajim, it installs the extra version each time.

If I run pacman -Syu, why would I still be seeing the extra version?

Try removing it with the version specifically.

sudo pacman -Rns gajim-1.0.0-1

Or, again, do something like illustrated above.

[as in its a pretty unobtrusive package .. nothing core relies on it .. so worst case scenario remove both/all and reinstall .. it might even be worth it to reinstall after however you end up removing the other one, just in case]

I think we might be misunderstanding each other....

I can remove the gajim package from my system, that's not a problem.

However, pacman still sees the 1.0.0 version in the extra repository, so I cannot install the 1.1.3 version in the community repository. Why does pacman still see the 1.0.0 version in the extra repository if it was removed?

If thats true then its sounds like you might have a bad mirror or you havent synced. I included sorting mirrors (and force syncing) in the first response above.

pacman-mirrors tells me it has no -f option

pacman-mirrors: error: unrecognized arguments: -f

Thats even weirder ... how long have you had this install ? What ISO did you use ?
This is all adding up to a rather broken or out of date system. Or partially updated, which is also broken.

You can maybe look at pacman-mirrors --help for whatever commands it used to use. But I think if its years old then maybe it has no -f and still uses -g ..

In which case it would be
sudo pacman-mirrors -g && sudo pacman -Syyu

But again - depending on the answers above you might find it easier to reinstall a fresh system than to fix and update whetevr you have now. But thats your call.

Though this really sounds like some sort of time-travelling frankenstein, because for example pacman-mirrors has had an -f option for years now.

Please answer the questions at the top of this post.
How old is the install? What ISO did you use? (maybe provide a link?)

Using the Raspberry Pi 4 (aarch64) 19.12.1 image posted here:

...are you sure ? The iso was 19.12.1 ? Did you also validate it ?

Lets look at system info:

inxi -Fxxxza --no-host

Yes I verified the SHA1 signature.

Manjaro-ARM-xfce-rpi4-19.12.1.img.xz
00c5a535a7f0adf606b3a0c57795d47c415daf99

System:
  Kernel: 4.19.97-1-MANJARO-ARM aarch64 bits: 64 compiler: gcc v: 9.2.0 
  parameters: coherent_pool=1M 8250.nr_uarts=0 cma=64M cma=256M 
  video=HDMI-A-1:1920x1080M@60,margin_left=0,margin_right=0,margin_top=0,margin_bottom=0 
  video=HDMI-A-2:1920x1080M@60,margin_left=0,margin_right=0,margin_top=0,margin_bottom=0 
  smsc95xx.macaddr=DC:A6:32:36:BE:EB vc_mem.mem_base=0x3ec00000 
  vc_mem.mem_size=0x40000000 root=/dev/mmcblk0p2 rw rootwait 
  console=ttyS0,115200 console=tty1 selinux=0 plymouth.enable=0 
  smsc95xx.turbo_mode=N dwc_otg.lpm_enable=0 kgdboc=ttyS0,115200 
  elevator=noop snd-bcm2835.enable_compat_alsa=0 
  Desktop: Xfce 4.14.2 tk: Gtk 3.24.13 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro ARM 
Machine:
  Type: ARM Device System: Raspberry Pi 4 Model B Rev 1.1 details: BCM2835 
  rev: c03111 serial: <filter> 
Battery:
  Device-1: hidpp_battery_0 
  model: Logitech M720 Triathlon Multi-Device Mouse serial: <filter> 
  charge: 55% (should be ignored) rechargeable: yes status: Discharging 
CPU:
  Topology: Quad Core model: N/A variant: cortex-a72 bits: 64 type: MCP 
  arch: ARMv8 family: 8 model-id: N/A stepping: 3 microcode: N/A 
  features: Use -f option to see features bogomips: 432 
  Speed: 1500 MHz min/max: 600/1500 MHz Core speeds (MHz): 1: 1500 2: 1500 
  3: 1500 4: 1500 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass status: Vulnerable 
  Type: spectre_v1 mitigation: __user pointer sanitization 
  Type: spectre_v2 status: Vulnerable 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: bcm2835-vc4 driver: vc4_drm v: N/A bus ID: N/A chip ID: brcm:soc 
  Device-2: bcm2835-hdmi driver: N/A bus ID: N/A chip ID: brcm:soc 
  Display: x11 server: X.org 1.20.7 driver: modesetting alternate: fbdev 
  resolution: <xdpyinfo missing> 
  Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:
  Device-1: bcm2835-audio driver: bcm2835_audio bus ID: N/A 
  chip ID: brcm:soc 
  Device-2: bcm2835-hdmi driver: N/A bus ID: N/A chip ID: brcm:soc 
  Sound Server: ALSA v: k4.19.97-1-MANJARO-ARM 
Network:
  Message: No ARM data found for this feature. 
  IF-ID-1: eth0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  IF-ID-2: wlan0 state: down mac: <filter> 
Drives:
  Local Storage: total: 28.97 GiB used: 6.23 GiB (21.5%) 
  ID-1: /dev/mmcblk0 vendor: SanDisk model: SL32G size: 28.97 GiB 
  block size: physical: 512 B logical: 512 B serial: <filter> scheme: MBR 
Partition:
  ID-1: / raw size: 28.88 GiB size: 28.36 GiB (98.22%) 
  used: 6.20 GiB (21.8%) fs: ext4 dev: /dev/mmcblk0p2 
  ID-2: /boot raw size: 94.0 MiB size: 93.8 MiB (99.79%) 
  used: 37.7 MiB (40.2%) fs: vfat dev: /dev/mmcblk0p1 
Sensors:
  Message: No sensors data was found. Is sensors configured? 
Info:
  Processes: 176 Uptime: 2h 29m Memory: 3.73 GiB used: 1.85 GiB (49.5%) 
  Init: systemd v: 244 Compilers: gcc: 9.2.0 Shell: bash v: 5.0.11 
  running in: xfce4-terminal inxi: 3.0.37 

Welcome to Manjaro. Manjaro ARM has it's own forum section:
moved to #manjaro-arm

Thanks for reporting.

Our current repo scripts can not take into account when a package moves to a different repo, so the older one would still be present.

I will manually remove it from the repo.

That doesnt account for the crazy actibg pacman-mirrors ..

The problem is the way we currently do our mirrors.

Manjaro ARM can't use the newer pacman-mirrors yet, so we are still using pacman-mirrorlist.
But that might change in the not-so-distant future.

Forum kindly sponsored by