Dummy output on restart/power-on on KDE

Hello, I’m having this problem every time I start the system with KDE. I have my headphones in the LR output from the motherboard. To make them work I have to change the profile to an input-only mode and the choose Stereo or Duplex to be detected. Previously I run XFCE for a couple of weeks without any problems. I tried several solutions in the forum but anything changed. I’m trying kernel 5.8 now (5.7 until 5 minutes ago) but again with no succsess. Also the multimedia keys don’t work, even with the Audio config panel open. The shortcuts are under the Global category. I remember using them, in the first days of the install and I didn’t change anything in the audio category.
Thanks in advance.


It might help to know the brand of headphone you are using? does the Headphone have a mic? or not. When it comes to headphones, it should be output stereo or duplex as I can’t see it being a input device unless it has built in mic. I have had two different keyboards, the current one is a Qamdias Hermes lite and I haven’t been able to get the mulitmedia keys to work. Maybe someone can help with that.

However Can you pls post your Inxi -F -a -z-y output so we can know what type of system you have.

I would post a link to “How to provide good Information” to help with providing information that will lead to a solution. But it won’t allow me to do that.

Hello @yawanathan, thanks for your reply and helping me posting more accurately.
Mi headphones are the Sennheiser HD202 , L and R output only. I’m using the connected in the green port at the back panel (where usually we connect speakers). Apart from that I have a generic and very simple microphone for online classes in the microphone input also in the back panel (the pink one). That’s why I use Duplex, but it doesn’t make any change to leave at Analog Stereo either, It’s changed back to Dummy when I restart or startup the system.
The front panel is empty and I’m not planning to connect or disconnect more devices.

I used this setup on Manajaro 20 XFCE for three weeks and never have a problem but I want to use KDE for customization and practical reasons. Yesterday I installed a new XFCE partition and everything was working fine.

For media keys I had to put the audio widget on the Latte dock for them to work. I don’t use a system tray or panel.
Thanks again, here is the output of my system.

  Kernel: 5.8.3-2-MANJARO x86_64 bits: 64 compiler: N/A 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 
  root=UUID=ed89482d-466f-4690-9b0c-7df8c8597eb0 rw quiet apparmor=1 
  security=apparmor resume=UUID=6e0934ed-6b43-4022-9d37-0caddd35e4df 
  Desktop: KDE Plasma 5.19.4 tk: Qt 5.15.0 info: latte-dock wm: kwin_x11 
  dm: SDDM Distro: Manjaro Linux 
  Type: Desktop System: Gigabyte product: Z87X-UD3H v: N/A serial: <filter> 
  Chassis: type: 3 serial: <filter> 
  Mobo: Gigabyte model: Z87X-UD3H-CF v: x.x serial: <filter> 
  UEFI: American Megatrends v: F3 date: 04/17/2013 
  Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard serial: <filter> 
  charge: 55% (should be ignored) rechargeable: yes status: Discharging 
  Topology: Quad Core model: Intel Core i7-4770K bits: 64 type: MT MCP 
  arch: Haswell family: 6 model-id: 3C (60) stepping: 3 microcode: 28 
  L2 cache: 8192 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 55892 
  Speed: 3891 MHz min/max: 800/3900 MHz Core speeds (MHz): 1: 3892 2: 3890 
  3: 3791 4: 3876 5: 3854 6: 3820 7: 3759 8: 3772 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: NVIDIA GM204 [GeForce GTX 970] vendor: Gigabyte driver: nvidia 
  v: 440.100 alternate: nouveau,nvidia_drm bus ID: 01:00.0 chip ID: 10de:13c2 
  Display: x11 server: X.Org 1.20.8 compositor: kwin_x11 driver: nvidia 
  display ID: :0 screens: 1 
  Screen-1: 0 s-res: 3840x1080 s-dpi: 92 s-size: 1060x301mm (41.7x11.9") 
  s-diag: 1102mm (43.4") 
  Monitor-1: DVI-I-1 res: 1920x1080 hz: 60 dpi: 92 
  size: 531x298mm (20.9x11.7") diag: 609mm (24") 
  Monitor-2: HDMI-0 res: 1920x1080 hz: 60 dpi: 96 size: 510x287mm (20.1x11.3") 
  diag: 585mm (23") 
  OpenGL: renderer: GeForce GTX 970/PCIe/SSE2 v: 4.6.0 NVIDIA 440.100 
  direct render: Yes 
  Device-1: Intel 8 Series/C220 Series High Definition Audio vendor: Gigabyte 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:8c20 
  Device-2: NVIDIA GM204 High Definition Audio vendor: Gigabyte 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:0fbb 
  Sound Server: ALSA v: k5.8.3-2-MANJARO 
  Device-1: Intel Ethernet I217-V vendor: Gigabyte driver: e1000e v: 3.2.6-k 
  port: f040 bus ID: 00:19.0 chip ID: 8086:153b 
  IF: eno1 state: down mac: <filter> 
  Device-2: Qualcomm Atheros AR93xx Wireless Network Adapter driver: ath9k 
  v: kernel port: d000 bus ID: 06:00.0 chip ID: 168c:0030 
  IF: wlp6s0 state: up mac: <filter> 
  Local Storage: total: 2.18 TiB used: 436.32 GiB (19.6%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda vendor: Western Digital model: WDS250G2B0A-00SM50 
  size: 232.89 GiB block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: 00WD scheme: GPT 
  ID-2: /dev/sdb vendor: Samsung model: SSD 850 EVO 250GB size: 232.89 GiB 
  block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s serial: <filter> 
  rev: 2B6Q scheme: GPT 
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
  ID-1: / raw size: 111.89 GiB size: 109.14 GiB (97.54%) 
  used: 65.79 GiB (60.3%) fs: ext4 dev: /dev/sdb2 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 8.80 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sdb3 
  System Temperatures: cpu: 26.0 C mobo: N/A gpu: nvidia temp: 27 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 49% 
  Processes: 258 Uptime: 23m Memory: 31.32 GiB used: 2.17 GiB (6.9%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 alt: 9 Packages: pacman: 1430 
  lib: 356 flatpak: 0 Shell: Bash v: 5.0.18 running in: konsole inxi: 3.1.05

Running pacmd list-sinks got me this, despite having Duplex running.

1 sink(s) available.
  * index: 19
        name: <alsa_output.pci-0000_00_1b.0.analog-stereo>
        driver: <module-alsa-card.c>
        state: SUSPENDED
        suspend cause: IDLE
        priority: 9039
        volume: front-left: 58982 /  90% / -2,75 dB,   front-right: 58982 /  90% / -2,75 dB
                balance 0,00
        base volume: 65536 / 100% / 0,00 dB
        volume steps: 65537
        muted: no
        current latency: 0,00 ms
        max request: 0 KiB
        max rewind: 0 KiB
        monitor source: 22
        sample spec: s16le 2ch 48000Hz
        channel map: front-left,front-right
        used by: 0
        linked by: 0
        configured latency: 0,00 ms; range is 0,50 .. 1837,50 ms
        card: 1 <alsa_card.pci-0000_00_1b.0>
        module: 7
                alsa.resolution_bits = "16"
                device.api = "alsa"
                device.class = "sound"
                alsa.class = "generic"
                alsa.subclass = "generic-mix"
                alsa.name = "ALC898 Analog"
                alsa.id = "ALC898 Analog"
                alsa.subdevice = "0"
                alsa.subdevice_name = "subdevice #0"
                alsa.device = "0"
                alsa.card = "0"
                alsa.card_name = "HDA Intel PCH"
                alsa.long_card_name = "HDA Intel PCH at 0xf3330000 irq 34"
                alsa.driver_name = "snd_hda_intel"
                device.bus_path = "pci-0000:00:1b.0"
                sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card0"
                device.bus = "pci"
                device.vendor.id = "8086"
                device.vendor.name = "Intel Corporation"
                device.product.id = "8c20"
                device.product.name = "8 Series/C220 Series Chipset High Definition Audio Controller"
                device.form_factor = "internal"
                device.string = "front:0"
                device.buffering.buffer_size = "352800"
                device.buffering.fragment_size = "176400"
                device.access_mode = "mmap+timer"
                device.profile.name = "analog-stereo"
                device.profile.description = "Analog Stereo"
                device.description = "Built-in Audio Analog Stereo"
                alsa.mixer_name = "Realtek ALC898"
                alsa.components = "HDA:10ec0899,1458a002,00100003"
                module-udev-detect.discovered = "1"
                device.icon_name = "audio-card-pci"
                analog-output-lineout: Line Out (priority 9000, latency offset 0 usec, available: yes)

                analog-output-headphones: Headphones (priority 9900, latency offset 0 usec, available: unknown)
                                device.icon_name = "audio-headphones"
        active port: <analog-output-headphones>

And at last, trying to run this sh from another post

while :
pacmd list-sinks | grep -E "name:|index:" | sed 's/<//g;s/>//g;s/_/ /g;s/alsa output.//g'
pacmd set-default-sink $CHOICE
echo "Your Audio Output has been set to $CHOICE"
echo "Press ctrl+C to exit."

And got this:
No PulseAudio daemon running, or not running as session daemon.
I’m not sure if KDE runs pulseaudio, maybe this is OK.
Sorry I’m new to this distros.

What’s the output of:

pulseaudio --check


Hello @Fabby, it returns nothing, tested it right after boot and after going to fix it via audio settings (selecting only input then reselecting duplex or stereo) I think it’s the same than unplugging and plugging the jack. Via Alsamixer, after selecting the “card” (it’s the onboard jack) I can see all the channels.

EDIT: trying other related issues if I execute pulseaudio -k seems to solve the problem. It’s a patch, not a solution.

huh? killing pulseaudio solves the problem? It must be set to restart automatically then.

  1. What’s the output of:

    ps aux | grep pulse
  2. would restarting pulseaudio at login be a solution for you?


From what I read in other post (sorry I can’t paste links for now) killing pulse audio restart ir automatically, that is why is working.

Now I’m in an odd situation because yesterday I added the command to the startup section in KDE and today I started the system to grab the output and I got this:

myuser    1490  0.2  0.0 762032 13092 ?        S<sl 08:33   0:00 /usr/bin/pulseaudio --daemonize=no
myuser    1510  0.0  0.0 238872  9352 ?        Sl   08:33   0:00 /usr/lib/pulse/gsettings-helper
myuser    2727  0.0  0.0   8852  2272 pts/2    S+   08:35   0:00 grep --colour=auto pulse

Then I proceded to disable the auto start to take a second output without being executed to check differences and got this

myuser    1466  0.7  0.0 499888 13120 ?        S<sl 08:37   0:00 /usr/bin/pulseaudio --daemonize=no
myuser    1488  0.0  0.0 238872  9580 ?        Sl   08:37   0:00 /usr/lib/pulse/gsettings-helper
myuser    2262  0.0  0.0   8852  2400 pts/1    S+   08:37   0:00 grep --colour=auto pulse

The really odd part is now it’s working without the need to add the kill in the autostart… Before applying that patch I installed pavucontrol and pavucontrol-qt but they didn’t solve the problem, I don’t think they are solving it now either.

pulseaudio should/must be daemonize? The important part is now audio is properly.
Now I can start solving weird issues like randomly not having middle click button in a wireless mouse.
Thanks a lot for your help, I’m learning a lot.

I’ve marked the below answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (I just want to avoid even more subjective opinions being posted and confusing you even more)

P.S. In the future, please mark a solution like this:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.