Dummy Output / no sound

Installed fresh Minimal Manjaro KDE.
I can’t see output device in settings, there’s only dummy output.
Output of inxi -Fazy

  Kernel: 5.15.65-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=b5cbdd18-aac7-44bd-8879-8223bb5b381f rw quiet
  Desktop: KDE Plasma v: 5.25.5 tk: Qt v: 5.15.5 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: MSI model: H61M-P31 (G3) (MS-7788) v: 1.0
    serial: <superuser required> BIOS: American Megatrends v: 2.7
    date: 01/10/2013
  Info: model: Intel Core i5-2500 bits: 64 type: MCP arch: Sandy Bridge
    gen: core 2 level: v2 built: 2010-12 process: Intel 32nm family: 6
    model-id: 0x2A (42) stepping: 7 microcode: 0x2F
  Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
    desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
    desc: 1x6 MiB
  Speed (MHz): avg: 2517 high: 2645 min/max: 1600/3700 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 2417 2: 2645 3: 2562
    4: 2446 bogomips: 26350
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT disabled
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: disabled, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
    vendor: Micro-Star MSI driver: i915 v: kernel arch: Gen-6
    process: Intel 32nm built: 2011 ports: active: VGA-1 empty: DP-1,HDMI-A-1
    bus-ID: 00:02.0 chip-ID: 8086:0102 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.4 compositor: kwin_x11 driver: X:
    loaded: modesetting alternate: fbdev,vesa gpu: i915 display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
    s-diag: 414mm (16.31")
  Monitor-1: VGA-1 model: Philips 196VL serial: <filter> built: 2012
    res: 1366x768 hz: 60 dpi: 85 gamma: 1.2 size: 409x230mm (16.1x9.06")
    diag: 469mm (18.5") ratio: 16:9 modes: max: 1366x768 min: 720x400
  OpenGL: renderer: Mesa Intel HD Graphics 2000 (SNB GT1) v: 3.3 Mesa 22.1.7
    direct render: Yes
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio
    vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
    chip-ID: 8086:1c20 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.65-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: no
  Sound Server-4: PipeWire v: 0.3.57 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: e000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp2s0 state: down mac: <filter>
  Device-2: TP-Link TL-WN822N Version 4 RTL8192EU type: USB driver: rtl8xxxu
    bus-ID: 2-1.5:5 chip-ID: 2357:0108 class-ID: 0000 serial: <filter>
  IF: wlp0s29u1u5 state: down mac: <filter>
  IF-ID-1: enp0s29u1u3 state: unknown speed: -1 duplex: half mac: <filter>
  Device-1: Samsung GT-I9070 (network tethering USB debugging enabled)
    type: USB driver: rndis_host v: kernel bus-ID: 2-1.3:7 chip-ID: 04e8:6864
    class-ID: 0a00 serial: <filter>
  Report: This feature requires one of these tools: hciconfig/bt-adapter
  Device-2: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB
    driver: btusb v: 0.8 bus-ID: 2-1.6:6 chip-ID: 0a12:0001 class-ID: e001
  Report: ID: hci0 rfk-id: 0 state: up address: N/A
  Local Storage: total: 703.77 GiB used: 8.13 GiB (1.2%)
  ID-1: /dev/sda maj-min: 8:0 type: USB model: USB Flash Memory
    size: 14.43 GiB block-size: physical: 512 B logical: 512 B type: SSD
    serial: <filter> rev: PMAP scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST500DM002-1BD142
    size: 465.76 GiB block-size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: KC48 scheme: MBR
  ID-3: /dev/sdc maj-min: 8:32 vendor: Western Digital
    model: WDS240G2G0A-00JH30 size: 223.58 GiB block-size: physical: 512 B
    logical: 512 B speed: 3.0 Gb/s type: SSD serial: <filter> rev: 0000
    scheme: MBR
  ID-1: / raw-size: 223.58 GiB size: 219.01 GiB (97.96%) used: 8.13 GiB (3.7%)
    fs: ext4 dev: /dev/sdc1 maj-min: 8:33
  Alert: No swap data was found.
  System Temperatures: cpu: 33.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 170 Uptime: 13m wakeups: 0 Memory: 7.47 GiB used: 2.03 GiB
  (27.2%) Init: systemd v: 251 default: graphical tool: systemctl Compilers:
  gcc: 12.2.0 clang: 14.0.6 Packages: pm: pacman pkgs: 1090 libs: 306
  tools: pamac Shell: Zsh v: 5.9 default: Bash v: 5.1.16 running-in: konsole
  inxi: 3.3.21

I installed sof-firmware and manjaro-pipewire
Any questions, suggestions, solutions?

1 Like

Onboard audio device Intel 6 Series/C200 Series Family High Definition Audio is using the correct driver snd_hda_intel. Additional sof-firmware drivers are not needed on a desktop system that does not have a built-in digital microphone array

‘Dummy Output’ in PulseAudio is only created when there are no ALSA (or Bluetooth) output sinks available
Replacing PulseAudio with PipeWire can resolve conflict between the two software sound servers, but cannot resolve issues in ALSA

Please post more information about ALSA

sudo alsa-info.sh --upload

--alsa-info.sh is not recognized option

just sudo alsa-info.sh --upload i guess.

(i can’t include links)
http:// alsa-project .org/db/?f=d993eb6babed4482b4fd165aa2e15b26ddb2afab

1 Like

any updates?

create the following file:
kate /etc/modprobe.d/audio.conf
and add there this line:
options snd-hda-intel model=auto index=0
save the file, reboot and test

Modprobe option to set card to index=0 number is not needed when there is only one card and it
is already assigned to slot 0

card 0: PCH [HDA Intel PCH], device 0: ALC887-VD Analog [ALC887-VD Analog]

Modprobe option model=auto is probably not needed as the onboard audio codec ALC887-VD appears to be detected and error free
Intel 6 Series/C200 Series Chipset Family High Definition Audio Controller

I suggest 2 changes for ALSA mixer control settings

  1. Turn off auto-mute mode

    amixer --card=0 sset 'Auto-Mute Mode' Disabled
  2. unmute audio control for rear line-out (green) jack

    amixer --card=0 sset 'Front' Disabled

I do not expect these 2 changes will resolve issue with dummy output in PipeWire, but it should be possible to test ALSA is working as expected

Use a music player configured to bypass PipeWire and play audio direct to ALSA.
(look for connections to: hw: 0,0 or front:CARD=HDA Intel PCH,DEV=0)

If audio is working for both front and rear audio jacks, the null audio issue precedes ALSA and must be in PipeWire or connection from PipeWire to ALSA

I installed gmusicbrowser and set everything. For the first time i had front and rear working.
But now
When I connect my headphones to rear jack, there’s sound
When I connect to front jack, it doesn’t work.
when I choose front: ... device i got this:

../gstreamer/subprojects/gst-plugins-base/ext/alsa/gstalsasink.c(889): gst_alsasink_open (): /GstBin:sink0/GstAlsaSink:alsa:
Playback open error on device 'front:CARD=HDA Intel PCH,DEV=0': No such device

i don’t understand what happened, rear jack works in player.
UPD: i got output device “Line out” when I connected to rear jack and sound is okay, but i need front one.

I didn’t mention ALSA mixer control for Headphone jack in previous post because it was set to 100% volume and unmuted and should work

Command 2 in my previous is not right and I don’t know how I missed an obvious error before posting. But how did audio to the Line Out rear jack socket get unmuted by a non-working command??

Please post full list of ALSA mixer controls to show current settings

amixer --card=0

Here it is:

Auto-mute is set to disabled (so 1st command worked)

But Headphone control is still shown with 0% level and muted [off]

Simple mixer control 'Headphone',0

  Front Left: Playback 0 [0%] [-64.00dB] [off]
  Front Right: Playback 0 [0%] [-64.00dB] [off]

This is the command I should have posted previously to raise level and unmute

amixer --card=0 sset 'Front' 80% unmute

gmusicbrowser is not a good choice for testing audio because it only allows ALSA to be selected and does not appear to have additional options to choose a specific ALSA output, so it may be trying to use PipeWire if that is set as default output

Check aplay -L to see list of ALSA outputs

If response shows default is set to PipeWire Sound Server
You need a different audio player that allows selection of outputs e.g. VLC, Audacious, Deadbeef
or use aplay or speaker-test commands in terminal

See links posted in this discussion for further information about ES8336 audio codec

default output is set to PulseAudio sound server
i want to admit, that I had sound on PhyOS (arch with custom dwm) in front and ubuntu systems.
speaker-test doesn’t give sound in front jack (but i remember how it did in gmusicbrowser)

The kernel configuration needs to include these two options


So i just need to wait for kernel to update?

If ALSA default output is PulseAudio sound server gmusicbrowser would still not be able to bypass the software sound server and play direct to ALSA device

speaker-test doesn’t give sound in front jack

Does audio play to rear jack?

Did you specify the device; format and channels in speaker-test? for example:

speaker-test -D hw:0,0 -f dat -c2 -l1

Did speaker-test command appear to work in terminal (playing pink noise to each channel) even if nothing was audible? or respond with an error message?

If command responds with an error advising unable to connect to ALSA device, try using speaker-test with the default PulseAudio device

speaker-test -D pulse -f dat -c2 -l1

And check if the audio stream is visible in audio controls even if it is not audible