DualShock 4 Bluetooth connection fails after USB is plugged in

I have a DualShock 4 that normally works fine through Bluetooth. However, after I connect it through USB, switch it off and try to connect wireless, the connection lasts for only a moment. When this happens, the light of the gamepad glows white for a few seconds, then goes off.

As a workaround, I can delete the device entry in blueman and pair it again (holding the PS and Share buttons on the controller), but I have to do this each time after I plug in the USB cable.

By the way, when I plug in the USB cable, I also get a Bluetooth notification asking for permission. The Arch Wiki suggests that this is when the device should be marked as trusted in bluetoothctl. I’ve already tried this, but it doesn’t fix the issue.

I’ve found the same issue reported for Fedora here and here last year. Seeing in one of the comments that a kernel update should fix it, I’ve tried several different kernel versions on Manjaro, including 4.19-LTS, 5.4-LTS, and 5.8. The results are the same.

You need to authorize the bluetooth connection. For me, when I plug into my computer, I can click on the notification and “Trust & Authorize” it.

There is a more complicated way to do it via bluetoothctl in the terminal… but I never remember what it is because it’s a pain.

Edit: Found the way to do it via terminal that I’ve used before. Still a WHOLE lot easier if you can just click it in the notification window like I do now.

https://wiki.gentoo.org/wiki/Sony_DualShock#Bluetooth

For me, when I plug into my computer, I can click on the notification and “Trust & Authorize” it.

Do you mean a dialogue window with buttons on it? Nothing like that appears for me, only a desktop notification. (I’m using i3-gaps with dunst.)


Edit: I’ve taken a look at the Gentoo Wiki page you linked. It turns out the line

[agent]Authorize service service_uuid (yes/no): yes

appears in bluetoothctl when I plug in the USB cable only if blueman is not running at the same time. This finally allows me to save the Bluetooth settings, so if I unplug the cable and connect wirelessly, it now works.

Still a WHOLE lot easier if you can just click it in the notification window like I do now.

Definitely. Maybe it’s time to replace blueman with something else.

Disclaimer: Had to PM @maxigaz this solution yesterday because the forums limited how many comments I can have per day as a “new user”… This worked for them. Copy and pasted my original post from archived forum.


OP uses dunst

My issue was solved by editing ~/.config/dunst/dunstrc

For dunst , these are called Actions.

in dunstrc , I added/edited:

[global]
show_indicators = true
dmenu = rofi -dmenu -p :dunst
mouse_left_click = do_action
mouse_middle_click = do_action
mouse_right_click = close_current
[shortcut]
history = ctrl+grave

dunst needs dmenu or an drop in replacement to be able to show action options. Manjaro Openbox uses rofi , which can act like drop-in dmenu replacement.

Added the history shortcut to make it easier to go back to select the notification in case it goes away too fast.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.