Dualbooting Windows 10 with hibernation in mind

Hi! New user here (generally in the desktop linux world), so please let me know if I something is not ok.

I have been planning moving to a Linux distribution for some time now, and a few days ago I finally started it.
The problem I have is that I can’t boot the Manjaro that I just installed.

A few basic things, some of which might be unimportant but better to clarify:
I have got the installation media for Manjaro KDE 21.0.7, and I’m running it with Ventoy from a USB drive.
Motherboard is an ASUS X470 one, of course with an UEFI, just for an estimation on how modern it is.
Secure boot is disabled, but CSM is on, more on that later.
Currently I have Windows 10 installed on an SSD, which I also want to use for my Manjaro installation. I have HDDs if really needed for e.g. an ESP partition.

An important note is that I have read [this](wiki . archlinux . org/title/Dual_boot_with_Windows#Disable_Fast_Startup_and_enable_hibernation), and I’m aware that since I want to be able to hibernate Linux or Windows any time and boot into the other, I’ll need a separate ESP partition from the one that Windows uses.

I’ve found [this guide](archived . forum . manjaro . org/t/howto-dual-boot-manjaro-windows-10-step-by-step/52668/) on the archived forum, and following it I theoretically already have an installation (512 MB EFI, 30 GB root, 20 GB home setup), but I cannot boot it. According to Windows Disk management, the 2nd ESP is there as you can see here:

But it turns out, that my UEFI’s boot menu (opened by F8 at boot time or from the setup itself) does not show an entry for the Manjaro installation (it’s interesting that it shows 2 entries for my SSD, but the first is clearly Windows, and the second is not working, though it’s probably very old and I don’t know what it might have been).
To try to fix this, I was following [this comment](archived . forum . manjaro . org/t/wiki-windows-10-manjaro-dual-boot-step-by-step/52668/9).
So after running the commands, I’ve ran efibootmgr -v again and saw that a new Manjaro entry appeared as the last entry (weird, man efibootmgr says -c should put new entries at the top). Rebooted to find that the F8 menu didn’t reflect the change, and booting the installer again and running efibootmgr -v showed that the new entry wasn’t there anymore.
The output of efibootmgr -v:
(sorry for the camera screenshot, Windows was hibernated and so I was unable to write to storage)

This is where I currently am. After reading these links (ArchWiki and Manjaro Forum links, from where I also read some other posts that were marked as related), I’m a bit confused about how the ESP is handled.

  • The ArchWiki states that the ESP, if a secondary is used, should be on a different disk.
  • The main guide I used for the manual partitioning part of the installation said that their solution won’t touch the ESP used by Windows (that’s correct, mountvol Z: /S and looking at contents of Z: I didn’t see any Manjaro or Linux related folders), but that guide made me make the 2nd ESP on the same drive where the first one resides, and implies that it should Just Work ™, but it doesn’t (in my environment).
  • Then others say that UEFI’s generally don’t search for a second ESP if they have found the first one, but as I remember none of them gave a better solution.
  • All the while Calamares seems to support the ‘2 ESP 1 disk’ setup without any warnings: it noticed that I made a 2nd ESP with it, and so it included the boot files in that ESP instead of the one that Windows uses. So, this again implies to me that this setup should work without problems, and also that I haven’t found others to be asking about issues like mine below the guide post.

So, first of all I would like to clear up my confusion about ESP detection. Then I want to find out if I did something wrong, my motherboard’s UEFI does not support 2 ESP’s on 1 disk, the MB’s it’s bootmgr store is corrupted, or if an UEFI upgrade would help, which I’m kind of afraid of after all the horror stories with modern MB’s breaking by an UEFI upgrade and long repair times that I can’t afford.
As I said, as a last resort I could install the 2nd ESP to an HDD, but I would rather have it on the SSD where Manjaro will be (and where Windows is)

An additional note is that I have CSM enabled in the UEFI. For some reason I need it to be able to select any boot option other than the Windows boot manager - if I disable it, the only option in the F8 boot menu will be the Windows bootloader.

final note:
It seems I can’t post images and links, so not sure what to do. For now just deleted the images, and broke the links so they can still be copied and fixed. I hope linking to this forum and the ArchWiki is not a problem :confused:

Try again using this guide:

1 Like

You can still post links as </> code (use the corresponding button after selecting your link to make it a ‘code’ piece as a workaround).


Oh, It’s very similar but newer. I think I have seen this already but thought it’s the exact same one that I linked.
I’ll go through it now, thank you!

Well, tried again following this and now it works. Thank you!

Not sure what did I do differently, though, so the conclusion for now is to try again a day later, in case I overlooked something.

I think I might have pressed F8 immediately after the reboot instead of waiting for it to boot to whatever it wants according to the BootOrder, and also I ticked the reboot checkbox on the finishing page of Calamares before closing it (though it didn’t initiate the reboot), but the only thing to do before reboot is to check if the BootOrder is correct, which was correct automatically, so not sure about it.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.