Dual screen not working


I am using Linux Manjaro on my laptop and have been using dual screens. When I woke up this morning it is no longer detecting additional screens. I have googled on similar issues, but they have not solved the case for me.

Here is some information about my system (tell if I need to post more):

  Kernel: 5.9.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 
  root=UUID=6b9378f0-2105-4d9f-8e21-ae5015488808 rw quiet udev.log_priority=3 
  Desktop: KDE Plasma 5.20.4 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Laptop System: Acer product: Nitro AN515-54 v: V1.30 serial: <filter> 
  Mobo: CFL model: Octavia_CFS v: V1.30 serial: <filter> UEFI: Insyde v: 1.30 
  date: 05/11/2020 
  ID-1: BAT1 charge: 55.3 Wh condition: 55.3/55.1 Wh (100%) volts: 17.3/15.4 
  model: PANASONIC AP18E5L type: Li-ion serial: <filter> status: Full 
  Info: 6-Core model: Intel Core i7-9750H bits: 64 type: MT MCP 
  arch: Kaby Lake note: check family: 6 model-id: 9E (158) stepping: A (10) 
  microcode: DE L2 cache: 12 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 62431 
  Speed: 4001 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 4001 2: 4001 
  3: 4001 4: 4001 5: 4000 6: 4001 7: 4000 8: 4000 9: 4001 10: 4001 11: 4000 
  12: 4000 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
Use of uninitialized value $working[3] in substitution (s///) at /usr/bin/inxi line 22314.
Use of uninitialized value $working[3] in substitution (s///) at /usr/bin/inxi line 22314.
  Device-1: Intel UHD Graphics 630 vendor: Acer Incorporated ALI driver: i915 
  v: kernel bus ID: 00:02.0 chip ID: 8086:3e9b 
  Device-2: NVIDIA TU106M [GeForce RTX 2060 Mobile] 
  vendor: Acer Incorporated ALI driver: N/A 
  alternate: nouveau, nvidia_drm, nvidia bus ID: 01:00.0 chip ID: 10de:1f15 
  Device-3: Chicony HD User Facing type: USB driver: uvcvideo bus ID: 1-5:4 
  chip ID: 04f2:b64f serial: <filter> 
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: modesetting 
  unloaded: intel alternate: fbdev,vesa display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP-1 res: 1920x1080 hz: 120 dpi: 142 size: 344x193mm (13.5x7.6") 
  diag: 394mm (15.5") 
  OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.3.1 
  direct render: Yes 
  Device-1: Intel Cannon Lake PCH cAVS vendor: Acer Incorporated ALI 
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci 
  bus ID: 00:1f.3 chip ID: 8086:a348 
  Sound Server: ALSA v: k5.9.16-1-MANJARO 
  Device-1: Qualcomm Atheros Killer E2500 Gigabit Ethernet 
  vendor: Acer Incorporated ALI driver: alx v: kernel port: 3000 
  bus ID: 07:00.0 chip ID: 1969:e0b1 
  IF: enp7s0 state: down mac: <filter> 
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: 3000 
  bus ID: 08:00.0 chip ID: 8086:2723 
  IF: wlp8s0 state: up mac: <filter> 
  IF-ID-1: docker0 state: down mac: <filter> 
  Local Storage: total: 476.94 GiB used: 88.19 GiB (18.5%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Micron model: 2200 MTFDHBA512TCK 
  size: 476.94 GiB block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
  lanes: 4 serial: <filter> rev: P1MA003 temp: 39.9 C 
  ID-1: / raw size: 476.64 GiB size: 468.16 GiB (98.22%) 
  used: 88.19 GiB (18.8%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2 
  ID-2: /boot/efi raw size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 312 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 66.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 308 Uptime: 5m wakeups: 1 Memory: 31.2 GiB used: 2.66 GiB (8.5%) 
  Init: systemd v: 247 Compilers: gcc: 10.2.0 Packages: pacman: 1324 lib: 413 
  Shell: Zsh v: 5.8 running in: konsole inxi: 3.2.01

Also getting this:

~ >>> sudo mhwd -r pci video-nvidia-440xx                                                                                                                  
[sudo] password for daniel: 
Error: config 'video-nvidia-440xx' is not installed!
~ >>> sudo mhwd -i pci video-nvidia-455xx                                                                                                               [1]
Error: config 'video-nvidia-455xx' does not exist!              

Any advice on how to solve this would be appreciated.

Thanks in advance,

You have to run:
sudo pacman-mirrors -f5 && sudo pacman -Syyu
and then
sudo mhwd -i pci video-nvidia

but since you have a laptop with hybrid gpu, you might want to take a look at that and install the hybrid driver.

I run the command but now after reboot I can’t even get into the computer any more. I get this error: Failed to start Simple Desktop Display Manager.

I am reading this post a post regarding this issue and there is a solution there saying that I should remove video-vesa since it has priority 0. I also have it with priority 0 but when I run the command sudo mhwd -r pci video-vesa it says “config video-vesa is not installed!” even though I can see it with the command mhwd -l -d.

Any idea how to solve this?

Best regards,

You better run
sudo mhwd -r pci video-nvidia

Is not installed, that is correct, don’t insist on that.
sudo mhwd -a pci nonfree 0300
will auto install the one is suited for your hardware.

I got back in now and it works to start, thanks! Although it still does not seem to find any other screens even though connected. I run the commands above and it went successfully.

I am under display configuration on system settings and I can only see my laptop screen there even though I have an external screen connected. When I connect it, it asks me to choose how I want the screen setup, but then it does not apply after it.

I wonder if the system also requires the video-modesetting installed too.
sudo mhwd -i pci video-modesetting

It says it is already installed but I did it with --force. Still seems to be the same issue though (rebooted after the command above). My friend told me that there are problems with Nvidia graphic cards and Linux. If there is any other information or if you have any other idea it would be greatly appreciated. Thanks for all the help so faar and happy new year:-)

Best regards,

I looked at another forum thread and saw an answer telling me to edit the nvidia.conf file. I tested this solution but now I can only see my external screen instead of the laptop screen. Any idea on how to edit this file so that it works on both? This was the answer:

Section "ServerLayout"
	Identifier "Layout0"
	Screen 0 "Screen0"
	Inactive "intel"
	InputDevice "Keyboard0" "CoreKeyboard"
	InputDevice "Mouse0" "CorePointer"

Section "Files"

Section "InputDevice"

	# generated from default
	Identifier "Mouse0"
	Driver "mouse"
	Option "Protocol" "auto"
	Option "Device" "/dev/psaux"
	Option "Emulate3Buttons" "no"
	Option "ZAxisMapping" "4 5"

Section "InputDevice"

	# generated from default
	Identifier "Keyboard0"
	Driver "kbd"

Section "Monitor"
	Identifier "Monitor0"
	VendorName "Unknown"
	ModelName "Unknown"
	HorizSync 28.0 - 33.0
	VertRefresh 43.0 - 72.0
	Option "DPMS"

Section "Device"
	Identifier "Device0"
	Driver "nvidia"
	BusID "PCI:1:0:0"
	VendorName "NVIDIA Corporation"
	Option "NoLogo" "1"
	#Option "metamodes" "nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"

Section "Screen"
	Identifier "Screen0"
	Device "Device0"
	Monitor "Monitor0"
	DefaultDepth 24
	SubSection "Display"
	Depth 24
	Option "AllowEmptyInitialConfiguration" "Yes"
	# Change to your resolution
	Monitor "1920x1080"

Section "Device"
	Identifier "intel"
	Driver "modesetting"
	BusID "PCI:0:2:0"
	Option "AccelMethod" "sna"
	Option "DRI" "3"

Section "Screen"
	Identifier "intel"
	Device "intel"

Section "Extensions"
	Option "Composite" "Enable"

Section "InputClass"
	Identifier "Keyboard Defaults"
	MatchIsKeyboard "yes"
	Option "XkbOptions" "terminate:ctrl_alt_bksp"

Best regards,

I think I have the same issue as OP. But I did notice some errors when upgrading earlier today. Here’s the log:

[2021-01-01T16:59:06-0300] [ALPM] upgraded manjaro-system (20210101-1 -> 20210101-3)
[2021-01-01T16:59:06-0300] [ALPM-SCRIPTLET] ==> Checking if graphic drivers need an update ...
[2021-01-01T16:59:06-0300] [ALPM-SCRIPTLET] ==> Maintaining video driver hybrid-intel-nvidia-455xx-prime
[2021-01-01T16:59:06-0300] [PACMAN] Running 'pacman -Rdd --noconfirm'
[2021-01-01T16:59:06-0300] [ALPM-SCRIPTLET] error: no targets specified (use -h for help)
[2021-01-01T16:59:06-0300] [ALPM-SCRIPTLET] ==> Installing Nvidia drivers for you ...
[2021-01-01T16:59:07-0300] [ALPM-SCRIPTLET] > Using config 'video-hybrid-intel-nvidia-prime' for device: 0000:01:00.0 (0300:10de:1f11) Display controller nVidia Corporation TU106M [GeForce RTX 2060 Mobile]
[2021-01-01T16:59:07-0300] [ALPM-SCRIPTLET] > Using config 'video-hybrid-intel-nvidia-prime' for device: 0000:00:02.0 (0300:8086:3e9b) Display controller Intel Corporation UHD Graphics 630 (Mobile)
[2021-01-01T16:59:07-0300] [ALPM-SCRIPTLET] > Installing video-hybrid-intel-nvidia-prime...
[2021-01-01T16:59:07-0300] [PACMAN] Running 'pacman --noconfirm --cachedir /var/cache/pacman/pkg --config /etc/pacman.conf --root / --needed -Sy nvidia-utils nvidia-prime lib32-nvidia-utils linux59-nvidia'
[2021-01-01T16:59:07-0300] [PACMAN] synchronizing package lists
[2021-01-01T16:59:07-0300] [ALPM-SCRIPTLET] Sourcing /etc/mhwd-x86_64.conf
[2021-01-01T16:59:07-0300] [ALPM-SCRIPTLET] Has lib32 support: true                                                                                               
[2021-01-01T16:59:07-0300] [ALPM-SCRIPTLET] Sourcing /var/lib/mhwd/db/pci/graphic_drivers/hybrid-intel-nvidia-prime/MHWDCONFIG                                    
[2021-01-01T16:59:07-0300] [ALPM-SCRIPTLET] Processing classid: 0300                                                                                              
[2021-01-01T16:59:07-0300] [ALPM-SCRIPTLET] Sourcing /var/lib/mhwd/scripts/include/0300                                                                           
[2021-01-01T16:59:07-0300] [ALPM-SCRIPTLET] :: Synchronizing package databases...                                                                                 
[2021-01-01T16:59:07-0300] [ALPM-SCRIPTLET] error: failed to update core (unable to lock database)                                                                
[2021-01-01T16:59:07-0300] [ALPM-SCRIPTLET] error: failed to update extra (unable to lock database)                                                               
[2021-01-01T16:59:07-0300] [ALPM-SCRIPTLET] error: failed to update community (unable to lock database)                                                           
[2021-01-01T16:59:07-0300] [ALPM-SCRIPTLET] error: failed to update multilib (unable to lock database)                                                            
[2021-01-01T16:59:07-0300] [ALPM-SCRIPTLET] error: failed to synchronize all databases                                                                            
[2021-01-01T16:59:07-0300] [ALPM-SCRIPTLET] Error: pacman failed!                                                                                                 
[2021-01-01T16:59:07-0300] [ALPM-SCRIPTLET] Error: script failed!
[2021-01-01T16:59:08-0300] [ALPM-SCRIPTLET] Warning: No device of class 0302 found!
[2021-01-01T16:59:08-0300] [ALPM-SCRIPTLET] Warning: No device of class 0380 found!
[2021-01-01T16:59:08-0300] [ALPM] transaction completed

After this, pacman continued with the upgrade, which is why I did not notice the error before rebooting and finding that I can’t use my external monitor anymore. Any help is appreciated, thanks.