Dual Monitor Setup Primary Monitor Problems

Hi there.

I’ve been looking around for solutions and couldn’t quite find someone with the same situation as I have.
I am running KDE Plasma in a dual monitor setup.

Most of the time it works fine, the problem is that my secondary monitor takes all the windows upon waking up from sleep,/hibernation, at boot or even after both displays timeout.

When powering up, my primary display shows the login screen (for a brief moment), and because my secondary screen is slower to power up, as soon as it starts displaying, everything switches to it.

After each login all of my windows that have been on my primary monitor switch to the secondary one.

Output of xrandr -q below

Screen 0: minimum 8 x 8, current 3840 x 1080, maximum 32767 x 32767
DVI-D-0 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 544mm x 303mm
   1920x1080     60.00 + 144.00*  119.98    99.93    59.94    50.00  
   1680x1050     59.88  
   1440x900      59.90  
   1280x1024     75.02    60.02  
   1280x720      59.94    50.00  
   1024x768     119.99   100.00    75.03    70.07    60.00  
   800x600      119.97   100.00    75.00    72.19    60.32    56.25  
   720x576       50.00  
   720x480       59.94  
   640x480      120.01    99.99    75.00    72.81    59.94    59.93  
DP-0 connected primary 1920x1080+1920+0 (normal left inverted right x axis y axis) 521mm x 293mm
   1920x1080     60.00 + 165.00*  144.00   119.98   119.88    59.94    50.00  
   1280x1024     75.02    60.02  
   1280x720      59.94    50.00  
   1024x768     119.99    99.97    75.03    70.07    60.00  
   800x600      119.97    99.66    75.00    72.19    60.32    56.25  
   720x576       50.00  
   720x480       59.94  
   640x480      119.52    99.77    75.00    72.81    59.94    59.93  
DP-1 disconnected (normal left inverted right x axis y axis)

The HDMI-0 Connection is my secondary display. And KDE successfully retains that my DP-0 Connection is my primary, but on every login it will still open all of my windows on the secondary display.

Any suggestions or help regarding this matter will be greatly appreciated

This doesn’t sound like a Manjaro problem. Maybe you should ask for support in the kde forums. It would be helpful to know if there is a different behaviour when running X11 vs Wayland.