Dual graphics laptop: Can't change brightness! (Gnome, Acer Predator 500, Nvidia Proprietary + Intel)

(Fairly new to Manjaro, fresh install on a new laptop)

Hitting brightness keys changes nothing about the physical brightness, but I get the notification that the brightness should be going up/down.
I tried changing acpi_backlight in /etc/default/grub to none, vendor, and later tried video, then running grub-mkconfig to save it, then restarting, which did nothing.
My issue with it being probably dual graphics related was mentioned in the arch documentation for backlights but I have been unable to find a solution/

inxi -Fxxz graphics output:

Graphics:
  Device-1: Intel TigerLake-H GT1 [UHD Graphics] vendor: Acer Incorporated ALI
    driver: i915 v: kernel arch: Gen-12.1 ports: active: eDP-1 empty: DP-1,DP-2
    bus-ID: 0000:00:02.0 chip-ID: 8086:9a60
  Device-2: NVIDIA GA104M [GeForce RTX 3070 Mobile / Max-Q]
    vendor: Acer Incorporated ALI driver: nvidia v: 520.56.06 arch: Ampere
    bus-ID: 0000:01:00.0 chip-ID: 10de:24dd
  Device-3: Chicony HD User Facing type: USB driver: uvcvideo bus-ID: 3-5:3
    chip-ID: 04f2:b6dd
  Display: x11 server: X.org v: 1.21.1.4 with: Xwayland v: 22.1.4
    compositor: gnome-shell driver: X: loaded: modesetting,nvidia
    alternate: fbdev,nouveau,nv,vesa dri: iris gpu: i915 display-ID: :1
    screens: 1
  Screen-1: 0 s-res: 4480x1600
  Monitor-1: HDMI-1-0 pos: right res: 1920x1080 dpi: 81 diag: 690mm (27.15")
  Monitor-2: eDP-1 pos: primary,left res: 2560x1600 dpi: 189
    diag: 406mm (15.97")
  API: OpenGL v: 4.6 Mesa 22.2.1 renderer: Mesa Intel UHD Graphics (TGL GT1)
    direct render: Yes

please provide us with all needed information otherwise it’s useless (which gui etc…)

inxi --admin --verbosity=7 --filter --no-host --width

second, switch to nvidia, you’re still on the iGPU of intel with its mesa-driver