Dual booting with Win 10 problems

Ok. So how can I add a boot option for Manjaro? Can I do sudo update-grub from the terminal?

Hi, I have installed Manjaro KDE alongside Win10 and I have to press F9 each time I like to run Manjaro. When I choose Manjaro the grub menu appears and I could choose to start between Manjaro or Windows.
I also run the command
efibootmgr
BootCurrent: 0002
Timeout: 0 seconds
BootOrder: 0001,3001,0002,0003,2001,2002,2003
Boot0001* Windows Boot Manager
Boot0002* Manjaro
Boot0003* Linpus lite
Boot2001* USB Drive (UEFI)
Boot2002* Internal CD/DVD ROM Drive (UEFI)
Boot3000* Internal Hard Disk or Solid State Disk
Boot3001* Internal Hard Disk or Solid State Disk
Boot3002* Internal Hard Disk or Solid State Disk
Boot3003* Internal Hard Disk or Solid State Disk

Do you think I have to change the order with efibootmgr or simply run update-grub?

I will very appreciate an answer.

I’m having the exact same problem as OP, but it seems you are not understanding it correctly.

What he means with

is that there’s no option to select grub during Boot options, but if you select “Boot from EFI partition”, you can follow the whole path and boot Grub into Manjaro.
My efibootmgr output is very similar to this:

with Manjaro not available, ergo not posible to select it in the boot order options.

This is totally unrelated. It is posible to open Grub, and it has Windows option, but it is not posible to select it as a boot device, unless going through the whole EFI path in the “Boot from EFI” option

@ippo

Understand. You do not have ‘manjaro’ listed in “efibootmgr”.
That’s bad. It may be a Lenovo issue as appeared in many other topics here.
But before we jump to that (though likely) , let’s give it another shot first.

Boot it up (your way, any way - I have a shorter way, but never mind now), and at terminal

sudo grub-install
sudo update-grub

Then verify again with

efibootmgr

If ‘manjaro’ is now listed and at top of the bootorder (It should).
Reboot.

If it does not boot up to Manjaro after reboot, come back here and we’ll review the next ‘unpleasant things’ we have to do.
Note: your ‘manjaro’ is again missing in ‘efibootmgr’ if you go boot back to Manjaro and check with ‘efibootmgr’
(and it’s a Lenovo thing, not a manjaro or linux thing)

But good luck.

[edit] -

  1. oh, if that fails and when you get back to us, this time provide at terminal
sudo efibootmgr -v

not just ‘efibootmgr’

You need to explain this. Is that from the install media or from your computer ‘bios’?
We get the impression it is from the computer.

  1. If computer is a HP, it may be ‘easier’ (relative to Lenovo) to fix it. But still quite a hassle.
    Let us know computer make and model.

Yes, just do

sudo efibootmgr -o 0002,0001,0003

and you’ll be fine. Good luck.

@Nekaze

I think you have a HP, but please confirm make and model.
Clarify in detail how you presently boot Manjaro.
I think you go to the computer bios, select the path to manjaro efi file and boot it.
If not correct, let us know.

See if this helps (modify to your computer …er… custom settings)

When booting up system, check bootsetup (F10?) if there is a uefi submenu with boot priority bootorder. Is there a “custom boot entry”? Click on it and see if it ask you to “enter path to file” (or something like that).

If there is, then we on to something. Reboot and go to bios setup (F9?), chose EFI-file, write down path after every click, to the directory \EFI\manjaro\grubx64.efi.

Reboot, and go to boot options F10(?).
move custom boot to the top of priorities and then typed in the exact path like \EFI\manjaro\grubx64.efi
Note use’’ instead of’/’ for directories and sub directories.
Save changes and reboot.

If it is different, see if this post can help.

And if it an Asus, this may help.
But usually, a

sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi

will be fine for other makes if there is an issue.

I’m not OP but I’ve explained this here, as I have the exact same issue:

In my case, the computer is an HP ay117cl



I’ve uploaded a couple of pictures that ilustrate my point. In the first, you can see boot selection menu and Grub not available to select in the boot order menu. However, selecting “boot from EFI file” option, and following the path, takes you to the EFI boot file where you can see and select Manjaro (picture 2). After doing this, you boot to Grub normally (picture 3) and can start Manjaro with no problems

Thanks for your reply, unfortunately I don’t have any “custom boot entry” on my UEFI setup, I believe this is only available on older HP models

What’s suggested here:

is what i usually do with all my other Linux distributions (Antergos, Ubuntu, Mint), and none of the have had any problem. But on Manjaro, the option just doesn’t appear.

While you were typing, I had a separate post to you.
I guessed you had a HP, and it is so.
Touble is, fromm what we see here, each HP has a different way in handling UEFI and see may above post if any can help. Setting a ‘custom path’ and then making it default is probably the way for your HP. It may be difficult to find out the bios process to do that. But please try all ways in your HP to see how to do that and make it ‘stick’.

Good luck

ps: I don’t have HP or Lenovo
(will never have, after all these issues, even if they cleaned it up )

@Nekaze
Try this as well.

[edit] - yes, there are at least 2 members here who tried everything, gave up finally and use legacy-boot (need to reinstall). Hope it don’t come to that. :slightly_frowning_face:

It appears this isn’t working either

I’d rather keep on using the “boot from efi” option than reinstalling or using legacy mode. I find it really odd that I have never encountered such problem with other linux distros, including Arch based Antergos

Interesting. Now, let’s see if we get each other right.
You are saying that in the same HP computer, booting up Arch and Antergos does not give you the same problem?

If so, how are you booting Manjaro (that fails - not that efi path thingy).
Are you using Arch or Antergos grub? (Because you cannot get Manjaro grub to appear - again, not that efi path thingy).

And how did you get Arch or Antergos to boot? Because I don’t see that (‘antergos’ or ‘arch’ bootentry in your ‘efibootmgr’ either.)

Can you please explain. It’s getting more confusing.

This is exactly what I am saying. I used Antergos some time ago, on the same PC, but had some trouble with it not being so stable. I loved Arch, and that’s why I decided to try Manjaro. I’ve now deleted every linux distribution I had, and clean installed Manjaro along with Windows10.

Im booting Manjaro by selecting the option on Grub after following that efi path thingy (as shown in the picture).

I got Antergos to work properly by just installing it using their tool, manually partitioning, etc, as with any Linux distro install. Everything went fine, and the only problem I found was Windows not showing on Grub, which was solved by a simple Grub update command.

[edit for clarification] I CAN get Manjaro grub to appear (by booting from the efi file), that’s the only Grub currently installed on my PC

Okay. thanks for the explanation. It’s important we understand.
But since (1) you do not have Arch or Antergos now (in the same HP computer) and (2) you cannot get Windows in their grub,

I guess that your windows is in UEFI and your Arch and Antergos was (were?) installed in bios-legacy as

(a) A bios-legacy grub cannot detect or boot a uefi windows.
(b) A uefi grub cannot detect or boot a bios-legacy windows.
© We don’t need efibootmgr to boot any bios-legacy OS.

If you want to put in more input into it, that will be welcome for furthering our understanding.
Cheers.

[EDIT]

Yes, understand - selecting a (an?) efi path to boot does not mean the bootentry is in the uefi firmware. It (boot/efi/EFI/manjaro/grubx64.efi) exists of course; just not in the computer system firmware. Chainloading that efi file will boot up core.efi and that will bring up the grub.cfg (as grub is multiboot compliant).

[EDIT]
Can you provide ?
sudo efibootmgr -v

I didn’t have it available just after installing, but after using grub update commands I could boot to Windows from Grub.

I’m not really sure about BIOS/UEFI stuff, but what I think is that every Linux distro and Windows10 I installed on this pc was on UEFI, since Legacy support is completely disabled on my PC, and I have never touched those options. Also, every installation process I did, I just used the default settings.

What I did (maybe it’s related) is to create a partition on my SSD for system (either Ubuntu, Antergos, or now Manjaro) and a partition on my HDD for /home directory. I switched from ubuntu to Manjaro, formated system partition and used the same /home partition for Manjaro (without formatting it). I have done this before when switching distros and had no trouble, but who knows maybe it’s related

I realized we do not have yours.
We had the others’ here. :grinning:

Sorry I just read that.

Here it is:

Timeout: 0 seconds
BootOrder: 0001,3001,2001,2002,2004
Boot0001* Windows Boot Manager HD(2,GPT,73fe23c6-70ef-470f-8e14-704729632e7d,0xfa000,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS…x…B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}…7…
Boot2001* EFI USB Device RC
Boot2002* EFI DVD/CDROM RC
Boot3001* Internal Hard Disk or Solid State Disk RC

Aha! You do not have ‘antergos’ or ‘arch’ in these either.
Note, these bootentries will remain even if we uninstalled or even if we delete their partitions.
Unless we specifically remove as follows
sudo rm -Rf /boot/efi/EFI/Antergos
sudo rm -Rf /boot/efi/EFI/Arch

And then
sudo efibootmgr -b xxxx -B
sudo efibootmgr -b yyyy -B

Or it may be there and your computer system just (like in Manjaro) cannot list these out in your firmware (but it will raise the issue how you can boot Arch or Antergos if they are not in the firmware either).

What’s
sudo ls /boot/efi/EFI/
sudo ls /boot/efi/EFI/Antergos (if there is)
sudo ls /boot/efi/EFI/Arch (if there is)
sudo ls /boot/efi/EFI/boot/

I forgot to add that I personally deleted the efi entries from windows, using diskpart tool, following this thread (the answer with 12 steps using diskpart) https://askubuntu.com/questions/429610/uninstall-grub-and-use-windows-bootloader

Ah… too bad.
Then that will remain a mystery to us. :slightly_frowning_face::joy:

Anyway, it’s interesting how that happens.
We’ll just have to wonder.
Cheers.

[EDIT]

That link you provide is for ‘mbr’ disks (msdos)
Your windows is UEFI

My error _ i read the first part. Not the second. Sorry.
I don’t do much things in windows (keeping it, just because it’s there, that’s the mountaineers’ excuse, why should that be acceptable and not in other cases? :rofl: )

Forum kindly sponsored by Bytemark