Dual-Booting/Installing Windows 10 on a Manjaro install

dual-boot
windows
manjaro

#1

Hey guys I am hoping to get some assistance installing Windows 10 as a dual boot on my machine. Apologies if there is already a thread for this somewhere, I searched for about 15 minutes trying to find one. I have been running Manjaro for a few months now and I love it, unfortunately I need a windows boot on my machine for my new reasearch project. Could anybody provide me with some assistance/tips/tricks on installing Windows 10 without ruining my current setup? I know it is a lot easier to install linux after windows. Should I just backup my current setup format the system and install windows 10 first to avoid the headache? Here is my current setup:
System: Host: piri Kernel: 4.4.52-1-MANJARO x86_64 (64 bit gcc: 6.3.1) Desktop: Xfce 4.12.3 (Gtk 2.24.31)
Distro: Manjaro Linux
Machine: Device: portable System: Dell product: Inspiron 5548 v: A02
Mobo: Dell model: 079JDM v: A00 UEFI: Dell v: A02 date: 12/04/2014
Battery BAT1: charge: 32.6 Wh 100.0% condition: 32.6/41.8 Wh (78%) model: SANYO DELL R0JM64CB status: Full
CPU: Dual core Intel Core i7-5500U (-HT-MCP-) cache: 4096 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9580
clock speeds: max: 3000 MHz 1: 2401 MHz 2: 2400 MHz 3: 2436 MHz 4: 2400 MHz
Graphics: Card-1: Intel HD Graphics 5500 bus-ID: 00:02.0
Card-2: Advanced Micro Devices [AMD/ATI] Opal XT [Radeon R7 M265] bus-ID: 04:00.0
Display Server: X.Org 1.19.2 driver: intel Resolution: 1920x1080@60.05hz, 1920x1080@60.00hz
GLX Renderer: Mesa DRI Intel HD Graphics 5500 (Broadwell GT2)
GLX Version: 3.0 Mesa 17.0.1 Direct Rendering: Yes
Audio: Card-1 Intel Wildcat Point-LP High Definition Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
Card-2 Intel Broadwell-U Audio Controller driver: snd_hda_intel bus-ID: 00:03.0
Sound: Advanced Linux Sound Architecture v: k4.4.52-1-MANJARO
Network: Card-1: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
driver: r8169 v: 2.3LK-NAPI port: 4000 bus-ID: 02:00.0
IF: enp2s0 state: down mac: 34:17:eb:8f:98:f8
Card-2: Intel Wireless 7260 driver: iwlwifi bus-ID: 03:00.0
IF: wlp3s0 state: up mac: cc:3d:82:1f:27:14
Drives: HDD Total Size: 960.2GB (14.7% used)
ID-1: /dev/sda model: PNY_CS1311_960GB size: 960.2GB
Partition: ID-1: / size: 863G used: 115G (15%) fs: ext4 dev: /dev/sda2
ID-2: swap-1 size: 18.42GB used: 0.00GB (0%) fs: swap dev: /dev/sda3
Sensors: System Temperatures: cpu: 54.0C mobo: N/A gpu: N/A
Fan Speeds (in rpm): cpu: 0
Info: Processes: 186 Uptime: 23:36 Memory: 2258.8/15967.0MB Init: systemd Gcc sys: 6.3.1
Client: Shell (bash 4.4.121) inxi: 2.3.8


#2


@gohlip is a very respected multi-boot scenario guy here, hopefully he’ll chime in for you,

if you backup your data then ya, that’s the apparent easiest way around this.
But, 1st question is:
Did you install Manjaro in uefi/gpt or MBR/Bios?, and/or as well, is Secure Boot disabled in your [uefi]/bios ?


#3

Thank you for the reply but, are you saying I shouldn’t try to install Windows 10 with Manjaro already installed? It seems to me that the link you posted is doing a Windows install, followed by a Manjaro install. I would like to install Windows without reinstalling Manjaro


#4

Far the easiest painless way of running windows on your rig is VirtualBox.

Windows is a bit annoying because it insist in being the first and at the top of the table - not very modest :slight_smile:


#5

well, you should always backup your important files anyway, and after that just, try n install Win 10, but please answer the other questions asked first.

?


#6

I currently do this when I need windows for simple windows things, however my research project is going to involve running pretty heavy 3d simulations on a windows box so I would prefer to not use a VM.


#7

@martinwallace
yes, but,

we gotta start somewhere? -so let’s start with the basics first.


#8

Sorry I was replying to other comment. I am pretty sure that I am installed with uefi/gpt

[marty@piri ~]$ parted /dev/sda print
WARNING: You are not superuser.  Watch out for permissions.
Model: ATA PNY CS1311 960GB (scsi)
Disk /dev/sda: 960GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size    File system     Name  Flags
 1      2098kB  317MB  315MB   fat32                 msftdata
 2      317MB   942GB  941GB   ext4
 3      942GB   960GB  18.4GB  linux-swap(v1)

#9

I see - you are a wise guy - only a few respond that way - as I said the problem with windows is it won’t install unless it is on the first partition even with GPT but I guess you already have found out.

But since a windows installation is a gigantic unpack operation from a wim file - I guess you could unpack the wim file to a gpt partition and add the boot info to the /boot/efi partition with the files from the boot/EFI folder on the installation DVD/ISO


#10

Sorry I didn’t mean to be a wise guy. Thanks for the reply, this sounds like it is above my skill level though. I will most likely just format then install windows followed by a fresh manjaro install.


#11

I may be wrong, but the above should be boot.esp, in your boot-flags of that efi partition, [type: EF00], instead of msftdata?
But anyway, I assume "Secure Boot"is disabled in your uefi/bios, aka “Other OS” ?

sry for chiming in here, but actually i didn’t know that, wow, so Win10 does this to any other existing uefi/gpt installation ?


#12

Yes when I run

sudo bootctl status
File system "/boot/efi" has wrong type for an EFI System Partition (ESP).

Sorry I am a newbie, some off this stuff is over my head.


#13

It was a kudo not a pun - I do not have english as my first


#14

Yep - unless windows get first row - you cannot install it - I have tried a couple of times - but I might change or have changed but I doubt it.


#15

just run gparted, and change that “msftdata” Parttion --> Manage Boot flags -. to boot, and esp


#16

There we go.

Yes secureboot is disabled.

[marty@piri ~]$ sudo bootctl status
Using EFI System Parition at /boot/efi.
System:
Firmware: n/a (n/a)
Secure Boot: disabled
Setup Mode: user

Loader:
Product: n/a
Partition: n/a
File: └─n/a

Boot Loader Binaries:
ESP: /dev/disk/by-partuuid/5e9308cc-ed1c-43c5-bf40-9e6113820717
systemd-boot not installed in ESP.
File: └─/EFI/BOOT/bootx64.efi

Boot Loader Entries in EFI Variables:
Title: PNY
ID: 0x0001
Status: active, boot-order
Partition: /dev/disk/by-partuuid/5e9308cc-ed1c-43c5-bf40-9e6113820717
File: └─EFI/boot/bootx64.efi


#17

ok, well that’s good to know, that M$ is as evil as it always has been. :wink:


#18

so there you go,
Linux can dual-boot with anything, whereas Windows just shoots everything away first, then asks questions after. :wink:


#19

Thanks for all of the replies @scjet and @fhdk. I am just going to backup all of my stuff then attempt a windows install overtop and see how it goes. Otherwise I will wipe -> install windows -> install manjaro again.

Believe me I wouldn’t using Windows if I had a choice. Almost refused the project because of it lol…


#20

well hopefully Win 10 will oversee your uefi “boot,esp” parttion and not over-write it and everything else, but ya, we probably both know Windows will not do that, lol.
but please, after you backup data and try this, let us know.
oh and btw, latest downloadable Win 10 iso is ver. 1607, I think, so, if you got the keys, try the latest.