Dual boot with Windows 10 on a separate drive and Legacy/UEFI issues

Hey everyone!
So, my setup is the following:

1HDD (sda) with Windows 10 installed in UEFI mode
1SSD (sdb) with Manjaro installed in legacy mode (99% sure).

I thought I installed Manjaro in UEFI mode, since during installation I created the EFI partiton, I have /boot/efi folder mounted, flagged as boot and esf; but apparently I haven’t.

It must be in legacy mode since:

  • when I do sudo efibootmgr -v in the terminal I get:
    EFI variables are not supported on this system.
  • I can’t find any /sys/firmware/efi folder in my system
  • If I disable CSM in BIOS settings I cannot boot from Manjaro.

So, my problem is that os-prober is unable to find the Windows drive, so I cannot dual boot with GRUB. This is due to the fact that I have the two systems installed one in legacy the other in UEFI mode, correct me if I’m wrong.

Now my question is, what is the best solution to this? Should I reinstall Windows 10 in BIOS/Legacy (GPT or MBR?) or reinstall Manjaro in UEFI mode (GPT or MBR and how do I do it?)?
The main OS is Manjaro, Windows is only used VERY seldom for some specific things, so I would like to have Manjaro as in the best configuration as possible.

I am not very fond of having UEFI, secure boot enabled and CSM disabled, but I am not an expert and maybe I’m wrong, but before reinstalling anything I would like to have some more information from you.

Thanks for your help!

Please see response #2 here:

1 Like

Wow, that was a fast reply!
I have read that thread, in the second response it suggests to reinstall one of the two systems.
My question still is, what is the preferrable setting, Dual boot both systems in Legacy or UEFI?
And in case of reinstalling Manjaro, how do I make sure that it is installed in UEFI?

LAST EDIT: I came here too late, topic is already closed, thanks to @Fabby and @jrichard326 for your help, I’ve managed to fix the problem with your advices.

Just a heads up: as I’ve read somewhere else, to be sure not to incurr in any problems as mine, if you want to install in UEFI mode, go to BIOS and check that CSM mode is disabled and only UEFI enabled. In this way you’ll be sure that the systems you install will use UEFI mode.
In my case I had CSM enabled and this made Manjaro install itself automatically in BIOS mode, even if I was creating the EFI partition (which made me think I had it installed in UEFI mode, but it wasn’t).

No one can answer that but you as you are the owner of the system and it depends on your UEFI environment.

  • Recent UEFI firmware: (<2 years): keep UEFI
  • Old or unsupported UEFI firmware: Go BIOS / CSM!


Therefore, I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back to your question after your issue has been solved and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.