Dual boot with Windows 10 + Manjaro doesn't show up a grub menu

You are doing it wrong …place usb first and after push key maybe is F11 to select option to boot


If you doesnt place stick usb first you will not see this option to start in usb uefi mode

2 Likes

It would be helpful if you tell us if you’re able to boot into Windows 10. Just go to your boot settings and change the first priority to Windows 10. If you’re able to boot into Windows 10, then let me know I will guide you further.

2 Likes

I got it right this time, thanks to XtyM. The secret was the Flash disk must be plugged in before the bios loads. I was trying to set the bios priorities first and then plug in the flash disk. After I just kept both of my LiveUSB in place (Windows and Manjaro) I completed my dual boot successfully, both in UEFI.

Thank you! :hugs:

BIOSes continue to amaze me. When I realized I had to do that my BIOS it was because the usb drive didn’t show as an option in the boot order list unless it was plugged in. I’m amazed by your experience with your bois because I’m surprised it even showed up as option in your bios yet it forced you to have it plugged in before switching the order anyway. That’s crazy. Glad you got it resolved.

1 Like

Currently, whenever I boot my PC, it straight loads Windows 10 without popping grub or any other OS selection menu, unless I press F11 during boot time, of course.

Now, is there any way I could boot straight to Manjaro (without displaying any grub menu), unless I press F11 in case I’ll need Windows? :thinking:

I suspect you need to change the boot order in your bios so manjaro is ahead of the windows bootloader. (this may cause grub to show a menu of which OS to boot but at least it won’t go straight to windows )

1 Like

It’s quite easy. First you open up your BIOS settings. You can look up the function key by looking up on the internet or it will be shown in the Boot splash screen. Once you’re in BIOS, open the ‘Boot’ tab and select first priority to Manjaro.

Actually, for this I am 100% sure Click BIOS 5 doesn’t have any Boot OS Priority. Their boot menu is related only to different partition and different memory devices. Both of my OS are installed on the same SSD, so I have just one selection. I was hoping I could do it from my Windows 10, at least.

EDIT: The first sentence may be misleading, see the link below.

Hmm ok. If it’s an old bios that only has boot order for device not bootloader the only other thing I can of is to verify that secure boot and fast startup have been disabled. (especially fast startup) Aside from that maybe someone else has an idea.

It’s a brand new bios (Click BIOS 5), secure boot is disabled by default and fast startup is also disabled.

Well that’s surprising. LOL

Anyway I’m sorry but I don’t know. Just wait someone else probably does.

@madjoe
At this stage, I take it that you can boot into windows in uefi
and now you can boot into manjaro using F11 but it is booted in bios-legacy.
Stop me now if that is not the case.
You have not found a way to boot the liveusb in uefi, that is the only problem. Am I right?

If above is correct, let’s try this.
Boot into manjaro (F11 ~ bios-legacy)

  1. Confirm that it is indeed bios-legacy. At terminal
test -d /sys/firmware/efi && echo UEFI || echo BIOS

Tell us what is the output. Either way continue below.

  1. Reconfirm that you still have entry in fstab
UUID=4C4A-0D65                            /boot/efi      vfat    defaults,noatime 0 2

and “findmnt /boot/efi” shows

/boot/efi /dev/nvme0n1p2 vfat   xxxx, xxxx, xxxxx ~~~ ~~~~ 

If not, do not proceed. Stop here.

  1. At terminal do the following…(please copy and paste carefully - watch out for the apostrophes in last command)
sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck --debug
sudo update-grub
sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi
sudo efibootmgr -c -d /dev/nvme0n1 -p 2 -L "manjaro" -l "\EFI\Manjaro\grubx64.efi"
  1. Now since you only have manjaro and windows, when you reboot, you might get to a black screen and nothing seems to happen (that’s because of our grub), you will see no grub menu.
    Press ‘esc’ key when screen is black. Or if you happen to press too late, wait for a while (~ 2 mins) and see if manjaro boots. Later on, let us know if you want to see the grub screen; we can fix that, but later, now we want to get this done.
  2. If/When booted, confirm again that you manjaro is now in uefi using the same command
test -d /sys/firmware/efi && echo UEFI || echo BIOS

Tell us what is the output now.

Good luck. Cheers.

ps: It’s late here. I’ll respond tomorrow when you reply.

3 Likes

Let me stop you… lol So, I can boot Windows and Manjaro in UEFI.

$ test -d /sys/firmware/efi && echo UEFI || echo BIOS
UEFI

The only thing left is actually to be able to boot Manjaro as a default and only if I press F11 optionally to boot Windows. I still don’t know if this is doable with my current setup.

So does that mean the initially problem has been solved?

This seems to be a different issue from the original listed above. I will suggest you create a new topic or research the answer to this.

Yes, the main issue has been solved.

Sure. Moving my related issue here:

Solved

m-i-s-100

please :wink:

But I already marked with post #21 as Solved.

1 Like

Sorry for that :slight_smile: ,
I’m Blind because it is so often forgotten. :slight_smile:

Morning. So you now cannot set manjaro uefi as default boot through your bios.
You want manjaro boot to be default and both are now booted in uefi.

At manjaro terminal

efibootmgr

You should get outout for efiboot-entries of both windows and manjaro
say xxxx is for manjaro and yyyy for windows
Do

sudo efibootmgr -o xxxx,yyyy

There are other (firmware) entries listed, you do not need to list them all and there’s no need to include them in the command.
If in doubt provide output of ‘efibootmgr’

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark