Dual Boot with Win10 - Manjaro Boot Drive on Win10 Corrupted?

Some months ago I put together a new build, installed Win10 to the m.2 drive and Manjaro to a SATA SSD. Everything worked fine for months - system boots to the grub menu, I choose which O/S to boot to…everything works. However, I always wondered about the drive that was created in Win10 that contains one folder named “EFI” and under that, two subfolders: “boot” and “Manjaro”. I was concerned that this drive was ‘exposed’ via Win10 and might get into trouble. I renamed it “Manjaroboot” and set it as drive L:. Again, all was working fine until recently. I noticed that the Userbenchmarks tool tried to write to that drive (and in fact created a folder there). Now, when I try to boot to Manjaro from grub, I get all sorts of problems, from black screens, to frozen startup splash screens, to a desktop with no mouse, etc., depending on which of the fallback options I choose from grub. In any case, none of them work properly, and though I can boot to Win10, I can no longer boot to Manjaro except in this terribly crippled way.

So, I’m wondering if a) this Manjaroboot drive has been corrupted in some way? b) can that drive be hidden or locked so Win10 never tries to write to it (or allow it to be written to)? and c) is there a way to fix my corrupted Manjaro install without completely re-installing the Linux O/S?

Thanks for any insight.

Hello @mxcrowe :wink:

  1. Possible…
  2. yes, flag it with hidden
  3. reinstall grub

If you have questions, just ask.

Yes, so marking that Win10 partition as hidden should work…hopefully, no Win10 apps will then see the drive and try to access it. However, I’m not sure re-installing grub is going to help, since grub appears to be working properly. It’s Manjaro itself that seems to be screwed up somehow - just enough so that it tries to boot, even gets to the desktop sometimes, but then just hangs there, with no mouse or activity. I either have to re-install Manjaro entirely, or find some way to boot into a command window where I can try to do a full update, which might fix whatever is corrupted.