Dual boot windows 10

Acer laptop, single SSD.

Prior to windows 10 april feature update (working/functional):
-boots directly to windows 10 (no boot menu/user intervention)
-F12 (efi menu) at boot, gives two options windows/manjaro (see image):

Following feature update, the second option (manjaro) failed with grub recovery, unknown filesystem.
I did the minimum:
set prefix=(hd1,gpt6)/boot/grub; insmod normal; normal;
result: booted to manjaro. However, upon restart F12 menu has only the windows option.

Booted from usb (discover feature update re-enabled fast startup which intially prevented this…)

Discover efi partions from live home menu (see image):
efidetect

I’ve only tried the ‘manjaro/grubx64’ option, which boots via grub fine.

In manjaro:
sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck

update-grub

Generating grub configuration file ...
Found background: /usr/share/grub/background.png
Found linux image: /boot/vmlinuz-4.17-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-4.17-x86_64.img
Found initrd fallback image: /boot/initramfs-4.17-x86_64-fallback.img
Found linux image: /boot/vmlinuz-4.14-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-4.14-x86_64.img
Found initrd fallback image: /boot/initramfs-4.14-x86_64-fallback.img
Found Windows Boot Manager on /dev/sda2@/EFI/Microsoft/Boot/bootmgfw.efi
Found memtest86+ image: /boot/memtest86+/memtest.bin
done

Restart, but no manjaro in F12 menu.

I’ve not tried chroot option to reinstall grub, is that recommended next.
Any suggestions how to get my F12 menu to display manjaro as previously?

additional info:

gparted(image):


Shamefully i don’t know why i added that boot flag to the root part on first install, although it looks like the boot went to sda2 as i intended. It would boot fine from F12 anycase…

fdisk -l

Disk /dev/sda: 232.9 GiB, 250059350016 bytes, 488397168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 68C9D8C0-11AA-11E8-BBE4-9828A600336C

Device         Start       End   Sectors  Size Type
/dev/sda1       2048   1024007   1021960  499M Windows recovery environment
/dev/sda2    1024008   1228815    204808  100M EFI System
/dev/sda3    1228816   1261591     32776   16M Microsoft reserved
/dev/sda4    1261592 209937003 208675412 99.5G Microsoft basic data
/dev/sda5  209938432 210976767   1038336  507M Windows recovery environment
/dev/sda6  210978816 252921855  41943040   20G EFI System
/dev/sda7  252921856 305350655  52428800   25G Linux filesystem
/dev/sda8  305350656 488396799 183046144 87.3G Microsoft basic data

lsblk -f

NAME   FSTYPE LABEL    UUID                                 MOUNTPOINT
sda                                                         
├─sda1 ntfs   Recovery 1E18979618976C11                     
├─sda2 vfat            6299-3240                            /boot/efi
├─sda3                                                      
├─sda4 ntfs            E2B69C17B69BEA75                     
├─sda5 ntfs            6AAA3FEFAA3FB683                     
├─sda6 ext4   root     fc78c783-d447-4b7e-a61a-a4e12ee0710a /
├─sda7 ext4   home     686e10cc-b4dc-4aba-9ee5-462860135b7c /home
└─sda8 ntfs   data     349EEE827CCCD419

fstab efi uuid matches above boot/efi

efibootmgr -v

BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0001,2001,2002,2003
Boot0000* USB HDD: Generic Flash Disk	PciRoot(0x0)/Pci(0x14,0x0)/USB(1,0)/HD(2,MBR,0xd389a378,0x350b6c,0x2000)RC
Boot0001* Windows Boot Manager	HD(2,GPT,11d4d926-8480-4ffc-8fd2-2e4d19071d48,0xfa008,0x32008)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}....................
Boot2001* EFI USB Device	RC
Boot2002* EFI DVD/CDROM	RC
Boot2003* EFI Network	RC

seems like the same issue here, even tho have different manifestations

and this might help

1 Like

While following the link (2nd one) boddancovaciu provided, don’t forget to do the 2 “UEFI - additional commands” at end of step 6.
sudo cp /boot/grub/x86_64-…
sudo efibootmgr -c -d /dev/sd…

Let us know what computer make and model as per the 4th post there.

Thanks for the guides.
Acer nitro 5, Nitro AN515-51.
Booted via efi, manjaro release has only one line manjaro linux.
findmnt /boot/efi

TARGET    SOURCE    FSTYPE OPTIONS
/boot/efi /dev/sda2 vfat   rw,noatime,fmask=0022,dmask=0022,codepage=437,iochars

sda2 as with gparted image.
following the two extra uefi commands:
sudo efibootmgr -c -d /dev/sda -p 2 -L “manjaro” -l “\EFI\Manjaro

\grubx64.efi”
[sudo] password for darren: 
BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0002,0001,2001,2002,2003
Boot0000* USB HDD: Generic Flash Disk
Boot0001* Windows Boot Manager
Boot2001* EFI USB Device
Boot2002* EFI DVD/CDROM
Boot2003* EFI Network
Boot0002* ࠜmanjaroࠝ

No luck, no F12 manjaro option.

For my reference;
Should i of made a separate efi fat32 partition for grub when i first installed manjaro?

You shouldn’t need to go F12 for manjaro entry.
A simple reboot should do without pressing any F12 key.
However, I suspect something else is amiss.
As per the last post on the link…

UEFI - if problem persists.,provide…

efibootmgr -v
sudo parted -l
sudo blkid
findmnt -s
findmnt /boot/efi
note: ‘parted -l’ --> small ‘L’ and provide information of all disks. 

Some you’ve provided, but it’s okay to do again with all above. It will be clearer what that ‘something amiss’ is.

ps: note again if at ‘efibootmgr’ , the entry ‘manjaro’ has gone missing again when you reboot.
Also, why is there a ’ ’ (surrounding manjaro) at Boot0002* ࠜmanjaroࠝ
Can you do again the 2 commands. Please type carefully.

@Darren85a

I really need to log off now. Won’t be on for at least 4 hours. But I’ll be back. [1]
If @bogdancovaciu or @petsam can fill in meantime, that’ll be great.
Good luck

[1]

1 Like

No rush, i can boot in from usb fine. Thanks for the support.

I don’t know why the symbols surround manjaro from that command.
I also don’t know why update-grub lists manjaro as vmlinux.
Are you suggesting that without pressing F12 we should go straight to grub? because that never happened before when it booted straight to windows login (no menu), i could only get to manjaro via F12. Perhaps i made an error during install, that has only now came up to bite me…(i installed windows 10 first, then manjaro).

efibootmgr -v

BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0002,0001,2001,2002,2003
Boot0000* USB HDD: Generic Flash Disk	PciRoot(0x0)/Pci(0x14,0x0)/USB(1,0)/HD(2,MBR,0xd389a378,0x350b6c,0x2000)RC
Boot0001* Windows Boot Manager	HD(2,GPT,11d4d926-8480-4ffc-8fd2-2e4d19071d48,0xfa008,0x32008)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}....................
Boot0002* ࠜmanjaroࠝ	HD(2,GPT,11d4d926-8480-4ffc-8fd2-2e4d19071d48,0xfa008,0x32008)/File(ࠜEFIManjarogrubx64.efi)
Boot2001* EFI USB Device	RC
Boot2002* EFI DVD/CDROM	RC
Boot2003* EFI Network	RC

sudo parted -l

Model: ATA Samsung SSD 850 (scsi)
Disk /dev/sda: 250GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size    File system  Name                          Flags
 1      1049kB  524MB  523MB   ntfs         Basic data partition          hidden, diag
 2      524MB   629MB  105MB   fat32        EFI system partition          boot, esp
 3      629MB   646MB  16.8MB               Microsoft reserved partition  msftres
 4      646MB   107GB  107GB   ntfs         Basic data partition          msftdata
 5      107GB   108GB  532MB   ntfs                                       hidden, diag
 6      108GB   129GB  21.5GB  ext4                                       boot, esp
 7      129GB   156GB  26.8GB  ext4
 8      156GB   250GB  93.7GB  ntfs                                       msftdata

sudo blkid

/dev/sda1: LABEL="Recovery" UUID="1E18979618976C11" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="68c9d8c1-11aa-11e8-bbe4-9828a600336c"
/dev/sda2: UUID="6299-3240" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="11d4d926-8480-4ffc-8fd2-2e4d19071d48"
/dev/sda3: PARTLABEL="Microsoft reserved partition" PARTUUID="68c9d8c3-11aa-11e8-bbe4-9828a600336c"
/dev/sda4: UUID="E2B69C17B69BEA75" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="68c9d8c4-11aa-11e8-bbe4-9828a600336c"
/dev/sda5: UUID="6AAA3FEFAA3FB683" TYPE="ntfs" PARTUUID="10faf14f-3db7-4052-84a9-7897436bab6f"
/dev/sda6: LABEL="root" UUID="fc78c783-d447-4b7e-a61a-a4e12ee0710a" TYPE="ext4" PARTUUID="3d9c952b-7d3b-4ac0-adc3-75730d52dc27"
/dev/sda7: LABEL="home" UUID="686e10cc-b4dc-4aba-9ee5-462860135b7c" TYPE="ext4" PARTUUID="e1a1f960-7213-4bf0-95e1-1ed108f87f78"
/dev/sda8: LABEL="data" UUID="349EEE827CCCD419" TYPE="ntfs" PTTYPE="dos" PARTUUID="52384fe0-abf3-4934-a4e8-910def4883d6"

findmnt -s

TARGET    SOURCE                                    FSTYPE OPTIONS
/boot/efi UUID=6299-3240                            vfat   defaults,noatime
/         UUID=fc78c783-d447-4b7e-a61a-a4e12ee0710a ext4   defaults,noatime,discard
/home     UUID=686e10cc-b4dc-4aba-9ee5-462860135b7c ext4   defaults,noatime,discard
/tmp      tmpfs                                     tmpfs  defaults,noatime,mode=1777

findmnt /boot/efi

TARGET    SOURCE    FSTYPE OPTIONS
/boot/efi /dev/sda2 vfat   rw,noatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro

Please notice the “smart quotes”. This may be the problem.
Make sure you don’t print them on the next try with the same command.
Check your keyboard layout.

Note: I copied/pasted them on a text editor and they are NOT the “code compatible” quotes to use.

1 Like

I think @petsam is onto it …

1 Like

Good spot, the commands output has normal characters now (i naively copy/paste from the forum).
However, the problem persists, no boot option for manjaro.

This is like it is not seen from UEFI.
You need to re-create it

sudo efibootmgr -c -d /dev/sda -p 2 -L "manjaro" -l "\EFI\Manjaro

and then make the manjaro entry first in order with a similar to this:

sudo efibootmgr -o 0002,0001,0000

I understood the first time, you solved the odd characters, the commands output is now ok.
But the main problem, boot issue…

fyi

BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0002,0001,2001,2002,2003
Boot0000* USB HDD: Generic Flash Disk
Boot0001* Windows Boot Manager
Boot2001* EFI USB Device
Boot2002* EFI DVD/CDROM
Boot2003* EFI Network
Boot0002* manjaro

You mean you only have Windoz entry?
Have you run this?

sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi

and verified you have this
/boot/efi/EFI/boot/bootx64.efi

solved, when i went back to correct the quotes i forgot to change the partition number…my apologies.
As bogdancovaciu first offered the correct place to look i will mark that solution.
Thank you for your patience petsam and gohlip.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.