Dual boot Windows 10 and Manjaro Kde

Hello EveryBody, I want to learn and understand Linux. I decided to install Manjaro KDE from the guide provided on my laptop dell xps 13. Everything went on smoothly until I rebooted and then only Windows boot option is present. NO GRUB screen and in the UEFI boot also no entry for Manjaro. I did the same installation at least 5 times but still no Dual boot. I need the windows 10 also, so i cannot affford to lose this partition. Can Anyone please help me solve this problem so as to dual boot. Thx in advance
[manjaro@manjaro ~]$ efibootmgr
BootCurrent: 0003
Timeout: 2 seconds
BootOrder: 0000,0001,0003
Boot0000* Windows Boot Manager
Boot0001 UEFI: PC300 NVMe SK hynix 512GB, Partition 1
Boot0002* Manjaro
Boot0003* UEFI: SanDisk Cruzer Blade 1.26, Partition 1

the command for lsblk give me this
[manjaro@manjaro ~]$ lsblk
loop0 7:0 0 27.5M 1 loop /run/miso/sfs/livefs
loop1 7:1 0 620.5M 1 loop /run/miso/sfs/mhwdfs
loop2 7:2 0 1.7G 1 loop /run/miso/sfs/desktopfs
loop3 7:3 0 667.8M 1 loop /run/miso/sfs/rootfs
nvme0n1 259:0 0 476.9G 0 disk
├─nvme0n1p1 259:1 0 500M 0 part
├─nvme0n1p2 259:2 0 128M 0 part
├─nvme0n1p3 259:3 0 119.7G 0 part /run/media/manjaro/WINDOWS
├─nvme0n1p4 259:4 0 920M 0 part
├─nvme0n1p5 259:5 0 244.1G 0 part /run/media/manjaro/Vick-1
├─nvme0n1p6 259:6 0 818M 0 part
├─nvme0n1p7 259:7 0 12G 0 part
├─nvme0n1p8 259:8 0 1.1G 0 part
├─nvme0n1p9 259:9 0 512M 0 part
├─nvme0n1p10 259:10 0 7.8G 0 part
├─nvme0n1p11 259:11 0 39.1G 0 part /run/media/manjaro/fdeac18e-ac7a-4a73
└─nvme0n1p12 259:12 0 50.3G 0 part /run/media/manjaro/789e613a-3d3c-4e84

Note that the nvmeOnp9 is the boot partition and nvmeOnp10 is the LinuxSwap nvmeOp11 is the root and nvmeOp12 is the home.

Could you please do a efibootmgr -v in order to have more verbosity ?
You may want to change the bootorder to boot on Manjaro, like so :

efibootmgr --delete-bootorder
efibootmgr --bootorder 0002,0000,0001,0003

efibootmgr with more verbosity gives me this

[manjaro@manjaro ~]$ efibootmgr -v
BootCurrent: 0003
Timeout: 2 seconds
BootOrder: 0000,0001,0003
Boot0000* Windows Boot Manager HD(1,GPT,db8fea2b-309c-44c5-9932-f3021bfea86
Boot0001 UEFI: PC300 NVMe SK hynix 512GB, Partition 1 HD(1,GPT,db8fea2b-30
Boot0002* Manjaro HD(9,GPT,f726d85f-f262-8342-8da6-e2ab9079d9bf,0x2da9
Boot0003* UEFI: SanDisk Cruzer Blade 1.26, Partition 1 PciRoot(0x0)/Pci(0x1
[manjaro@manjaro ~]$

Hi yannssolo , reordering the boor order gives me “invalid bootnum”

OK, so, you see Manjaro bootnum is 0002. So, you can try with only :

sudo efibootmgr -o 0002,0000 (you must be root, i forget to tell it to you)

Anyway, you can also change that order in your BIOS

Hi Yannssolo, in the boot option ( When I hit F12) there is no Manjaro option Only the 2 other boot option. I think windows does not recognize the boot partition for Linux. I do not how to fix it. I have seen that re installing GRUB fix it but not very at ease with Linux CMD. I am still learning. How do I chroot to my Linux Installation and install GRUB again… I need to mount the partition, How do I do it? Then Install GRUB. What is the cmd to install GRUB…
Any help will be much appreciated

Close secure boot.

In UEFI settings: (Google to know how to enter the UEFI screen, I only know Surface)

Security → Secure Boot → Disabled

And maybe you should close your fast-boot in control-panel(Windows 10)

This is not Windows business here. Did you disable secure boot in your bios ?
To chroot, this is not complicated, just follow this

Firestar, Secure Boot is off in UEFI setting I did F2 and then in the bios I can disable secure boot which is done. Then Fast boot also is turned off.

should I type the cmd from a live usb boot. Then how I do install GRUB again ?

I gave you the link already, this is here ! chroot + reinstall grub

Thanks I am going through it. Thanks, will keep you updated and see if it works.

Hello, I did all the steps mentioned in the link provided by yannsollo but still cannot have grub screen for dual booting. Laptop just boots windoz

From Windows, have you tried the following?

  1. Run cmd.exe as Administrator, then enter:
  2. bcdedit /set {bootmgr} path \EFI\manjaro\grubx64.efi
  3. Reboot

If there are no problems with the grub entry, hopefully this should set grub up to load.

Problem solved. I manage to get GRUB and dual boot normally. The steps I followed is listed here. I would like to express my heartfelt thank to @yannssolo for pointing me to this link. But this still did not solve the GRUB issue. Then I chrooted and installed GPARTED and then using GPARTED I set the flag for the efi partition to boot and esp. Voila GRUB appeared like magic on the next reboot. But in the GRUB menu no WINDOWS was listed. What I did is mount the windows partitions while log in as ROOT and then OS-PROBER. The windows partition was detected and then sudo update-grub. Then every thing works fine.
Thank You all @summrum @yannssolo @Firestar for helping.

1 Like

Very pleased to hear you got it working.

1 Like