Dual Boot Trouble!

Hello! I’m new to Manjaro, but have used Arch and Debian before. The only reason I’m trying Manjaro is that Arch Install is broken this year(tried all the releases since january, none is working). That said, I’m trying to use dual boot with windows 11, but, for some crazy reason, I don’t have the Grub Screen at boot, so I’m trying to install grub-customizer to fix that. The problem is that pamac keeps giving me a lot of bugs, like:

fatal error: gtkmm.h: No such file or directory

I would like to know if there’s any solution to this or any way I can replace pamac for yaourt, since it works way better.

Thanks in advance!

Welcome to the forum! :vulcan_salute:

You must change the line… :arrow_down:


… into… :arrow_down:


… in /etc/default/grub and then run… :arrow_down:

sudo update-grub

Don’t Do That™

Seriously, don’t. There’s a reason why we kicked that package out of our repositories. grub-customizer is not compatible with Manjaro’s grub and will ruin your boot loader configuration.

yaourt is abandonware. You can use yay (from the repository) or trizen (from the AUR) for that.

But still, do not install grub-customizer. We do not support it, and you will quickly come to sorely regret installing it. :slightly_frowning_face:

1 Like

Thank you for your help!

I installed yay successfully, but it cannot recognize the aur for grub-customizer, so it’s worse than pamac in this sense.

Your tip about the “hidden” to “menu” helped, now I can see a really nice grub screen at boot, but it still doesn’t recognize the windows partition.

Since you don’t recommend installing grub-customizer, is it impossible to have dual boot in Manjaro?

Would you like us to tell you if it is possible? Yes, of course. :face_with_raised_eyebrow:

Edit /etc/default/grub again and change this line… :arrow_down:


… into… :arrow_down:


Then run… :arrow_down:

sudo update-grub

… again. It will now scan your drive for other operating systems and will add them to the boot menu.

Of course, and the above will take care of that, but there’s a caveat… If one of the operating systems on the same drive was installed in UEFI mode and the other in legacy BIOS emulation mode (CSM), then the UEFI firmware will favor booting in legacy BIOS emulation mode, and then the UEFI-native operating system won’t work.

You can have native-UEFI operating system installations and legacy BIOS operating system installations on the same computer, but not on the same drive. This is a limitation of UEFI.

1 Like

Thank you again! I tried doing that, but it still doesn’t recognize the windows partition. Grub-customizer would have made it work already. I guess I’ll wait for archinstall to be fixed and use only windows until then. But thanks for your help anyway!

Yep, one system in UEFI mode and the other in legacy BIOS emulation mode, as I said.

And as I also said, there’s nothing that can be done about that software-wise, because this is a “feature” of the UEFI firmware.

The only option you have is to reinstall one of the two systems and make sure they’re both booting in the same mode of the firmware. I recommend installing both in UEFI mode, but this is only possible after you’ve explicitly disabled legacy BIOS emulation in the UEFI firmware setup utility.

Another thing to watch out for is that Secure Boot, Windows Fast Boot and Windows Hybrid Sleep must be disabled.

Follow these instructions and everything will play nice together:


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.