Dual-boot problems on boot (Windows 10) and shut-down (from Manjaro)

Hi all,

First timer here. I have attempted to install Manjaro XFCE 18.04 alongside my current Windows 10 setup on a Dell XPS 15 9560.

I have two problems at the moment. I don't know if they could be related. These are:
(i) When turning on laptop, I arrive to GRUB bootloader where I can select: "Manjaro Linux", "Advanced options for Manjaro Linux", and "Windows Boot Manager (on /dev/nvme0n1p1)". When selecting "Windows Boot Manager (on /dev/nvme0n1p1)" the system tries to boot (Windows/another boot manager?) up but fails and ends up on the GRUB boot-loader again.

(ii) Booting Manjaro works fine however when shutting down, restarting or logging out it gets stuck on a black screen with the keyboard backlight and power button light still on until I press the power button to shut down.

I installed Manjaro following instructions mainly from this link.

During installation process I also did the following:
(a) Changed SSD drive from RAID to AHCI (before installation).
(b) During installation I chose "free drivers".
(c) Installation was getting stuck a few times. I resolved this by adding .acpi_rev_override=0 to the /etc/default/grub to the GRUB_CMDLINE_LINUX_DEFAULT line after quiet. Then installation run OK.
(d) During installation I created the root, SWAP and efi partitions from Manjaro installer.
(e) Previously (after installation) trying to boot "Windows Boot Manager" from GRUB it sent me to Dell's Support Assist tool where it started checking for hardware problems. After a few boots it said there were no hardware problems. Since then, point (i) above occurs.

I am not sure if "Windows Boot Manager (on /dev/nvme0n1p1)" is the correct image that should be showing up on GRUB? I've seen pictures online where it just says "Windows 10". I have also seen online it is recommended to choose "non-free" drivers during installation?

I have just learnt the technical words for all of this in the past few days so please forgive me if I have got mixed up somewhere.

Any help is greatly appreciated. Many thanks beforehand.

Need info. From Manjaro terminal

sudo parted -l
sudo blkid
efibootmgr -v
cat /etc/fstab
ls /boot/efi/efi/
inxi -G

Where do you think it should be?

Thanks for the quick reply.

I meant the name "Windows Boot Manager". Should it be this? I have zero experience but I had seen pictures of GRUB online where it just said "Windows 10".

After running the last command: inxi -G and while copying the output to the forum, the computer froze. I couldn't access terminal so I hard shut down. When booting up again I could connect to the internet as it said "No network devices available". This issue hadn't occurred before.

Shutting down and booting up again I am now connected to wifi. But bottom left menu button (Manjaro logo) is now a mouse. I have now ran the commands with no problem:

sudo parted -l
Model: Unknown (unknown)
Disk /dev/nvme0n1: 512GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size    File system     Name                          Flags
 1      1049kB  525MB  524MB   fat32           EFI system partition          boot, esp
 2      525MB   660MB  134MB                   Microsoft reserved partition  msftres
 3      660MB   392GB  392GB   ntfs            Basic data partition          msftdata
 7      392GB   461GB  68.2GB  ext4
 8      461GB   482GB  21.0GB  linux-swap(v1)
 9      482GB   482GB  537MB   fat32                                         msftdata
 4      497GB   498GB  979MB   ntfs                                          hidden, diag
 5      498GB   511GB  12.6GB  ntfs                                          hidden, diag
 6      511GB   512GB  1217MB  ntfs                                          hidden, diag

sudoblkid
/dev/nvme0n1p1: LABEL="ESP" UUID="DE57-ABDD" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="f1d21893-31f8-4b58-8c86-80414d9edc54"
/dev/nvme0n1p2: PARTLABEL="Microsoft reserved partition" PARTUUID="6eb40124-b3ac-40e7-954a-b58174180c18"
/dev/nvme0n1p3: LABEL="OS" UUID="B67A84F17A84AFA3" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="fc5288be-13f6-43ff-b954-22f68d4f501e"
/dev/nvme0n1p4: UUID="626E57A96E57752F" TYPE="ntfs" PARTUUID="36369503-78a7-484e-9610-eb2dc4fab79c"
/dev/nvme0n1p5: LABEL="Image" UUID="C06C3FBF6C3FAF52" TYPE="ntfs" PARTUUID="83000089-4915-4a00-8b45-925ba0357aa9"
/dev/nvme0n1p6: LABEL="DELLSUPPORT" UUID="C0E4A680E4A677F4" TYPE="ntfs" PARTUUID="8b6ae609-8a9c-459a-ada7-55606636b202"
/dev/nvme0n1p7: UUID="c6b9daa8-484a-4fee-9b3d-f2b7cdef78ca" TYPE="ext4" PARTUUID="22f14b3e-6f47-4fd8-be58-734f3f9dc45e"
/dev/nvme0n1p8: UUID="2f3a00f6-e318-46c3-a428-b8d753d686ff" TYPE="swap" PARTUUID="6b06a459-5d06-4937-b684-d41cae03e60b"
/dev/nvme0n1p9: UUID="503A-8AC4" TYPE="vfat" PARTUUID="f621c7f2-3bff-4382-a07b-945971403046"

efibootmgr -v
BootCurrent: 0002
Timeout: 0 seconds
BootOrder: 0002,0000
Boot0000* Windows Boot Manager	HD(1,GPT,f1d21893-31f8-4b58-8c86-80414d9edc54,0x800,0xfa000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}....................
Boot0002* Manjaro	HD(9,GPT,f621c7f2-3bff-4382-a07b-945971403046,0x38114800,0x100000)/File(\EFI\Manjaro\grubx64.efi)

cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=c6b9daa8-484a-4fee-9b3d-f2b7cdef78ca /              ext4    defaults,noatime 0 1
UUID=2f3a00f6-e318-46c3-a428-b8d753d686ff swap           swap    defaults,noatime 0 2
UUID=503A-8AC4                            /boot/efi      vfat    defaults,noatime 0 2

ls /boot/efi/efi/
boot  Manjaro
inxi -G
Graphics:
  Device-1: Intel HD Graphics 630 driver: i915 v: kernel 
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] driver: nouveau 
  v: kernel 
  Display: x11 server: X.Org 1.20.5 driver: intel,modesetting 
  unloaded: nouveau resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 630 (Kaby Lake GT2) 
  v: 4.5 Mesa 19.1.1 

  1. At manjaro terminal,
sudo parted /dev/nvme0n1 set 9 boot on
  1. Print out windows entry at manjaro's grub.cfg. Just the windows entry.
  2. Have you tried booting windows at bios firmware?
    It is one of the F keys (usually F8 ~ F12) and select "Windows Boot Manager"
    If this boot key is not enabled, you can enable it at bios set up (usually F2)
    You can also select to boot windows at F2 in one of the the boot section, but preferably enable the boot key and use the boot key.
    If you tried to boot windows at this bios/boot, and you still end up at the grub boot menu, then it is confirmed there is something wrong at your windows, not at manjaro. You will need to fix it at windows. In uefi, if one bootloader fails, it will go to the next, which is manjaro's grub.
  3. Nothing related to your boot, but I noticed you are using free drivers with your nvidia graphics.
    And you have dual graphic cards. I am not good in graphics, but suggest after you fix your boot, start a new topic (with your inxi -G) and someone better can help you with this. Perhaps you do not need all these parameters that you are using to help you boot into manjaro.

Welcome to Manjaro.

Many thanks again for your help.

Output:

Information: You may need to update /etc/fstab.

The windows entry at Manjaro's grub.cfg:

Trying to boot from BIOS firmware using F12 key makes the same thing happen. End up in Manjaro GRUB.

I can access BIOS setup using F2 but can't find how to boot into Windows from here.

Thanks for the tip, will post about graphics drivers.

Right, as said, it is a windows thing that you need fixing, at windows.
And I do not see anything wrong at manjaro for your windows, and your windows entry looks fine at manjaro grub.

Take care.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by