Dual Boot Error (error: 'file /efi/Microsoft/Boot/bootmgfw.efi' not found.)

So I've been running into this issue constantly of being unable to boot into Windows using the Windows Boot Manager option in the bootloader. Everytime I try it gives this error:

error: no such device: 0EA3-DE6A
error: 'file /efi/Microsoft/Boot/bootmgfw.efi' not found.
Press any key to continue...

Now I checked and my EFI partion's UUID is listed currectly as 0EA3-DE6A in the KDE Partition Manager. And it even detects it in my efibootmgr


And if I tick the option of "Next boot" for windows, it boots into windows on restart no problem. It even loads windows from the bootloader properly on next restart from windows, but the moment I boot into linux, it doesn't boot into windows through the bootloader. Can someone help me figure this out?
I'm new to linux and haven't used linux in general before this.
The way I have setup my dual boot is that my Windows is on the default ssd my laptop came with and manjaro is on a 500Gb partition I created on my second 1TB ssd. I did a manual install with a 512mb efi partition within that 500 gb partition.
Really appreciate any input that could potentially help me solve it.

this error come from kernels
see line EFI
https://git.kernel.org/pub/scm/linux/kernel/git/stable/stable-queue.git/commit/?id=f4323461b6ccda85772dbe34b167571e1df1b713

this one ,@philm can we add as patchs or fix ?
https://git.kernel.org/pub/scm/linux/kernel/git/stable/stable-queue.git/diff/queue-5.7/efi-libstub-fix-path-separator-regression.patch?id=f4323461b6ccda85772dbe34b167571e1df1b713

I'm very unsure as to what I'm supposed to understand from it ':D.... I'm very new to linux. What exactly should I look for or change? I don't know coding much if at all. If you could give me a step by step guide to resolve it I'd really appreciate it!
Should I be updating my kernel to 5.7 via the Kernel options in the System Settings?

you see slash ? /.../...

you need antishlash to boot in EFI ...\ .. \ ...


So the part I have highlighted, should be '\efi\Microsoft\Boot\bootmgfw.efi ' ?

it should works , patch should be soon in stable kernel

I tried but the Grub Customizer messed something up after this. My entire grub time whether I set it to 10 or 30 secs would stay blank for that entire period, until it default boots to windows.
I followed the reset method given in the read me file of the grub folder of manjaro, but the bootloader now looks completely different and has started to give a new error when booting into linux as well, after pressing enter twice and running into the error, it starts in "blind mode" which idk what that is, and boots into linux.

Okay nvm, so I re did the steps and got it to normal somehow, Idk how to change the theme back to what it was at install, but atleast the bootloader works normally. However that being said, I'm still unable to boot into windows even after making those changes

Out of curiosity, did you launch the Manjaro USB using UEFI mode? I had a similar problem where GRUB was not adequately mapping/detecting my Windows install (on another separate NVMe drive) when I was booting and installing on non-UEFI mode.

If you didn't do that, I would highly recommend using UEFI (assuming your BIOS supports/runs it) because the odds are that it just didn't detect it and thus will not properly install to GRUB.

1 Like

Yes it was installed in UEFI mode, the issue is that it will boot into windows, but only if I booted into windows previously, if I had booted into Linux before and then on restart/ next boot if I choose windows it says device not found and then the error efi/... not found.
But again if I set next boot into windows, then shut down then boot into windows using bootloader it worked. I have no idea why that is, the only thing I could think of was maybe the SSD gets unmounted everytime I boot into and out of linux that could be the problem.

Do you have fast boot enabled in BIOS, by any chance? If so, disable that.

Yep that was the issue thank you! Apparently I hadn't saved the change before when I disabled it in the BIOS.
It worked, but I have run into another problem, my grub bootloader doesn't show up anymore. It just stays blank until the 10 second timer goes away and boots into linux

When on Manjaro, try to run these commands:

sudo os-prober && sudo update-grub

I tried it, didnt work :frowning:
I have reinstalled the OS as well hoping the issue would go away but nothing changed.
Tried this after reinstalling as well.

Press esc.

Okay that worked, but why is it that I need to press escape suddenly to see the bootloader? Can I change it? '
Also for some reason WIndows boot manager fails to show up completely now in the bootloader xD

This is the reason it's "going dark". I think it's a silent boot feature - nothing showing if no other OS besides Manjaro is detected.

Forum kindly sponsored by