Dual boot and secondary hard drive ownership

I have a windows installation on my system as well as manjaro and ubuntu (so technically triple boot), all of them installed on an nvme ssd. There are also 2 hard disks connected to the system. One of them behaves just fine, I can delete from and write to it. The second hdd however is read only. I disabled fast boot and hibernation under windows, ran chkdsk and found no problems. However, I still cannot write or delete from the drive when in manjaro.
When I run

sudo fdisk --list  

I get:

Device     Boot Start        End    Sectors   Size Id Type
/dev/sdb1  *     2048 1953521663 1953519616 931.5G  7 HPFS/NTFS/exFAT

For the working drive, I get

Device     Start        End    Sectors   Size Type
/dev/sda1     34      32767      32734    16M Microsoft reserved
/dev/sda2  32768 1953521663 1953488896 931.5G Microsoft basic data

Partition 1 does not start on physical sector boundary.

EDIT: sorry I had switched the two drives, sdb is the one who is readonly, sda is the working one.

Hi @relefat.

That is the partition type, and yes, that is probably why you can’t write to it, since it has an NTFS partition and NTFS is proprietary. To change it will require deleting the partition, recreating it and reformatting the disk. This can, however, cause Windows to lose access to the disk, as well as data-loss if the data hasn’t been backed up.

This might help:

1 Like

It is NTFS - there is not ownership on the content - but you may be limited if you forget permissions on the mountpoint.

Also kernel driver may get in your way.

Maybe a little late in answering this one but I have been messing with this sort of thing lately and ended up here. Since I use Manjaro on my other computer, I thought I would have a look.

Have you tried installing NTFS-3G?

pacman -S ntfs-3g

And on Windows there is only paid options Paragon and Tuxera…

Won’t change the fact that it’s NTFS, or that it doesn’t have file ownership. So if, and that’s a BIG IF, it works, it’ll just be a fluke and not reliable.

I couldn’t fix the issue but I managed to back up all the data then proceeded to format the drives. Both were like this, interestingly I could create some folders but could not create folders in some other folders, it was just a mess.

So: you did something

but you still have …
… what kind of problems?

What is the actual problem? Still the same as described in the initial post?

By that reasoning, you might also suggest another arguably paid option – Windows itself, which employs NTFS as the default filesystem.

I’m simply being facetious, excusé moi.

A note on blacklisting ntfs3 in favour of ntfs-3g:

The ntfs3 kernel driver can appear to fail if damage; or, rather, an indicator of damage; to an NTFS formatted drive is found (commonly referred to as a dirty bit).

ntfs-3g, however, ignores this and mounts the NTFS partition, regardless.

Important to note is that the NTFS filesystem may still be damaged, as ntfs-3g allows you to blissfully continue using your drive.

If an error does exist, it should/must be corrected within a Windows environment using chkdsk, which can achieved by launching an administrative command prompt and using the command:

chkdsk /f x:
  • x: denotes the drive letter of the disk as it appears in Windows.

If a Windows installation is not available, chkdsk may also be run from a bootable Windows installer, or the downloadable Hiren’s BootCD PE; as one possible example.

I hope this additional information is helpful.



it’s fixed after I formatted the drives, no issues now whatsoever.

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.