Dual Boot always goes to Window 11 on Startup

I know I should change the boot order.
When I go to the BIOS Setup, the options are:

OS Boot Manager
USB Flash Drive/USB Hard Disk
! Network Adapter

From here, the boot manager does not differentiate between Windows 11 and Manjaro.

I can go to the Boot Options, and select Manjaro from there, but this menu does not give me the ability to change the boot order.

Once in Manjaro, I can view the boot order with: sudo efibootmgr -v, and the output is 0002, 0003, 0004, 2001, 3002

0002: Windows
0003: Manjaro
0004: EFI Hard Drive
2001: EFI USB Drive
3002: Internal Hard Disk

I can change the boot order with sudo efibootmgr -o 0003, 0002, 0004, 2001, 3002.
I can confirm the boot order has been changed with -v.

However, when I restart my computer, it automatically boots Windows.

When I get back to Manjaro and view the boot order, it has reverted to 0002, 0003, 0004, 2001, 3002.

Is there a step that I am missing?

Thank you!

sudo efibootmgr -b 0003 -a

sudo efibootmgr -b 0003 -a

I tried this, and I got the following error message:
efibootmgr: Boot entry 3 not found
Could not set active state for Boot0003: No such file or directory

What do -b and -a represent?

I also tried the link you posted. It took me to the following instructions:

    Run CMD as Administrator
    bcdedit /set {bootmgr} path \EFI\Manjaro\grubx64.efi

However, when I type in this command line, “bcdedit” is red. I would think that is because I am not running as an administrator, but the error message it gives me is:
zsh: command not found: bcdedit

man efibootmgr

translated to what I read it as:
set the third boot entry to active

This is meant to be run from within Windows - it’s not something you can run on your Linux installation.

I entered Windows and opened the command prompt as an administrator, and typed in the command as written.
I got a response that said “operation completed successfully.”
However, when I rebooted my computer, I still went to Windows on startup.

does the OS Boot Manager option in bios have a right arrow pointing to it?
if yes, highlight this and press enter
Press F5/F6 to put manjaro above Windows Boot Manager
Press F10 to save the changes
Save all your changes and exit the UEFI settings

You’d have to ask @linux-aarhus about that.
I don’t have Windows to even try it out.
Perhaps the path given was wrong - or some other part of that command.
I just don’t know.
I just pointed out that this wasn’t something you could do from within Linux - as you evidently did.

No, I went into Windows and executed the command.

… but not the first time - and this is why I said it:

that, the error message

zsh: command not found: bcdedit

means that you where in Linux when you tried it

this is not productive - let’s not continue this …

You’re right. sorry, I misunderstood what you meant. Thank you for the help, anyway.

This worked!

Thank you! I had not noticed the arrow next to the OS Boot Manager option.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.