Dropouts with bluetooth earphones

Hi again from Bluetooth noob-land. This may indicate my lack of Bluetooth experience, but I don’t think so.

I am using i12 Bluetooth headphones. In recent months, using the stable updates only, I am having audio dropout problems with playing videos, sometimes one or the other ear, or both ears.

I have tried kernels 5.12 and 5.10 LTS, same problems. Playing the video files over HDMI audio shows the problem is not with the videos themselves.

My info:

  Kernel: 5.12.1-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.12-x86_64 
  root=UUID=c8e669d6-890c-431a-9083-a5bee720d372 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.24 info: xfce4-panel wm: xfwm4 vt: 7 
  dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux 
  Type: Mini-pc System: IP3 Tech product: TX95 v: N/A serial: <filter> 
  Mobo: IP3 model: AB1A serial: <filter> UEFI: American Megatrends v: 0.02 
  date: 06/30/2020 
  RAM: total: 7.62 GiB used: 1.68 GiB (22.1%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: Quad Core model: Intel Celeron N3450 bits: 64 type: MCP arch: Goldmont 
  family: 6 model-id: 5C (92) stepping: 9 microcode: 40 cache: L2: 1024 KiB 
  bogomips: 8756 
  Speed: 796 MHz min/max: 800/2200 MHz Core speeds (MHz): 1: 796 2: 1741 
  3: 988 4: 808 
  Flags: 3dnowprefetch acpi aes aperfmperf apic arat arch_capabilities 
  arch_perfmon art bts cat_l2 clflush clflushopt cmov constant_tsc cpuid 
  cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts ept ept_ad erms est 
  flexpriority fpu fsgsbase fxsr ht ibpb ibrs ida intel_pt lahf_lm lm mca mce 
  md_clear mmx movbe mpx msr mtrr nonstop_tsc nopl nx pae pat pbe pclmulqdq 
  pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pts rdrand rdseed rdt_a 
  rdtscp rep_good sdbg sep sha_ni smap smep ss sse sse2 sse4_1 sse4_2 ssse3 
  stibp syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer 
  tsc_known_freq tsc_reliable vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec 
  xsaveopt xsaves xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass status: Not affected 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel HD Graphics 500 driver: i915 v: kernel bus-ID: 00:02.0 
  chip-ID: 8086:5a85 class-ID: 0300 
  Display: x11 server: X.Org 1.20.11 driver: loaded: intel 
  unloaded: modesetting alternate: fbdev,vesa display-ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: HDMI1 res: 1920x1080 hz: 60 
  OpenGL: renderer: Mesa Intel HD Graphics 500 (APL 2) v: 4.6 Mesa 21.0.3 
  direct render: Yes 
  Device-1: Intel Celeron N3350/Pentium N4200/Atom E3900 Series Audio Cluster 
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_apl 
  bus-ID: 00:0e.0 chip-ID: 8086:5a98 class-ID: 0403 
  Sound Server-1: ALSA v: k5.12.1-2-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.26 running: no 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  driver: r8169 v: kernel port: e000 bus-ID: 01:00.0 chip-ID: 10ec:8168 
  class-ID: 0200 
  IF: enp1s0 state: down mac: <filter> 
  Device-2: Intel Wireless 3165 driver: iwlwifi v: kernel port: e000 
  bus-ID: 02:00.0 chip-ID: 8086:3165 class-ID: 0280 
  IF: wlp2s0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IF-ID-1: nordlynx state: unknown speed: N/A duplex: N/A mac: N/A 
  IP v4: <filter> scope: global 
  WAN IP: <filter> 
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 
  bus-ID: 1-7:3 chip-ID: 8087:0a2a class-ID: e001 
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends 
  Message: No logical block device data found. 
  Message: No RAID data found. 
  Local Storage: total: 235.56 GiB used: 109.94 GiB (46.7%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/mmcblk1 maj-min: 179:0 vendor: HP model: DF4128 size: 116.48 GiB 
  block-size: physical: 512 B logical: 512 B rotation: SSD serial: <filter> 
  rev: 0x8 scheme: GPT 
  ID-2: /dev/sdc maj-min: 8:32 type: USB model: Genesys SD USB3 Reader 
  size: 119.08 GiB block-size: physical: 512 B logical: 512 B serial: <filter> 
  rev: 1206 scheme: GPT 
  Message: No optical or floppy data found. 
  ID-1: / raw-size: 118.79 GiB size: 116.87 GiB (98.39%) 
  used: 53.16 GiB (45.5%) fs: ext4 dev: /dev/sdc2 maj-min: 8:34 label: N/A 
  uuid: c8e669d6-890c-431a-9083-a5bee720d372 
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 312 KiB (0.1%) fs: vfat dev: /dev/sdc1 maj-min: 8:33 label: N/A 
  uuid: 6EF9-53C7 
  ID-3: /mnt raw-size: 115.32 GiB size: 115.32 GiB (100.00%) 
  used: 56.79 GiB (49.2%) fs: ntfs dev: /dev/mmcblk1p3 maj-min: 179:3 
  label: OS uuid: 7802BE5802BE1AD8 
  Alert: No swap data was found. 
  ID-1: /dev/mmcblk1p1 maj-min: 179:1 size: 100 MiB fs: vfat label: SYSTEM 
  uuid: C2B5-68AC 
  ID-2: /dev/mmcblk1p2 maj-min: 179:2 size: 128 MiB fs: <superuser required> 
  label: N/A uuid: N/A 
  ID-3: /dev/mmcblk1p4 maj-min: 179:4 size: 957 MiB fs: ntfs label: Recovery 
  uuid: 08B2BED7B2BEC888 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 8 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-2: 1-2:2 info: Genesys Logic Hub ports: 4 rev: 2.0 speed: 480 Mb/s 
  power: 100mA chip-ID: 05e3:0610 class-ID: 0900 
  Device-1: 1-2.1:4 
  info: Holtek Wired Keyboard (78/79 key) [RPI Wired Keyboard 5] 
  type: Keyboard,HID driver: hid-generic,usbhid interfaces: 2 rev: 2.0 
  speed: 1.5 Mb/s power: 100mA chip-ID: 04d9:0006 class-ID: 0300 
  Device-2: 1-2.3:5 info: Microdia USB Device type: Keyboard,Mouse 
  driver: hid-generic,usbhid interfaces: 4 rev: 1.1 speed: 12 Mb/s 
  power: 100mA chip-ID: 0c45:8101 class-ID: 0301 
  Device-3: 1-2.4:6 info: Logitech Keyboard K120 type: Keyboard,HID 
  driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 1.5 Mb/s 
  power: 90mA chip-ID: 046d:c31c class-ID: 0300 
  Device-4: 1-7:3 info: Intel Bluetooth wireless interface type: Bluetooth 
  driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA 
  chip-ID: 8087:0a2a class-ID: e001 
  Hub-3: 2-0:1 info: Full speed (or root) Hub ports: 7 rev: 3.0 speed: 5 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  Device-1: 2-3:2 info: Genesys Logic All-in-One Cardreader type: Mass Storage 
  driver: usb-storage interfaces: 1 rev: 3.0 speed: 5 Gb/s power: 896mA 
  chip-ID: 05e3:0748 class-ID: 0806 serial: <filter> 
  System Temperatures: cpu: 74.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 197 Uptime: 21h 45m wakeups: 6 Init: systemd v: 247 
  tool: systemctl Compilers: gcc: 10.2.0 Packages: 1295 pacman: 1290 lib: 403 
  flatpak: 5 Shell: Bash v: 5.1.4 running-in: xfce4-terminal inxi: 3.3.04 

Unfortunately, I don’t remember exactly at which update this started. I’ve had (and continue to have) other problems with Bluetooth headphones freezing out my keyboard, and that was more my focus.

Has Pulse audio been updated recently?

Thanks for any ideas on this.


The latest update for PulseAudio (v14.2-2 to v14.2-3) was included in [Stable Update] 2021-04-09

If PulseAudio is not working after an update, clearing old user settings might get audio working again

Delete Pulseaudio user settings databases and cookie, then reboot system so new user files are created

rm ~/.config/pulse/*.tdb ~/.config/pulse/cookie && reboot

Thanks for this suggestion! I tried it, but unfortunately, the dropouts persist. I’m now wondering how to try pipewire instead of pulseaudio, since it is supposed to address bluetooth issues when playing video. I’ll check the forum for pipewire info.

Pipewire didn’t seem to help, but the most recent stable update (16 jun 2021) fixed the dropouts!

THANKS to whichever layer was improved, and to the Manjaro team in any case!


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.