Driver support on AMD RX-4XX Series on manjaro

so radeon is now amdgpu?

No Radeon is the old driver, amdgpu the new one. For some cards you can use both.

so how do i enable the AMDGPU and VDPAU?

Depends. If you can wait a little longer, just wait… A week because I’m mostly done with the automation for GCN 1.0,1.1 (mhwd script.)
Otherwise I’ll explain it to you when I’m back home in ~10h

no worries, busy till then anyways :slight_smile: thanks for the efford man

Graphics: Card: Advanced Micro Devices [AMD/ATI] Curacao PRO [Radeon R7 370 / R9 270/370 OEM]
Display Server: X.Org 1.18.4 driver: radeon Resolution: 1920x1080@60.00hz
GLX Renderer: Gallium 0.4 on AMD PITCAIRN (DRM 2.48.0 / 4.9.0-0-MANJARO, LLVM 3.9.0)
GLX Version: 3.0 Mesa 13.0.2

[quote=“fixxxer, post:36, topic:14115”]
R9 270
[/quote]if you do not mind telling me how much did you pay for it?

I got it used for 75EUR, its the Sapphire R9 270 Dual-X 2GB GDDR5 256bit.
Fans dont start below 30% load :smiley: its a beaty

OK let’s do this.

MHWD uninstall part

The first step is to remove every video-driver inside mwhd so please remove them.
you can list them by

mhwd -li

Install dependencies

Here we install all the dependencies that is mostly the latest xserver and linux.

sudo pacman -S "xorg-server>=1.18" "linux>=4.9" xf86-video-amdgpu xf86-input-libinput

Setting up Grub

Because this is experimental we need to tell linux on bootup that it activated the experimental hardware support. Thanks to Philm this is enabled in linux4.9 for GCN 1.0. To do this you need to edit the file /etc/default/grub look for the line


and add amdgpu.exp_hw_support=1. So if there is nothing else in this line it should look like this:


And we need to update grub with

sudo update-grub

Kernel Module loads n’ unloads

Because its the most important thing to have amdgpu kernel module (kmod) loaded and radeon blocked, we need to create some files to do that. At first create a file /etc/modules-load.d/amdgpu.conf with the content


and another file /etc/modprobe.d/radeon_blacklist.conf with

blacklist radeon


Xorg setup

Next you have to switch Xorgs driver(DDX), because it WILL load the radeon ddx by default. So create another file /etc/X11/xorg.conf.d/90-mhwd.conf (lets use the manjaro default for this) with just following entry in it (delete everything else if needed)

Section "Device"
        Identifier  "R9270" #identifier can be everything
        Driver      "amdgpu"


now restart and you should be on amdgpu


Graphics: Card: Advanced Micro Devices [AMD/ATI] Curacao PRO [Radeon R7 370 / R9 270/370 OEM]
Display Server: X.Org 1.18.4 driver: amdgpu Resolution: 1920x1080@60.00hz
GLX Renderer: Gallium 0.4 on AMD PITCAIRN (DRM 3.8.0 / 4.9.0-0-MANJARO, LLVM 3.9.0)
GLX Version: 3.0 Mesa 13.0.2

Only one issue: I have a pink line on the left side of my monitor after the reboot (not visible in screenshots)

Appeared on every reboot with “starting version 231(or whatever the number is)”

Now what @anon35400795

Nothing. thats it. Remeber that amdgpu(kmod and ddx) are in experimental mode for GCN1.0, 1.1. So things like this could be a normal bug that you should report (when its not a hardware defect)

What cable are you using to connect your screen? Does your screen have a “calibrate” option in its menu? You might consider trying that one.

1 Like

not working, its not a monitor issue

How di revert if I wish to?

Do exactly the opposite of that howto except for the “install dependencies”, you dont need to remove anything and for the xorg setup where you can just replace “amdgpu” by “radeon”

After following @anon35400795 guide, I noticed Xorg still tried to load the old driver. I changed the ‘Driver’ entry in the /etc/X11/xorg.comf to “amdgpu” and that fixed it.

I’m not sure why the /etc/X11/xorg.conf.d/90-mhwd.conf file didn’t work…

You should not have a /etc/X11/xorg.conf file. Thats why /etc/X11/xorg.conf.d/90-mhwd.conf dont works.

Tids, will this work for my R9 290 (non-X version). I have both the 290 and the R9 Fury (non-X) in the same computer and I’ve been stuck running Win10 because I can’t get them both working under Linux, unless I go back to FGLRX, which I have no desire to do because it’s a gigantic pain in the poop chute.

I hate Windows 10. This stupid OS has been uninstalling things that I specifically installed, it’s been crashing, the web is SLOW compared to Linux and I’m always worried about viruses. I really, REALLY want to get back to Linux…but I need my R9 290 to work, because this is my SETI@home second computer. Plus, SETI runs faster under Linux for AMD GPUs, so I’m not getting my full output that I should be getting.

Thanks in advance for any reply or assistance you can provide me.

Mostly yes. But you can just wait for the new mhwd-addons-amdgpu-hwe package from unstable. When this is in stable, there will be another package, called “amdgpu-experimental”. You can just install this. It will configure everything for you, except for the xorg-config part. That would need your interaction.

Do you know how long it will be before the new package makes it into the stable repos?

Forum kindly sponsored by Bytemark