Drive mounting in different location due to file permission issue

I have a mounted hard drive that I keep the majority of my files on for programming.
I noticed that some files suddenly couldn’t be deleted. Unsure why. After a restart, I noticed that my hard drive was no longer mounted in its location.

Instead of being mounted at /run/media/nick/HDD - it was now /run/media/nick/HDD1.
The old folder still exists, and all that is in it are those files that I couldn’t delete. It appears to be mounted as a tmpfs drive and is owned by root instead of my user. I’ve tried deleting those files as well as unmounting that drive, but after I restart, it comes back.

Is there anything I can do here short of re-creating the partition? The drive is NTFS as it’s shared by my Windows dual boot. However, I haven’t booted in to windows since the problem started happening.

Welcome to the forum! :slight_smile:

It’s not a tmpfs. However /run is a tmpfs. Your drive is simply mounted to a directory that itself resides on the tmpfs.

I strongly suspect that you’ve got Windows Fast Boot on. This does not fully shut down the Windows filesystems, and as a result, it is possible that udisks2 now mounts the volume to another mountpoint, and with a different ownership and permissions, given that it may still remember the previous mount.

Either way, here’s my advice… :arrow_down:

  1. Turn off Windows Fast Boot.

  2. Add the NTFS volume to /etc/fstab with a fixed mountpoint ─ e.g. to a directory that itself resides under your $HOME, given that they are personal files anyway.

Look into the pertinent man pages for the correct mount options…

man fstab
man mount

Ah, I didn’t realize you could give it a permanent mount point. (Manjaro is my first linux distro!)
I’ve just been accessing it from the other default mount.

I suspect it is a corrupt file as well, so I’m running a chkdsk in windows to try and see if that’ll fix anything.
Afterwards, I’ll pursue the fstab (and I’ve also turned off fast boot!)

Thanks for the advice and welcome!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.