Drive automount broken in KDE

kde

#1

My removable USB disks are not anymore automounted in KDE. They appear in the Device Notifier, but I need to manually select and click on each of them to activate them. This is the reason why I switched back last week fon Testin to Stable…:joy: lol.
Anyway, I have read something about a security feature done on purpose. Is it the case, or can we expect this to be considered as a bug which will be (hopefully) corrected in a future maintenance update ?
(The same occurs for me on 2 machines, both with KDE)


[Stable Update] 2018-02-17 - Kernels, KDE, MATE, Firefox, LibreOffice, Mesa, Systemd
#2

Same here with an internal disk.


#3

Seems it depends of the hardware. See above the link from @torvic in a previous post. Brightness is also working for me in a Tower, but not in my XPS13. Automount does not work in either.


#4

I, too, am affected by the no longer auto-mounting of external drives. I already checked the KDE system settings and both drives are ticked to automount.


#5

I have the same issue with NTFS partitions. Automount doesn’t work in KDE edition.


#6

The same here. I guess it’s how Plasma 5.12 works now. I also want to know if that’s temporal thing and automounting will return or will it be broken forever? :frowning:


#7

KDE Automount bug: https://bugs.kde.org/show_bug.cgi?id=389479


#8

Thanks, added mine comment. Hopefully they will fix it soon. I’m happy that it’s considered a bug and not a feature - at least so far.


#9

I don’t think so. Since the whole removable media section in the KDE settings wouldn’t make any sense…

@pierrep56, @mofusi, @anon73134900 and others having the automount-issue:

As a workaround put into the KDE/Plasma autostart the program udiskie (just plain like that). It was installed on my system (I guess by default). Here is what it is and does:


(linked from https://wiki.archlinux.org/index.php/Udisks#Mount_helpers)

P.S.: @philm: I had both udisks and udisks2 installed on my system. Is the first one of any use still?


#10

udiskie works great for me as a workaround. Thanks @b_quest


#11

Thanks, I added my comments as well.


#12

udiskie uses udisks2 as dependency now.


#13

It doesn’t work for me.

activé= activated in english


#14

Did you re-login or ran udiskie manually in your current session?


#15

I did re login but i haven’t ran udiskie.

[marc@marc-pc ~]$ udiskie

(udiskie:4603): Gtk-WARNING **: Theme parsing error: gtk.css:68:35: The style property GtkButton:child-displacement-x is deprecated and shouldn't be used anymore. It will be removed in a future version

(udiskie:4603): Gtk-WARNING **: Theme parsing error: gtk.css:69:35: The style property GtkButton:child-displacement-y is deprecated and shouldn't be used anymore. It will be removed in a future version

(udiskie:4603): Gtk-WARNING **: Theme parsing error: gtk.css:73:46: The style property GtkScrolledWindow:scrollbars-within-bevel is deprecated and shouldn't be used anymore. It will be removed in a future version

It’s still running and nothing new…


#16

Another workaround is to downgrade solid to 5.42

pacman -U https://archive.archlinux.org/packages/s/solid/solid-5.42.0-1-x86_64.pkg.tar.xz


#17

I can’t find it in the cache, i only have 5.43.0-1 though i didn’t clear it…


#19

Seems one of these changes made the automount act differently now:

Maybe contact Kai Uwe to get a fix for it.

@imarco: old verisons of solid can be found here.


#20

Downgrading solid fixes the bug.
Thanks! :+1:


#21

@imarco: where gets your drive auto-mounted?