Draftsight Build failure

Hi,

I'm just an ordinary user and I run, trying o ut, Manjaro on an old computer. Just need internet and some 2D and 3D CAD occasionally.

I'm used to Auto-CAD and Inventor from my work. Draftsight looks just perfect for me.

It works fine after build. However it looks like one error that could be an service pack. I'm not sure where to post that.

curl: (56) Recv failure: Connection deleted by partner
==> ERROR: Failed to download http://dl-ak.solidworks.com/nonsecure/draftsight/2019SP1/draftSight.rpm
Canceling ...

The package has been flagged out of date. Maybe solidworks has removed also the last version.
You can try changing the package version in the PKG file and see if it builds (the file seems to be available there):

pkgver=2019SP2

Let us know if it works!
Cheers,

Cheers and thanks for that information d7rk.

What you propose is to heavy for me. And it seems to work just fine for now.
Do you know if we need to tell this guys fixing package?

Thanks,

https://aur.archlinux.org/packages/draftsight/

It is flagged out-of-date since 2019-09-26

The maintainer is @oberon.
But it just replacing the pkgver and the md5sum seems to work (I've just tried opening one dwg only):

However, it is supposed to stop working (for free) on 31/12/2019...

Cheers,

1 Like

Forum kindly sponsored by