DP-alt mode not working on my PBP

Manjaro Arm has been working pretty well for me so far on my Pinebook Pro. I installed in January without X, opting for Wayland and Sway. In April, my System stopped getting updates, so I was stuck on linux-pinebookpro-56 iirc. Two days ago, I changed the Mirrors to the correct ones and updated everything at once.
This worked kinda fine, except that now, on linux-58 mainline, USB-C DP-Altmode with my USB-C to HDMI adapter has stopped working.
When I use Sway on Wayland, swaymsg -t get_outputs only shows the internal Display adapter eDP-1. On Gnome with X, xrandr also shows DP-1, but always lists it as “Disconnected”.
It definitely is not a hardware fault, booting Kali Linux from an SD-card worked fine with an external display.

dmesg -w only shows the USB-Billboard-device being recognized and one other line:

cdn-dp fec00000.dp: [drm:cdn_dp_pd_event_work [rockchipdrm]] Not connected. Disabling cdn

Does anyone have a clue what I could do to fix this behaviour? I don’t know whether the Kernel is at fault here, because linux 5.7.1 from Kali Linux worked fine and theoretically, this issue with the DP-Altmode not working should have been resolved, according to this discussion.

It would be really great to find a workaround of some kind, because I am kind of dependent on using an external monitor for my work.

This seems to be a known problem, as mentioned in this thread.

I guess I will see whether I can downgrade my kernel to linux 5.7

It’s a known issue with the upgrade to kernel 5.8 and has been addressed with the developers already: [ARM Stable Update] 2020-08-13 - Bitwarden, Plasma, SystemD and Kernels

every single up-to-date pinebook pro user has this problem right now. Pretty huge.

Luckily, i found out a way to downgrade to the old kernel, in case you don’t have an old kernel flying around your hard drive.

type in this command in the command line / console:

sudo pacman -U http://manjaro.mirror.serversaustralia.com.au/arm-stable/core/aarch64/linux-aarch64-5.7.8-1-aarch64.pkg.tar.xz http://manjaro.mirror.serversaustralia.com.au/arm-stable/core/aarch64/linux-aarch64-headers-5.7.8-1-aarch64.pkg.tar.xz

Is downloads and installs the previous kernel and headers. Works atm.

Have a good day.


Worked perfectly fine,

thank you!

I don’t thing there is linux-aarch64 available in the repo anymore.

To solve DP-Alt mode for users we have decided to maintain linux-pinebookpro until we have dp-alt mode working on linux-5.8

Users can update the system and install linux-pinebookpro and linux-pinebookpro-headers
sudo pacman -Syyu linux-pinebookpro linux-pinebookpro-headers

For those who don’t want to use dp-alt mode can stay on linux-5.8

Thank You.


Hi, i just tested it. It’s still available since the server is out of sync atm.

Smart :wink:
Yes this mirror is out of sync, good observation, but some time it will sync that is the reason we have brought back the old package, I will check with the team and see if we can use linux-aarc64-5.7.8 as long as dp-alt mode works on it.

Thanks for the support.


@spikerguy thank you for the info. It fixed my usb-c out on my pinebook pro. The people on these forums are great.

1 Like

Thanks for confirming that alt-mode worked on linux-aarch64-5.7.8

I bumped linux-pinebookpro to 5.7.12 by using the linux-aarch64-5.7.12

Currently posting from PBP over USB-C Hdmi output, Next will try to bump it to 5.7.14 over the weekend.

We can close this thread with a solution.
Thank everyone for supporting Manjaro ARM Project.