Downloaded Latest Updates - Stuck on Logon Screen


#1

I am running the Budgie version of the stable branch. I can not get past the logon screen. It attempts to log in then reloads the logon screen. Any ideas what the fix might be?

I believe my network connection is broken now after downloading latest updates.
I saw some errors related to that.

Also seeing the attached.


#2

rm /var/lib/pacman/db.lck
try that and then start the sudo pacman -Syyuu again


#3

Something is using pacman’s database (in GUI for example?)


#4

Still no luck in getting it to boot after the logon screen. I think I am going to try a different Linux distro. I’ve only been using this for about a month. Sadly, I wish I hadn’t ran the updates.


#5

…why did you not finish the updates?
Then why did you not follow instruction to … finish the updates?

…I guess a different distro would suit you better…
But remember, not updating your system is not OK no matter what computer/distro/OS you use. :wink:


#6

I made many attempts to correct the problem using command line and USB bootable OS. The fault does not lie with me, I was using the built in update manager. Yes, I am thinking I’d prefer an OS that is stable and usable versus one that is up to date and broken. Thanks for the help everyone.


#7

Given the information you have so far posted it does lie with you as your database was locked due to multiple instances of a package manager running. According to your information you did not even attempt to manually remove the lock.

If you want to blame the OS … go ahead. :kissing_heart:


#8

my goodness people. blaming people is no use
i had had two broken systems from the last major updates and this forum is full of people who have broken systems. something was very wrong in the last updates, and i needed some time to figure it out. so please dont blame people.
but in the end i managed with all the help of posts this forum to get it right


#9

You can bring a horse to a water stream but you can’t make it drink from it


#10

@landfiets is right, this will unlock your database (the “unable to lock database” message).

If after this you don’t have internet connection to run sudo pacman -Syyuu you need to Boot up from live Manjaro media then enter into the terminal:

manjaro-chroot -a

This is automatic chroot, useful when multi boot, will list all bootable partitions, select the proper (Manjaro) root partition then run sudo pacman -Syyuu


#11

Hey, I’m new on this forum (first post), quite newbie and excuse me about my English :wink:

I’ve get exact same situation.

I’ve successfully updated system (pacman output was like ‘success’), then rebooted machine and tried to login… stucked - I can’t get into xsession. On logon screen everything works normal (as before update), but after typing password it hangs. Mouse pointer is movable, but nothing happens (power button works, possible to shutdown, with keyboard keystroke Ctrl+Alt+F_ sessions are switchable).

I’ve been using Manjaro about a year and from time to time, so whenever I start my work, some updates are available.

Few steps I’ve made:

  • booted as always to logon screen
  • switched to other session (tty5)
  • tried update with sudo pacman -Syyuu which gave me ‘nothing to do’
  • then added new user to system to check if it isn’t my misconfiguration
  • new user also can’t log to xsession

Today that is my 3rd breakdown and this accident formed my opinion about Manjaro - it’s crapware ;(

I’m considering to change distro again (4th change since 2004) but before that I want to learn something about the case. So help me Guys to investigate and track problem as it would be helpful for users.