Downgrading ZFS from 2.0.3 to 2.0.0

I have problems with my ZFS crashing my system on a daily basis.

Someone suggested me to downgrade to 2.0.0 version of ZFS as supposedly there were a lot of write behaviour changes afterwards.

However I am not capabil of doing so.

if I try downgrading zfs-utils usign the “downgrade” tool I get this.

downgrade zfs-utils                                      

Downgrading from A.L.A. is disabled on the stable branch. To override this behavior, set DOWNGRADE_FROM_ALA to 1 .
See https://archived-wiki.manjaro.org/index.php?title=Using_Downgrade  for more details.

Available packages:

-  1)  zfs-utils    0.8.5  2  x86_64  (local)
-  2)  zfs-utils    2.0.0  2  x86_64  (local)
-  3)  zfs-utils    2.0.1  1  x86_64  (local)
-  4)  zfs-utils    2.0.2  1  x86_64  (local)
+  5)  zfs-utils    2.0.3  1  x86_64  (local)

select a package by number: 2
loading packages...
warning: downgrading package zfs-utils (2.0.3-1 => 2.0.0-2)
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing zfs-utils (2.0.0-2) breaks dependency 'zfs-utils=2.0.3' required by linux510-zfs
:: installing zfs-utils (2.0.0-2) breaks dependency 'zfs-utils=2.0.3' required by linux54-zfs

If I try to downgrade linux510-zfs I get the oposite.

downgrade linux510-zfs                                                                                                                               

Downgrading from A.L.A. is disabled on the stable branch. To override this behavior, set DOWNGRADE_FROM_ALA to 1 .
See https://archived-wiki.manjaro.org/index.php?title=Using_Downgrade  for more details.

Available packages:

-  1)  linux510-zfs    2.0.0  8  x86_64  (local)
-  2)  linux510-zfs    2.0.1  6  x86_64  (local)
   3)  linux510-zfs    2.0.2  3  x86_64  (local)
-  4)  linux510-zfs    2.0.2  5  x86_64  (local)
+  5)  linux510-zfs    2.0.3  4  x86_64  (local)

select a package by number: 1
loading packages...
warning: downgrading package linux510-zfs (2.0.3-4 => 2.0.0-8)
resolving dependencies...
warning: cannot resolve "zfs-utils=2.0.0", a dependency of "linux510-zfs"
:: The following package cannot be upgraded due to unresolvable dependencies:
      linux510-zfs

:: Do you want to skip the above package for this upgrade? [y/N] ^C
Interrupt signal received

Can someone please help me with this?

You simply can’t as we upgrade constantly. Most likely if you want to use 2.0 of ZFS you may need to compile it yourself from the PKGBUILDs and use the dkms versions for the extramodules.