Don't see windows in GRUB

It seems like I messed up cause I installed manjaro in UEFI mode so now my grub doesn’t see windows (which is as far as I understand using BIOS) and only boots to Manjaro (according to other forum posts here)

Although (it seems like) I figured out the problem I can’t find a way to boot into windows to uninstall Manjaro so it would be amazing if anyone could help me.

I have also tried to backup my full system with timeshift but for some reason i’m not able to resize my NTFS HDD and make another ext4 partition to back up in there.

Some details: I have dual boot Windows and Manjaro in my SSD and have a 1TB HDD; I have tried booting windows from my UEFI but nothing worked .

Sorry just in case if this question was answered, I really wasn’t able to find a solution so far :sleepy:

Have you tried to install the Grub Customizer?

When I added HDDs with additional operating systems after installing Manjaro, the Grub didn’t have os-prober running by default (thus no new OSes were discoverd) but Grub Customizer ran the update and discovered all operating systems including Windows on all HDDs (and the result can be easily edited). I don’t know whether it solves the UEFI-BIOS issue though…

grub-customizer has the potential (and likelihood) to break your boot.
And besides its not needed, and conflicts with grub in the repos.

Yes … that is your issue.

You can try to run sudo update-grub … but it probably wont find anything.

In order to get back to windows, you may be able to select it as a startup device (by hitting F12, or if your bios ofers boot selections, etc)

Hi and welcome to the forum :+1:

You probably just don’t get to see the menu of grub to choose your M$.
Just press and hold any letter key while booting to see it…

Related: GRUB Menu Not Showing On Boot, Boots into Default Kernel Instead

I tried the F12 but it didn’t work(
An it doesn’t seem like it wants to boot into live usb either (with windows)


But no I can see the grub although it is heavily customized (Manjaro’s default I guess)

I’m gonna try @cscs 's solution and see if anything happens.