Dolphin, switching from files to Places or Terminal area, changes cursor type and results in misclicks

Since the big update 2 days ago (?) my mouse cursor behaves strangely in Dolphin.

First, when I try to click the Places area (left side, top to bottom) or to the Terminal area, the cursor changes to the vertical size change cursor as I hover into these areas. What’s worse is that when I click a Place or click in the terminal (which is attached at the bottom of Dolphin), the click doesn’t register most of the time. I have to really move my mouse around and try to find the ‘correct’ place to click in order to switch to the terminal or to switch to the Downloads folder.

Can this be resolved?


Operating System: Manjaro Linux
KDE Plasma Version: 5.21.5
KDE Frameworks Version: 5.82.0
Qt Version: 5.15.2
Kernel Version: 5.10.36-2-MANJARO
OS Type: 64-bit
Graphics Platform: X11
Processors: 16 × AMD Ryzen 7 2700X Eight-Core Processor
Memory: 31.4 GiB of RAM
Graphics Processor: Radeon RX 580 Series


Is a slight bug, but it happens only when the side panel (Places) is too small. If you resize it to be larger, the click will turn back to normal behavior, and you have to make sure you do not go over the re-sizable “edge” after that, otherwise will turn back to a non clickable cursor.

Is probably known already upstream (didn’t check) and they will fix it in the next release.


Hopefully they will. Thanks.

Same here…

Same thing(dolphin, krita) after latest stable update. Had to restore system from backup. Switching to testing branch didnt help.

Let’s hope this will be resolved soon. For those of us who are Dolphin addicts, having half a dozen split tabs open at any given time, this is a serious bug :confused:

So there was a big update just now and dolphin is still not fixed.


Same here, not solved.

it’s known,there are many threads about it on Reddit.
some one gave a work around(i didn’t try):

apparently it got fixed in 5.22 and someone said there:
" That got fixed two weeks ago and distros were asked to backport the fix because the next release was still far away. So if you still see the bug, ask your distro to do the backport and subscribe to the mailing list to not miss such announcements in the future."


the workaround works! :sunglasses:

1 Like

Praise be, that worked!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.