Dolphin seg faults when moving folder+files into another on many occasions

I get this annoying issue with Dolphin where it seg faults whenever I try to move a folder with files into another with the same name.

The valgrind log is below. What I am doing is moving some wine prefix folders and files from the users folder steamuser folder as I’m restoring settings/saves after rebuilding a prefix.

This issue however happens anywhere I try to copy folders with files into another that already has said folders. Never had this issue before in non-manjaro kde distro’s

I believe the failure begins at line 412 when the actual move-into process is started. Going to try dolphin-git.

Tried dolphin-meld on git (the dolphin-git fails building for me) and the error remains.

It seems to me there could be a Qt issue on my system but I don’t understand where or how.

Installed Thunar, no problems… rip dolphin, for now it seems.

I can’t reproduce your issue, and that leads me to say it might be something on your end. Have you tried to copy the files/folders and once overwritten to delete those you don’t want anymore?

Please don’t do that, and now i have to ask if you had mixed packages from stable KDE Plasma and the GIT version ? (as we provide both), and that in combination with AUR packages related to KDE Plasma might lead to an unstable system.
Delete ~/.config/dolphinrc and also everything from ~/.cache
Run this command from terminal:

sudo pacman-mirrors -f5 && sudo pacman -Syyu plasma-framework plasma-desktop qt5-base dolphin

let me know the output.
Reboot the system after that.

I only installed the git AFTER I had issues, not before. I’ve since removed them and done the things you’ve said. Will do testing, see how it goes.

Bugger problem still persists.

A simple copying folders with folders inside overwriting an existing folder(s) with same name triggered the immediate crash of dolphin.

I thought maybe the crash was due to QT_QPA_PLATFORMTHEME=qt5ct not being set, but after configuring .profile to load in bash_profile correctly (otherwise it won’t load .profile), and setting that export QT_QPA_PLATFORMTHEME=qt5ct, and confirming with qt5ct and env in bash, the problem remains. Unless the setting qt5ct is causing the crash (may be default behavior also).

Another pastebin for good measure, took longer to do this time, maybe qt5ct was doing more work, basically did this with very low fps and response, but I got the crash still. (marked action start point)

The crash appears to happen around the time I selection Apply to all. Changed whole desktop theme and qt5/gtk theme a few times now with no affect :frowning:

The crash appears to happen around the time I selection Apply to all
I get the same issue here only when I select Apply to all.

Operating System: Manjaro Linux
KDE Plasma Version: 5.20.4
KDE Frameworks Version: 5.77.0
Qt Version: 5.15.2
Kernel Version: 5.10.2-2-MANJARO
OS Type: 64-bit
Processors: 28 × Intel® Core™ i9-7940X CPU @ 3.10GHz
Memory: 62.5 GiB of RAM
Graphics Processor: NV106

Hi everyone!

I just joined this forum for this specific problem also.

I just bough a Pinebook Pro and I am using Manjaro ARM with KDE/Plasma on it.

(my first experience with Manjaro and never used KDE since Knoppix in the early 2000)

Everytime I try to copy from source A to destination B and that destination B has some existing folder, if I click on “apply to all”, Dolphin crash.

If I manually click on “accept” or “yes” (not 100% sure, I am running in French - Canada) it workis.

Anyway for me to provied the logs to help debug the situation ?


I also have this problem since the the most recent update. Select “Apply to all” and Dolphin crashes.

So, it is fixed already or pending for next release?

Confirming, Apply to all option crashes Dolphin window 100% of the time in my KDE system, fully updated.

I have the same issue on my machines. Seems like an upstream bug in Dolphin.
Dolphin 20.12.1 just got released, maybe that fixes it?

Cannot reproduce this (anymore) on unstable so it seems to be fixed now. stable users can look forward to the next update…


I will wait and see. Staying on XFCE for now due to that.

Tried this solution. Well doesn’t work…

I think the problem has been fixed in mainline dep, because issue does not occur for me anymore. Dolphin 20.12.2

I did create a whole new user account and folder recently… not sure if that had anything to do with it. Worth a try if you still have this issue, create a new fresh account and test.