Dolphin filemanager hangs out

Dolphin file manager hangs for a couple minutes when I try to add a new folder to Places. And sometimes it can freeze without visible connection with my actions. Has anyone met this problem?
I noticed it a month ago i think.

UPD: Dolphin hangs even I just try hide or show any point in Places.

My system info

Hi @GuardCat,

I use KDE, so Dolphin, every day the whole day and I’ve never had a problem like this.

However, I do know a possible cause of this kind of behavior happened when Windows explorer tried to access a USB device. Or something on a network share. So it might happen with Dolphin as well.

So check that, it might fix it or it might help troubleshoot the problem. You could also try and see if the problem persists with another kernel or if that makes a difference.

Hope this helps!

Thanks for your reply! At first I thought about these problems too. But there aren’t any usb drives plugged to my pc. Even though there are some ftp folders i think they only can slow down Dolphin from starting up.
May be there is some rare bug…

FTP mount would, theoretically, do it.

If a connection times out, then it has to reconnect again. So, don’t have them automatically connect. See

Thanks for your reply! I don’t mount ftp folders, just use them by ftp address only when they are needed.
And they aren’t in Places causing the bug. So it looks like they are not to blame.

OMG! I fixed it! It is not Dolphin’s bug! It’s KDE Connect’s bug! I switched the hidden places on and found that there are a ton of points to my phone! KDE connect adds it in hidden state for every connect! Perhaps I hid one of these points several years ago and it led to adding new points with my phone in hidden state.
I discovered ~ 23 000 rows in /home/user/.local/share/user-places.xbel! I deleted all extra point and Dolphin flies like a rocket now.
And even more: it solved problems with slowly opening the file open dialog in some programs.

So I will look to KDE Connect documentation to solve the problem.

Just as I said, a remote connection.

But, I’m happy you got it right.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.