Dolphin File Manager seems to be unresponsive

I opened my laptop with Manjaro today, yesterday it seems to be all fine. But today, everytime i open dolphin, it seems to be really slow(but still work). It takes atleast 30 secs for anything to happen. It does not make my fans run fast or anything, it just is really slow. Nothing abnormal in system monitor too. Pacman prompted a system update but nothing changed after it.

How do i fix this?

If you have the package xdg-desktop-portal-gnome installed, remove it and replace it with xdg-desktop-portal-kde.

kde one was already installed and GNOME wasnt.

Also, i just noticed, this problem isnt there when my external SSD is connected. Its smooth as usual.
It might be continuously checking for my SSD? idk

1 Like
  1. When you said you opened your laptop today did you mean opened after hibernation?
  2. Do you have an entry in /etc/fstab for your external SSD?

No, i booted it actually, but didnt fix after a restart.
Yes it is in fstab.

Try to comment that entry and restart the system.

Yea, Dolphin works fine now, but will this affect my plex media server(ref: my previous post)?

Is external SSD connected by USB?

Yes, it is connected by a cheap SATA to USB cable, which does the job.

By the way,I connected my SSD and it mounted to the spot it was supposed to, so I guess i shouldnt expect any problem?

Well, you never know but if you do just create a new topic :slightly_smiling_face:

1 Like

Commenting out the entry is not required, but I suspect that it doesn’t have the nofail mount option, and that it’s set to mount automatically.


Oh yes, I am automounting it using systemd. But the entry in fstab also has the nofail option.
Also it seems now that Dolphin will not open at all.

The mount entry in systemd:

Description=Mount Multimedia (/srv/mmedia)



This is the automount entry in systemd:

Description=Automount backup partition



The /etc/fstab entry:

#UUID=1bcf4134-86d3-4721-9900-4bd126368ed5 /srv/mmedia    ext4    defaults,noatime,noauto,nofail 0 0

Using flatpak dolphin now, so far no issues.