Dolphin drag & drop files, CTRL moves instead of copies?

You know how by default if you drag and drop a file, you get a popup asking you to clarify if you want to move, copy, or link the file? And it shows which key you hold to get the effect so the popup doesn’t happen? SHIFT for move, CTRL for copy, and ALT for link.

Well, when I hold CTRL it MOVES the file instead of copying it! This is getting pretty dangerous, as files I expected to be somewhere are no longer there because I thought I was copying…

That is part of the Non Modal Dialogs
https://userbase.kde.org/Dolphin/File_Management#Non_Modal_Dialogs
and AFAIK is hardcoded, can’t be changed. It works on two of my installs i tested. There must be something on your end. Does the same if you log in a TEST user, live media?
Using the dialog instead of shortcuts, does what is showing on it, or does the same as you described?

I don’t get this behaviour when copying between 2 Dolphin windows or Dolphin tabs (Ctrl is held down all the time while I’m doing this):

What are you doing differently?

:thinking:

1 Like

Well, as expected, booting from a live USB of Manjaro behaves correctly - holding CTRL causes the dragged file to have the little green + icon on it, to tell you it’s about to copy when you drop the file, and the file is indeed copied.

Back in my own installation of Manjaro, when I drag & drop and rely on the pop up menu, yes it works correctly. It’s only when I try to save time by holding CTRL instead, it moves. And while that happens, the green + icon does not show.

Okay I’m testing it again now while writing the post and it’s working properly. I swear to Zeus it was behaving the way I described when I wrote the post. Let’s consider it solved for now and I’ll come back if it happens again… :expressionless:

Ok I worked out the problem. You have to be very careful when dragging & dropping with modifier keys.

The modifier key only takes effect if you MOVE the mouse cursor while holding it! If the cursor is stationary for whatever reason, and you hold the key, then drop the file, the modifier does not take effect! In fact it doesn’t even pop up the options - just defaults to a move operation! This is a bug as far as I can tell.

Because if you do a quick drag and drop, hitting the modifier key just after the drag and releasing just before the drop, you have a strong chance of the mouse not having “moved” as far as Manjaro is concerned, and you will trigger this bug, even though you qualified by releasing the mouse button before letting go of the modifier key. I’ve been dropping files this way in Windows with no issue.

I think I’ll have to log a bug.

That’s the expected behaviour. If you want to change that, you have to install accessibility addons which will allow you to push the Ctrl key once.

Thanks for insinuating that I’m “lesser-abled”… kind of rude, and the irony is it’s because I’m used to other distros and Windows where I can pull this off with a flick of the wrist without issue for years, to the point where I’ve gotten used to it. Additionally, I’m triggering a situation where the pop up menu fails to show, and no modifier icons appear, yet it unexpectedly performs a file-move, without warning or explanation. So now, I’m slowing right down, paranoid the operation will fail. I have folders with missing files due to this unexpected behaviour.

The expected behaviour is the modifier key should immediately do it’s job when you press it, there’s no reason for the delay other than it being an oversight.

Therefore, I’ve changed the solution back to my previous post.

I think @Fabby was referencing ‘accessibility’ addons or settings and the like.
(albeit a bit fumbled … I dont think it was meant derogatorily)
Please remember that this is an international forum.

1 Like

:uk: is only my third or fourth language depending on how you count and no insult was intended at all. The post was edited to show “accessibility add-ons” and I wanted to point out they might help. If they don’t, feel free to ignore that particular suggestion…

I’m not sure…
I’m not sure to understand what said @Domarius but if you need to keep the modifier key hold during the drag and drop for it works… i don’t understand why dolphin fall back to a move operation if you don’t do it… it should fall back to the standard and show the pop up to choose the desired operation. I think it’s what @Domarius called a bug. And if it’s what happen i also think so . As he chose the modifier key to do a copy… i understand the operation was not done correctly but why to fall back to move??? :thinking:

I will need to experiment to understand exactly what behaviour @Domarius experiment

1 Like

As far as I can remember, it’s always been the default in Plasma:

  • If you do nothing the helper icon will show up (to allow for touch interfaces)
  • If you use Ctrl it defaults to copy
  • If you use Shift it defaults to move
  • If you press and release any key it defaults to keyboard interface (not touch interface) with a copy to an external medium (MTP, CIFS mount, …) and a move on your local file system.

And it was like that on KDE 4, except for the touch interface. (first bullet point)

As I’m an :older_adult: my :brain: might be failing me, but that’s how I remember it…

:man_shrugging:

If he detected a key press… i would fall back to the desired key that were pressed if it is shift or ctrl it would be a saner way to do it… and the other behaviour (keyboard interface) in case of any other key just my opinion… and in all cases i never liked to have 2 different behaviour depending of the origin and destination location (on Windows or Linux)

That would be a feature request, not a bug…

:man_shrugging:

Firstly, my commendations to all the work done on Manjaro, it’s my favourite distro. I’m posting at length to identify the issue more clearly. Secondly, my response now looks like an overreaction since Fabby edited his post. But offence intended or not, this isn’t a case for accessibility software.

The items in bold should not be two separate possibilities! But even so, when I try the last option, press & release, I still get the popup when I drop the file. I am not entirely sure what causes the “surprise move” bug, all I can tell you is I saw it happen a number of times once I was looking for it, but not every time.

In any case, as a computer user of 30 years, I should not have folders with files missing that I did not intend, that I now have to restore from a git backup. (The copies I made have been edited.)

As for the lesser issue of the modifier key not taking effect immediately; this would fine if if the pop up appeared every single time. Still, I should not have to move the mouse to see the result of the modifier key. I should be able to click & drag, hold still, and press the modifier keys on and off and see the little copy or move icon coming and going with each press, like it does in other interfaces.

Yes I much prefer Manjaro’s pop-up! Windows default for “move within drive” and “copy between drives” is a practically invisible decision, and requires you as a user to stop and think, “are these two folders on the same drive, or a different drive?” And it slows you down. As soon as I saw Manjaro’s pop up, I immediately thought - that is SO much better. Now if only it didn’t trigger this “surprise move” bug when I copy with my new-found confidence… :confused:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.