Dolphin Can't Open OpenOffice Files

Whenever I try to open an OpenOffice file from Dolphin, it first asks me whether I trust the application, then tells me that the application is not executable.

An example is attempting to open an ODT spreadsheet with LibreOffice Calc:

First I get a warning- (Note this is not a code response from the terminal. this is just the text from the dialog produced by the GUI. Easier than providing a screenshot.)

Warning - Dolphin
This will open the program:
LibreOffice Calc
If you do not trust this program, click Cancel.

Upon clicking “Continue,” it throws me this error message-

Unknown error code 100

Unable to make the service LibreOffice Calc executable, aborting execution.

Existing file /usr/share/applications/libreoffice-calc.desktop is not writable.

Please send a full bug report at https://bugs.kde.org.

Now if I enter LibreOffice Calc first and open the file from within Calc, I have no problem.

  • Does this also happen if you create another user, log in there and double-click on a file there???
    • If yes, please uninstall LibreOffice completely, removing all settings and then install it again:

      pamac --no-save remove libreoffice*
      pamac install libreoffice*
      
    • If no, please report back.

:+1:

It seems to be specific to my user. Everything worked fine on the test account.

So re-installing LibreOffice did not make it work under your old user? (Unsure from your rather cryptic feed-back…)

:thinking:

No; you said to report back if I was able to open files from Dolphin on the new account. I was. I created the test account, logged in, and successfully opened several LO files directly from Dolphin. The problem still persists on my user account; though I haven’t tried re-installing via CLI

I’m an idiot! My apologies! :man_facepalming:

As it does work under your new account, we’re going to do the following:

  • Verify that the new user has access to the same groups as your old one by executing groups and comparing the output of both users.

    groups U45
    groups U45-2
    

    (Where obviously, U45 is your old user and U45-2 is your new one.)
    E.G. if U45 is a member of operator and U45-2 isn’t, execute:

    usermod --append --groups operator U45-2
    
  • Copy all data files from your old profile into your new one

    cp --verbose --recursive --preserve=time-stamps /home/U45/Documents/* /home/U45-2/Documents/
    

    If that worked and you had no errors, remove the documents from your old user:

    rm --recursive /home/U45/Documents/*
    

    repeat for:

    • Pictures
    • Videos
    • Music
    • .thunderbird
    • .mozilla/firefox/
    • Templates, and everything else that is important to you.
    • Linux games like Battle of Wesnoth have their game data stored under ~/.local/share/ E.G. ~/.local/share/wesnoth/

    After everything has been copied over, disable the old user so you cannot accidentally log on:

    usermod --lock U45
    

    If you would have theming going on, don’t do everything in one day but do this at the rate of 1 application / theme / whatever per day and if the problem crops up again, roll back your last change

  • in 1 month delete the entire home directory of your old user, but don’t delete the user itself so that in 6 months time files still owned by that user will still show up under its username.

  • If you ever migrate to a new machine, just don’t migrate the old user: only the new one.

  • From now on, start making backups so you can roll back and never have to do this again:

:+1:

So I got it working again, at least for now, by some stroke of luck. I looked back at the error message I was getting every time I tried to open a file from Dolphin. It read:

Existing file /usr/share/applications/libreoffice-calc.desktop is not writable.

So I navigated to /usr/share/applications and noticed that there was an exclamation point icon overlaid on each of the libreoffice application links. On a hunch, I logged out and logged into the test account, navigated to the same location, and sure enough, the exclamation point icons were missing. When I logged back into the old account and navigated back to the same place, the links looked normal. The exclamation point icons were gone. I tried opening up a libreoffice document and, boom, it worked. Did it several times with different file types; no issues.

Not sure what I did, but while uninstalling and reinstalling the LO package, it kept informing me of conflicts between libreoffice-still and libreoffice-fresh. So I made sure to specify that I was installing only libreoffice-still.

This spontaneous tinkering seems to have solved the problem. Gonna reboot to make sure.

EDIT: Spoke too soon. Problem still persists upon reboot. There’s probably a solution there somewhere, but I don’t have the time nor expertise to go looking for it. Is there a why to transfer admint control to a new account?

Yes, just follow the procedure above exactly… I.E. this bit transfers admin:

I assume U45, U45-2, and operator are just placeholder names?

Granting group access went smoothly, though I did have to use sudo to accomplish it. I keep all my files on a separate disk, so there wasn’t anything I needed from my home directory.

I tried to perform the recursive deletion of all files in the old home directory from the new account, but I was told the directories didn’t exist; even when I used sudo.

Since the old /home will be deleted in a month’s time anyway, I went ahead and locked the account.

1 Like

I have to go with the information I have:
2020-10-16_20-19

I never put any sudos anywhere so people don’t blindly copy paste “ze codez” :grin:

magic needs to be performed then: sudo -s and you’re actually root in a root command shell. Be very careful!

:+1:

So, I’ve marked the below answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

:innocent:
P.S. In the future, please don’t forget to come back and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
Solution
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

My bad. Will do.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.