Doesn't boot with newer Kernel, why?

Installed new Kernel 5.13, but after reboot it’s still stuck at older Kernel 5.12:

It’s a dual-boot system with two Manjaro KDE partitions.
Already updated to Kernel 5.13 on the other (first) partition sucessfully, because it will only switch to newer Kernel on second partition if the first partition is already on new Kernel.
This is, because the first install owns grub?

But now it doesn’t switch to newest Kernel anymore on partition 2 (second Manjaro KDE install).

I uninstalled Kernel 5.12 while using it to force 5.13, but no reboot anymore, had to reboot manually with Kernel 5.10 to install 5.12 again to be able to boot.
How can this be solved?
How can i set ownership of grub to the second installation?

Already tried update-grub.
Please help.

System:    Kernel: 5.12.19-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.22.4 Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASRock model: A300M-STX serial: <filter> UEFI: American Megatrends v: P3.60K date: 07/22/2020 
CPU:       Info: Quad Core model: AMD Ryzen 5 3400G with Radeon Vega Graphics bits: 64 type: MT MCP cache: L2: 2 MiB 
           Speed: 1277 MHz min/max: 1400/3400 MHz Core speeds (MHz): 1: 1277 2: 1361 3: 1255 4: 1262 5: 1278 6: 1272 7: 1261 
           8: 1262 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Picasso driver: amdgpu v: kernel 
           Display: x11 server: X.Org 1.20.13 driver: loaded: amdgpu,ati unloaded: modesetting resolution: 1: 1920x1080~60Hz 
           2: 1920x1080~60Hz 
           OpenGL: renderer: AMD Radeon Vega 11 Graphics (RAVEN DRM 3.40.0 5.12.19-1-MANJARO LLVM 12.0.1) v: 4.6 Mesa 21.2.1 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel 
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio driver: snd_hda_intel 
           Sound Server-1: ALSA v: k5.12.19-1-MANJARO running: yes 
           Sound Server-2: PulseAudio v: 15.0 running: yes 
Network:   Device-1: Intel Wireless-AC 9260 driver: iwlwifi 
           IF: wlp3s0 state: up mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 
           IF: enp4s0 state: down mac: <filter> 
Bluetooth: Device-1: Intel Wireless-AC 9260 Bluetooth Adapter type: USB driver: btusb 
           Report: rfkill ID: hci0 state: up address: see --recommends 
Drives:    Local Storage: total: 1013.5 GiB used: 350.25 GiB (34.6%) 
           ID-1: /dev/nvme0n1 vendor: Silicon Power model: SPCC M.2 PCIe SSD size: 953.87 GiB 
           ID-2: /dev/sda type: USB vendor: Crucial model: M4-CT064M4SSD1 size: 59.63 GiB 
Partition: ID-1: / size: 468.3 GiB used: 350.25 GiB (74.8%) fs: ext4 dev: /dev/nvme0n1p2 
           ID-2: /boot/efi size: 299.4 MiB used: 280 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 
Swap:      Alert: No swap data was found. 
Sensors:   System Temperatures: cpu: 47.0 C mobo: N/A gpu: amdgpu temp: 35.0 C 
           Fan Speeds (RPM): fan-1: 0 fan-2: 0 fan-3: 0 fan-4: 0 fan-5: 0 
Info:      Processes: 243 Uptime: 16m Memory: 23.47 GiB used: 1.84 GiB (7.9%) Shell: Bash inxi: 3.3.06 

Only one grub is installed et you run update-grub in bad manjaro; run in other in after all is ok

1 Like

What is the default grub entry?
cat /etc/default/grub | grep GRUB_DEFAULT (in grub owning system)

1 Like

Already solved the issue not switching to 5.13. See papajokes posting. :+1:

cat /etc/default/grub | grep GRUB_DEFAULT (in grub owning system)

# line, and set GRUB_DEFAULT to saved.

Is there a way to switch grub owning system?


cat /etc/default/grub
GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor udev.log_priority=3"

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices

# Uncomment to use basic console

# Uncomment to disable graphical terminal

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'

# Uncomment to allow the kernel use the same resolution used by grub

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"

# Uncomment to disable generation of recovery mode menu entries

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.

# Uncomment one of them for the gfx desired, a image background or a gfxtheme

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

# Uncomment this option to enable os-prober execution in the grub-mkconfig command

is this Key !
“saved” == load last linux/kernel user choice
but we can also pass a number if you want force one entry

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.