Does `reboot -f` risk causing damage to the system?

Goodmorning everyone.
I recently discovered the Manjaro operating system and, after trying it on virtual machines, I decided to install it on my Laptop.
I then downloaded the 18.0.2 version of Manjaro Deepin and installed it without problems, correctly receiving all the updates.
I noticed, however, that after installing the latter, it is no longer possible to shut down the computer using the DE buttons. I then tried to use the command sudo shutdown -r now, but this only returned the following message: Failed to talk to init daemon.
To restart the PC I then had to use the command sudo reboot -f and, at power on the problem seems to be solved.
I wonder however: if it should happen again, forcing the reboot does not risk causing damage to the system? If so, is there a way to restart the aforementioned init deamon?

systemctl reboot
and
systemctl poweroff

should work

1 Like

I tried systemctl reboot, but it only replied that I am not authorized to do that operation.

Post the out put of this please and format it as shown in the thread :grinning:


Also that is a very old ISO. Last time I tried it it gave me the same issue. I believe and don't quote me on it, upgrading the kernel fixed it. You must have done 600+ updates :scream:
uou could also try this ISO https://osdn.net/projects/manjaro-community/storage/deepin/18.1.0-pre1/
But be warned it is using the unstable branch and is a minimal ISO so you will have to add the applications you want yourself. You could always install it and then switch to the stable mirrors.

1 Like

Yes, I saw ISO 18.1.0, however, as you wrote yourself, it uses unstable branch, while I need a stable system...

In any case, these are the specifications of my computer:

System:
  Host: Ricky-2nd-Laptop Kernel: 4.19.49-1-MANJARO x86_64 bits: 64 
  compiler: gcc v: 8.3.0 Desktop: Deepin 15.10.1 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: LENOVO product: 20324 v: Lenovo IdeaPad Flex 10 
  serial: <filter> 
  Mobo: LENOVO model: IdeaPad Flex10 v: 31900050Std serial: <filter> 
  UEFI: LENOVO v: 93CN58WW date: 04/10/2015 
Battery:
  ID-1: BAT1 charge: 17.6 Wh condition: 19.4/23.2 Wh (84%) 
  model: SANYO L13S3Z61 status: Discharging 
CPU:
  Topology: Dual Core model: Intel Celeron N2806 bits: 64 type: MCP 
  arch: Silvermont rev: 3 L2 cache: 1024 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 6401 
  Speed: 533 MHz min/max: 533/2000 MHz Core speeds (MHz): 1: 533 2: 533 
Graphics:
  Device-1: Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display 
  vendor: Lenovo driver: i915 v: kernel bus ID: 00:02.0 
  Display: x11 server: X.Org 1.20.5 driver: intel unloaded: modesetting 
  resolution: 1366x768~60Hz 
  OpenGL: renderer: Mesa DRI Intel Bay Trail v: 4.2 Mesa 19.0.6 
  direct render: Yes 
Audio:
  Device-1: Intel Atom Processor Z36xxx/Z37xxx Series High Definition Audio 
  vendor: Lenovo driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Sound Server: ALSA v: k4.19.49-1-MANJARO 
Network:
  Device-1: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter 
  vendor: Lenovo driver: ath9k v: kernel port: 1000 bus ID: 01:00.0 
  IF: wlp1s0 state: up mac: <filter> 
  Device-2: Qualcomm Atheros AR3012 Bluetooth 4.0 type: USB driver: btusb 
  bus ID: 1-4.2:7 
Drives:
  Local Storage: total: 465.76 GiB used: 9.11 GiB (2.0%) 
  ID-1: /dev/sda vendor: HGST (Hitachi) model: HTS725050A7E630 
  size: 465.76 GiB 
Partition:
  ID-1: / size: 453.19 GiB used: 9.10 GiB (2.0%) fs: ext4 dev: /dev/sda2 
  ID-2: swap-1 size: 4.03 GiB used: 1.8 MiB (0.0%) fs: swap dev: /dev/sda3 
Sensors:
  System Temperatures: cpu: 48.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 145 Uptime: 13m Memory: 1.83 GiB used: 1.04 GiB (56.9%) 
  Init: systemd Compilers: gcc: 8.3.0 Shell: bash v: 5.0.7 inxi: 3.0.34
sudo systemctl poweroff

@dlgt :ballot_box_with_check:

As I had previously written the command sudo systemctl reboot did not work, but since you "insist" on advising me to use sudo systemctl poweroff, I will try it as soon as I install the same ISO on my other laptop.

Because that command works - it even works without sudo but as you wrote in earlier you tried reboot without sudo and failed.

So something is off with your system and it could be that your systemd has been updated as this can cause temporary systemd failures.

But pressing your power button a few seconds usually initiates a clean shutdown.

If nothing works there is something off/weird on your system and I advice you to do a complete update using TTY either on your installed system or manjaro-chroot on a live ISO.

Using TTY CtrlAltF4 and login

sudo pacman-mirrors -c Germany && sudo pacman -Syyu

Boot live ISO and swithc to TTY like above then login using credentials manjaro:manjaro

Use the below command and select the system - if only one usually the 0

manjaro-chroot -a

Then

pacman-mirrorrs -c Germany && pacman -Syyu

Today I installed and updated Manjaro on my other laptop and, as I expected, the init daemon doesn't respond.
I then tried the command sudo systemctl poweroff, as you suggested, and this is the precise output:

Failed to power off system via logind: Unit systemd-poweroff.service has a bad unit file setting.
Failed to start poweroff.target: Access denied
See system logs and 'systemctl status poweroff.target' for details.

Since I imagine the status of the target could be useful, I quote it below:

● poweroff.target - Power-Off
   Loaded: loaded (/usr/lib/systemd/system/poweroff.target; disabled; vendor preset: disabled)
   Active: inactive (dead)
     Docs: man:systemd.special(7)

Did you install and update from a new ISO?

It's normal there are some incompatibilities with very old ISOs because the installation paths change and your configuration files can be doubled and in different folders. Check your systemd --system config tree and open the various files to see if they are in conjunction. If all this is happening to a fresh installation or in live env, then there could be a hardware specific bug with systemd but there really shouldn't be one.

I installed (and later upgraded) Manjaro Deepin 18.0.2 on both PCs, the most recent downloadable from the stable channel.

Like I said your best bet is the unstable ISO and then DOWNGRADE to stable via the stable mirrors or to not use deepin at all really. I never really understood the fascination people have with this DE. It's certainly not special in any way I can see.