Does it still make sense to use Swap with Btrfs?

you are writing

It means your reference configuration is based on base. But the standard in Manjaro KDE Plasma seems systemd. Also I am using systemd. Checking just with ps -p 1 -o comm=
Also have not found your mentioned “base” but “init” for example.
How should the reference configuration look like with systemd than? Or have I understood you wrong?

The reference configuration is Manjaro Linux default for this particular usecase.

There is a topic discussing which HOOKS would be correct and what syntax should be used

And comment referencing what choices can be made and why one would choose to do so.

I don’t think it applies for this discussion - which is using the default Calamares to install btrfs with encryption and swap.

Please educate yourself using the provided links above

For the first notebook I have installed the configuration as you described. Here summarized with all comments. Of course I used the UUID of my own Swap partition. “resume” was already set by installation.

But hibernation does not work. If I press hibernation a dark screen appears as if it wants to turn off but shortly later the login screen appears.

I) btrfs with swap with hibernation without encryption
(source by ManLuxer) and updated by me.
In order for waking up from hibernation to work, the swap partition in the boot loader must be passed to the kernel with the resume option.
First you must do an Calamaris installer with swap-hibernation-btrfs but no encryption.

  1. With GRUB this can be set up permanently by first editing the file
    sudo nano /etc/default/grub or
    sudo micro /etc/default/grub if you have micro editor installed. I like it more than the standard nano.
    resume is added to the line GRUB_CMDLINE_LINUX="" together with the swap partition UUID.
    The swap partition UUID you can find by lsblk. For more information you may use sudo blkid It should look like this but with your UUID
    sudo update-grub

  2. resume must be added to HOOKS in the file /etc/mkinitcpio.conf (after udev!).
    The modified line finally may look like this:
    HOOKS="base udev autodetect modconf block keyboard keymap consolefont plymouth encrypt resume filesystems"
    Avoid copy/paste to the grub file; noting the quotation marks used in the forum “ which have been known to cause issues.

  3. sudo mkinitcpio -P && sudo grub-mkconfig -o /boot/grub/grub.cfg

  4. Now hibernation DOES NOT work.