Docker support?

raspberrypi

#1

Hello!
I’m running a Raspberry Pi 3 with Manjaro-arm, trying to run it as a home server.

Since a few of the services I’m trying to run weren’t able to properly install, I wanted to give docker a try, but when I try to start the service:

$ systemctl start docker
Job for docker.service failed because the control process exited with error code.
See "systemctl status docker.service" and "journalctl -xe" for details.
$ systemctl status docker.service
level=warning msg="Running modprobe bridge br_netfilter failed with message: modprobe: WARNING: Module bridge not found in directory /lib/modules/4.14.54-2-MANJARO-ARM\nmodprobe: WARNING: Module br_netfilter not found in directory /lib/modules/4.14.54-2-MANJARO-ARM\n, error: exit status 1"
level=warning msg="Running modprobe nf_nat failed with message: `modprobe: WARNING: Module nf_nat not found in directory /lib/modules/4.14.54-2-MANJARO-ARM`, error: exit status 1"
level=warning msg="Running modprobe xt_conntrack failed with message: `modprobe: WARNING: Module xt_conntrack not found in directory /lib/modules/4.14.54-2-MANJARO-ARM`, error: exit status 1"
Error starting daemon: Error initializing network controller: error obtaining controller instance: failed to create NAT chain DOCKER: iptables fail>
iptables v1.8.0 (legacy): can't initialize iptables table `nat': Table does not exist (do you need to insmod?)
Perhaps iptables or your kernel needs to be upgraded.
(exit status 3)

It seems that I lack a few kernel modules. Does that mean that I’d have to recompile the kernel with these modules? Being quite unexperienced with cross-compiling kernels, I’m afraid that I’d rather try out raspbian then, which presumably supports docker out of the box.

Thanks in advance ^^


#2

I’m no expert on kernels, but can you make sure you have the kernel headers installed?

A quick google also reveiled this site, I assume you tried this?

@dodgejcr Did we ever hear back from the Docker people?


#4

Thanks for the fast response. The guide you posted is for raspberry pi 1 (ARMv6) and thus incompatible as-is for the raspberry pi 3.
The script (as far as I understand) basically installs the kernel headers needed (which I didn’t do previously, so thanks for that) and then installs docker from pacman. Both are things I did manually and the problem sadly persists. :frowning:

Ok, apparently, I installed the headers for kernel 4.14.69, but I’m running 4.14.54. But I can’t update my kernel to4.14.69 through pacman:

$ uname -r
4.14.54-2-MANJARO-ARM
$ sudo pacman -Syu
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
:: Starting full system upgrade...
warning: tzdata: local (2018e-2) is newer than core (2018e-1)
 there is nothing to do


#5

Ah, I think I know what’s going on there.
It’s a server side problem regarding the headers. I’ll fix that when I get home today. And rebuild the kernel.


#6

Great! Thanks a lot! :smiley:


#7

Btw, which services are these?


#8

In particular Firefly-III. Building it requires the library icu60, but pacman only suplies icu62. And building icu60 from the AUR failed on the raspberry pi.

I guess that’s a problem, the firefly-iii dev would have to fix (I seriously don’t know why someone would want to code in php in 2018…)

That was the first service I tried to install. But in case, another service doesn’t run as planned…


#9

That’s an AUR package. And it has been reported out-of-date. Nothing to do, but wait until the package manager fixes it, or edit the PKGBUILD yourself for the new version.


#10

Already tried updating the PKGBUILD, but it didn’t work. The problem stems from the composer package.
Also, the AUR package seems abandoned.


#11

Just checked the repo. The repo does contain kernel 4.14.69 + it’s headers.
You might be on an out-of-date mirror.
Try running sudo pacman-mirrors -g && sudo pacman -Syyu

Or did you simply not reboot after updating/installing kernel and headers? :slight_smile: