Dock context menu moves away when application is opened


Today I installed Manjaro Gnome and fully updated the system. After the update I found a bug (gnome 40.3.0, kernel 5.10.56-1-MANJARO, NVIDIA proprietary drivers).

If I right click on any closed application’s icon in the dock, I get a context menu. If I then open this application and right click on it’s icon in the dock then the context menu is moving on my second monitor’s left upper corner. I tried disconnecting second monitor, problem still exists (context menu moves to the left upper corner of current monitor or completely disappears).

The menu is frozen and I can’t select an option in it. It stays in the corner even after I close the application. The only way to remove it is to use activities menu or restart gnome session.

I usually use right click in the dock to open new window. Now I can’t find out how to open second nautilus window (for example) without terminal or hotkeys. I started exploring the bug and found out that using traditional or GNOME (because it has dock only in activities :slight_smile: ) layout fixes the bug. I can work with them but I prefer modern layout.

What could be the problem and is there any solution? If it is a bug, how can I report about it to developers? Is it an upstream bug or dash to dock bug?

Unfortunately, I can’t attach images of problem. If it requires a more detailed description I will be glad to complete my description.

With best regards,

I have the issue with Dash To Panel and e.g. alacritty, does noty happen with the other default apps. I switch to Dash To Panel anyway normally, there it’s gone, so maybe …

Opening a new Nautilus window is Ctrl+N

EDIT: FWIW - Steps to reproduce: fresh manjaro GNOME 40 install (21.08 or 21.1RC3). Right click on Terminal: exptected behaviour. sudo pacman -Sy alacritty, Super-L > alacritty, right click icon in dock: Error happens (Context menu is floated to the top left corner on a 1-screen setup, gets unresponsive)

I did not look in the logs, as this does not bother me myself, just some quick steps how to quickly reproduce it without much ado

I checked the Extensions app and tried to change settings of dash-to-dock. I couldn’t change them because of an error. It seems that there is no version of DtD for Gnome 40.

Fortunately, installing and reinstalling gnome-shell-extension-dash-to-dock fixed the problem

1 Like

I also have this issue on a fresh install today.
How it manifests varies. Right-clicking on the Trash in the dock, or on an app which is running. Clicking the Show Applications icon makes the stuck dialogue in the corner go away & then you cant right click on running apps at all. I tried x11 but it was the same, perhaps it is a gnome 40 bug.

I fixed this issue following this advice (remove dash-to-dock schemas folder)
The extension can now be used properly & the dock right-click menus function normally.

Kuznero’s post:


Uninstall/Re-install of Dash-to-Dock fixed it for me as well.