Do kernels get changed when updates are applied?

Hi there,

Fairly new to this whole Linux experience so please bear with me.

As the subject line implies, I am wondering if the latest large update (240 some items) changed my kernel. Does it do that by default? I will keep a closer eye on that in the future.

Reason being I am experiencing lots of trouble with wifi when coming out of sleep mode. Overnight and/or during the day if the laptop goes into sleep mode when I come back it will not see my card nor id any available networks around me (mine or neighbors).

Maybe I’m not even looking in the right direction here, being a newb I’m not sure. But it most definitely started after the latest set of package updates.

Sometimes it needs a restart others after trying two or three times on it’s own to connect it will find everything and be fine.

Not the end of the world but annoying no doubt about it.

If this has nothing to do with a kernel update then I’m sorry for posting in the wrong place. This happened once before and took me all night to finally get back up and functioning. After trying so many different suggestions I wasn’t sure what actually fixed it I was so brain numb. I do remember going back and forth between kernels though and eventually something worked.

Hope any of this makes sense, further details needed just ask please.

Current kernel is 5.10.18-1 and I also have 5.9.16-1 installed. Is there a way to find out what was running before the current one?

Wifi card is: Broadcom Inc. and subsidiaries BCM4313 802.11bgn Wireless Network Adapter (rev 01)

I am running Manjaro Nibia 20.2.1 with Kde.

Hope that’s enough info and I made any sense, if any further details are needed pleas just ask.

Thanks in advance for any replies!

If you’re curious to what was installed during an upgrade, you can check the log in /var/log/pacman.log

Hmm, not seeing any specific kernel numbers and a lot of stuff that I’m not sure about but I do see this at the end.

Kernel has been updated. Modules of the current kernel
[2021-03-02T19:50:29-0500] [ALPM-SCRIPTLET] → have been backed up so you can continue to use your
[2021-03-02T19:50:29-0500] [ALPM-SCRIPTLET] → computer. However, the new kernel will only work
[2021-03-02T19:50:29-0500] [ALPM-SCRIPTLET] → at next boot.

So I guess that means it did update it. Not jumping to any conclusions about what is causing the problems. I will continue to read! I do have a “snapshot” before the updates if it continues to be a problem. So maybe that’s an option.
Like I said not end of the world but it is annoying.
Thanks for the reply/advise!

Make sure you reboot after you install updates like the kernel. Sometimes the system behaves strangely until this is done. Also the updated kernel is not applied until after a reboot.

It should only change your kernel by default if you have linux-latest installed, which is a meta package. The Manjaro Team chooses which kernel the linux-latest package installs, and it is currently 5.10, before it was 5.9

Also it will replace an End Of Life kernel with this meta package. But it is the only way Manjaro will change your kernel automatically. It will UPDATE the installed kernels though by itself during system update. But it will not change to another kernel version without a critical reason (like the kernel doesn’t exist anymore in the repositories).

1 Like

Just looked this up and yes that is installed 5.10-1. Just came along with some package update I guess, not something I got on my own.

Technically, it was you who installed it :slight_smile:

Upon doing sudo pacman -Syu, it asks you to replace your kernel that is EOL with the linux-latest package, and you have to press Y (default, or pressed enter) or N. I don’t know if pamac does the same thing or not though. I don’t use the linux-latest package myself.

1 Like

Ha! Good One! :grin: So true now that you mention it.

I have done it both ways in the past but mainly pamac for the more recent past. Still reading along in other groups/topics (wifi problems and such) but thanks for the replies!

Hi,

If anyone is still reading this.

I gave 5.11.1-1 a try and still have the same problem. Not another question though.

When I try to uninstall 5.10.18-1 from the list to get back to 5.9.16-1 (last one that everything was working fine on) it gives me this:

linux510
linux510-broadcom-wl
Starting
checking dependencies…
:: removing linux510 breaks dependency ‘linux510’ required by linux-latest
error: failed to prepare transaction (could not satisfy dependencies)
Done …

So then I can’t go back and try 5.9.16-1, right? I seem to be stuck on 5.11 or 5.10 which neither are letting me connect wireless.

Still curious about this kernel issue since I thought you could “roll back” if wanted/needed. If I can’t remove the one listed prior it will not go to the next oldest one correct? If I’m missing something and I usually am just let me know.

Thanks for the help so far! I also started a thread in the wireless group since that seems to be where the problem is.

If you still have kernel 5.9 installed on your computer, you just need to select that kernel in your bootloader you use to boot into. But it is EOL, meaning the kernel is now unsecure as it will no longer get updates and patches.

You can install 50 kernels, and boot into any of them in your bootloader, regardless if it’s older or newer.

If neither kernel 5.10 or 5.11 is working for you, try kernel 5.4

You can use journalctl to check what kernels you used in specific boot times.

i.e.

journalctl --list-boots
jorrnalctl -b <input a boot ID from the above command>

You can’t uninstall kernel 5.10 without uninstalling linux-latest, because linux-latest is a meta package that is currently using kernel 5.10 as a dependency, telling your system that it must have kernel 5.10 installed.

Great info thank you!

I was under the impression I had to uninstall the previous listed kernel before the system would reboot with the next one. I’m not presented with a bootloader screen of any kind, I will have to look into that.

I guess there isn’t much point in going back to 5.9 then? I will keep trying to find out what’s going on over in the wireless group.

Oh, if you read this is there a way/command/key to get through that massive list when I used journalctl ? It starts all the way back in June of 2020, that’s a lot of lines to scroll down. Just wondering.

Thanks agai!

The bottom of journalctl --list-boots are the more recent boots. It lists every single boot you’ve done from oldest to latest, the very bottom should be your current boot.

You can do jorrnalctl -b <input a boot ID from the above command> | grep kernel or grep anything you want to find. | grep can be used for any other commands to that outputs something in the terminal.

1 Like

I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

:innocent:
P.S. In the future, please don’t forget to come back and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
Solution
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.