DNS issue: ping IP but not DNS name

Thank you, it seems the issue is not (only) about the DNS servers I am using, for three main reasons – but I may be wrong.

  • when I use the Network Interface to shift from “DHCP (Automatic)” to “DHCP (Automatic) addresses only” and add ‘’ to DNS, it does not change much (even after restarting the service)
  • when I overwrite the resolv.conf generated by NetworkManager with ‘’, it does not change much;
  • the NetworkManager, if I understand correctly, receives the DNS from my ISP provider, other computers in the house do just fine;

in the configuration you had
DHCP (Automatic)
it receives the DNS server from the router - which in turn gets its DNS from your ISP

DHCP (Automatic) addresses only
you can choose your own nameserver over the one provided by the ISP

if other devices, which connect through the same router, are working just fine
the issue is not likely to be the DNS server that your router (your ISP) provides

Indeed, given that “DHCP (Automatic) addresses only” (e.g. with DNS does not seem to change anything, any idea?

… just ideas, indeed :wink:

maybe IPv6 is used and not working?
Try turning it off to test.

I really am no expert in troubleshooting this.

What’s the content of /etc/resolv.conf?

There is a few things which can mess with your DNS - half hearted experiments with

  • VPN
  • The plethora of privacy guides which instructs you to change your dns settings
  • Some even suggests making resolv.conf immutable.
  • Adblocking on DNS level e.g. hosts manipulation
  • Pihole
  • A change here - a change there - and no record of what, where and when - making it next to impossible to roll back

A basic troubleshooting guide is available


#generated by NetworkManager
Nameserver ::1

Thanks. I’ll look into that and come back.

I followed the [root tip] it blocks with “drill” command which gives:

Error: error sending query: Could not send or receive, because of network error.

I followed the NetworkManager instructions for setting manual DNS, provided here: Networking - Manjaro, but I still get:

Temporary failure in name resolution

I am affraid I might have to reinstall the whole thing – and maybe switch back to debian.

N.B.: I do not have traceroute installed, so cannot install it.

This is the problem.

I’m not experienced with NetworkManager so I don’t know how to fix it.
Apparently, it configures your loopback device over IPv6 as DNS which doesn’t seem sensible.

Did content of /etc/resolv.conf change? If not, try manually changing nameserver to nameserver Does it work then?

You can use tracepath instead. It’s installed by default.

Hello, if that what @zbe said didnt help I guess the people who help you need more information.

If so, please provide the output of these 3 commands:

inxi -Nxx
ip addr
systemctl status NetworkManager

It still looks like this is the problem.

Turn off/disable IPv6 in NetworkManager settings.

Thanks already.


The resolv.conf had been changed with functional DNS, and it did not change anything.

@mithrial and @Nachlese

I went to the IPv6 Settings of my current connection and selected ‘Disabled’ in the method.

@kisun here are the command asked:

What is that ipv6leak interface? You must have set it up somehow.

Don’t know. Neever set it up manually. When looking online, it looks like it might be related to protonVPN. I am happy to get rid of the Interface / VPN, if necessary.

A problem that might sound similar (and remained unanswered) seem to have been flagged here: Internet not working since last update (NetworkManager doing weird stuff) (and indeed, I had to reinstall manjaro 3/4 weeks ago, for a similar problem that I could not solve).

This is looking like an xyproblem.

You are trying to fix something - then you got dns problems as a result - and now you are trying to fix the dns error without solving the underlying issue.

So you are asking for help to fix a dns issue without telling us you have been fidling with vpn?

That would be nice - at least so it is possible to know it is not interfering.

There is nothing wrong with a pristine Manjaro system with relation to dns or networking and unless there is upstream regressions - which happens occasionally - with NetworkManager - updates doesn’t cause dns issues.

This is becoming more and more difficult to help with - because we cannot possibly know which changes you have made before consulting the forum so we are practically blind with relation to how to suggest you solve the issue.

Disable ipv6 using kernel arguments - IPv6 - ArchWiki

sudo nano /etc/default/grub

Add the argument ipv6.disable=1 to the kernel commandline

Save and rebuild grub

sudo grub-mkconfig -o /boot/grub/grub.cfg

Then reboot

And please don’t post pictures of console output

I solved the problem : (1) I got rid of ProtonVPN (via Pamac), (2) I deleted the interface (sudo nmcli connection delete pvpn-ipv6leak-protection), (3) I reverted to Automatic DNS (undoing what I had done, following Networking - Manjaro), (4) I restarted the computer.

Thanks for your help – I did no change before consulting the forum, I believe I mostly wrongly assumed that ProtonVPN did not mess with DNS / Interfaces. For next time, do you have suggestions for sending the content of a console in text format from a computer that has no internet connection?

copy the text to a text file - transfer using usb

To get ouput into a file without an editor pipe the result to file

e.g. inxi

inxi -Fxxxx > ~/inxi.txt

or from systemd status

systemctl status NetworkManager > ~/status.txt

or appending several commands to the same file using a append pipe

echo inxi -Fxxx >> status.txt
inxi -Fxxxx >> ~/status.txt
echo systemctl status NetworkManager >> ~/status.txt
systemctl status NetworkManager >> ~/status.txt
echo journalctl -xe --no-pager >> ~/status.txt
journalctl -xe --no-pager >> ~/status.txt

Or if you have an android phone you can tether your phone internet on the dysfunctional system :slight_smile:

I use protonvpn - I have never experienced this issue - but hey - there is something - if you are not using systemd-resolved - the resolv.conf is not always reset correctly - especially if rebooted while connected

i know i have had nothing but problems with protonVPN. at least on linux i have. they also seem to have some bugs with their firewall. Idk. But i switched to using Windscribe and have never been happier. i only pay $2 a month for unlimited use and i cant tell the difference in internet speed whether i have it on or off. Also i just use a openvpn config from them and set it right up in the manjaro network settings instead of relying on the VPN to have a working GUI.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.