Dngconverter does not work anymore

dngconverter (AUR Adobe DNG Converter) does not work anymore.
Also installing via Wine does not work anymore, it always shows up: This program does not support the version of Windows your computer is running.
No matter if I choose Win 7, 10 or 11.


Alternative would be of course to convert the raw with digiKam to dng, but unfortunately the results are not good.

Does anyone have any ideas?

1 Like

Since when?

1 Like

Certainly since a few days, but maybe since a few weeks. There were no problems for at least two years before that, until December 2022 or even January 2023, but I’m not sure.
I have the phenomenon on two different Manjaro machines.

I downloaded a sample .dng file and it opened and converted to .jpg etc. with no issue using xnViewMP. What is so special about the Adobe offering?

The big difference is that Adobe has very good color and lens profile settings. Also, Adobe is the best contact for new cameras, whose raw are not yet supported by many converters. If they are converted to DNG, they can be processed very well. Especially the dreamlike good RawTherapee is not always up to date with the camera support. I would trust the DNG of XnView even less than those of digiKam.
In addition, I don’t want to exchange the valuable digital negatives, i.e. the raw, for the inferior jpg.
The idea is to convert the original raw to DNG while preserving the original quality and being able to write tags into it. You can’t do that in the raw, at least you risk actually destroying them. With DNG this danger does not exist.
Converting to a jpg can be done with the raw converter in any good quality.
But the raw file, or the DNG, will always be saved.

1 Like

Have you tried rebuilding it?

Oh, this totally overwhelms me. I am an eternal beginner in Linux.
Currently I have not installed the dngconverter via AUR, but I had taken the trouble to install it via Terminal using Wine. That was much more up to date.
Yesterday I needed it, but it didn’t work. No problem, I thought and reinstall it: Does not work anymore! So nothing works anymore.
Question: Can you install it on your end via AUR?

Nope, “Windows version” issue.
Though from the AUR page, the package hasn’t been updated for months…

I wonder why my dngconverter installed via Wine suddenly stopped working. Strange.
This forces me to take a break. Maybe my raw doesn’t necessarily need to be converted to DNG. At least it doesn’t work now.

I have just downgraded: wine 8.1-1 back to 7.22-1
and already I could install the dngconverter with AUR. Unfortunately, I did not succeed with the self-installation via terminal. There was the same error message.

Then please use a manager like bottles. I saw the same message. I downloaded the latest version: 15.2 from the adobe page and just installed it without issues.

And yes, there must be a change of the windows api which checks the version:

00ec:err:module:import_dll Library api-ms-win-core-versionansi-l1-1-1.dll (which is needed by L"C:\\Program Files\\Adobe\\Adobe DNG Converter\\Adobe DNG Converter.exe") not found
00ec:err:module:LdrInitializeThunk Importing dlls for L"C:\\Program Files\\Adobe\\Adobe DNG Converter\\Adobe DNG Converter.exe" failed, status c0000135

This can happen anytime as Windows want to and Adobe DNG Converter just updates to it. :wink: That error happens with wine 7.0 but when I switch to wine 8.0, then it works.

1 Like

It works here on xfce unstable (from AUR), Wine 8.2. oh my, 1.4GB…wow

Hello @jrichard326
That can be that it works with you, because you use wine 8.2. My normal Manjaro has only 8.1 - and it doesn’t work with that. Only after a downgrade to 7.x, there it works.

I suppose that is possible. Wine 8.2 is in Testing and Unstable now. You could always switch branches and give it a try or wait a bit. Curiosity got the best of me there. If it does not work when 8.2 hits Stable then I guess there is something “off” on your system. What is troubling is that @megavolt shows it running fine with Wine 8.0.

Oh, that worries me a bit. How can you tell what’s wrong with the system? Or reinstall it right away?

I wouldn’t re-install without trying to fix this. It looks like it works with Wine 8.0 and 8.2. Maybe it just does not work with Wine 8.1? That is how it looks from one of your posts.
You can switch temporarily to Testing Branch and see if it will work on your system with Wine 8.2.

1 Like

First try to solve the problem. That’s a good, typical Linux recommendation: Don’t reinstall immediately, which I had always done with Windows when there were problems.
I have now made wine on 8.0-2 and now I can install the dngconverter with AUR. But still not directly with wine in the timeline.
So with 7.x and 8.0 it works via AUR. Pirma.

You say I could try the Testing Branch - how does it work, and can it be totally undone?

Please see here:

What do you mean by this? I have limited experience with wine as I only use it for two standalone, small footprint programs, Quickpar and WinSCP(seldom used to access router at a system level). With this dngconverter, I built manually via makepkg and installed. I wound up launching the .exe directly via /usr/bin. Do you mean there wasn’t a traditional launcher for the software? I didn’t see a launcher in .wine/drive_c/Program Files or Program Files (x86)

With AUR, Adobe DNG Converter is not up to date (14.x). If I install it via Wine, then I can always use the latest version:
The installation goes like this:

mkdir -pv $HOME/Wine/DNGConverter/{prefix,dngconverter}
export WINEPREFIX=$HOME/Wine/DNGConverter/prefix
export WINEARCH=win64
export WINEPATH=$HOME/Wine/DNGConverter/dngconverter
export WINEDLLOVERRIDES="winemenubuilder.exe=d"
export WINEDEBUG=-all
export WINEDLLOVERRIDES="mscoree=d,winemenubuilder.exe=d,mshtml=d"
wineboot --init
wineboot –restart
wine $HOME/Downloads/AdobeDNGConverter_x64_15_2.exe

I once learned this from megavolt, I myself would never in my life know how to do it.

This worked wonderfully, only recently it no longer works, not even with wine 8.0 or 7.x

You only need: wine and winetricks.