Dmenu and morc-menu broken on update (i3 edition)

i3

#1

I’ve just installed a bunch of updates yesterday, and since then my dmenu and morc_menu have the following problem. When i hit mod+d or mod+z the dmenu or morc_menu come up, but then on the next key press they disappear. Even if I hit enter, it doesn’t launch the highlighted app. I can however click on the items with the mouse.

Most frustrating, does anyone know what the problem might be or how I would go about debugging it?


#2

I just installed manjaro i3 on a different brand new laptop and the only change I have made is installing firefox and I’m getting the exact same problem straight away. Any help on this issue would be greatly appreciated.


#3

I saw on this thread [SOLVED]Dmenu and Morcmenu close on input that a user had success changing /etc/locale.conf to change en_DK.UTF-8 to en_US.UTF-8 and then running locale-gen. I’ve tried this and the problem persists.


#4

Solved it! I commented out the line en_DK.UTF-8 UTF-8 in /etc/locale.gen and ran locale-gen. This has solved my issue.