DM not starting

Hey Guys!

every time i start my computer i need to manually do startx via TTY2 because it hangs on a black screen, after i run startx everything works (kinda), is there any way to fix it, im still kinda a noobie with linux so if you want any logs just tell me how to get them and i will post them, thx

Seems you need a display manager like lightdm or sddm.
Install it and restart.

i installed lightdm via pacman and after a quick restart it fixed nothing…

You may need to activate it with
sudo systemctl enable lightdm -f

Just installing a display manager isn’t enough.
It needs to be set so it starts every time.

systemctl status display-manager.service

But KDE already comes with sddm - look for that name in the output of the above command.
Perhaps it just doesn’t start for some reason.

Be sure you didn’t install and enable a second one
you mentioned lightdm -
that will create problems when two are active at the same time.

Hardware info for all to see what you are dealing with would be good:

inxi -Fazy

yeah, i uninstalled sddm and tried it but still isnt working, so i just removed that again and installed sddm again, will try the above mentioned now

i did systemctl status with display-manager and sddm and both showed enabled and had no problems shown

I can’t help now.
And others will need details …