Dkms dependency issue

linux-headers for currently installed kernel should be installed automatically as a dependency for all dkms packages, it doesn’t get pulled down with nvidia-dkms

Hi @person1873, and welcome!

I’ve never experienced an issue installing my nvidia’s drivers. How did you install it?

Edit:

And besides, nvidia-dkms already has dkms as dependency for nvidia-dkms:

$ pamac info nvidia-dkms
Name                  : nvidia-dkms
Version               : 495.46-3
Description           : NVIDIA drivers - module sources
URL                   : http://www.nvidia.com/
Licences              : custom
Repository            : extra
Installed Size        : 50.7 MB
Groups                : --
Depends On            : dkms nvidia-utils=495.46 libglvnd
Optional Dependencies : --
Provides              : NVIDIA-MODULE nvidia=495.46
Replaces              : --
Conflicts With        : --
Packager              : Mark Wagie <mark@manjaro.org>
Build Date            : Tue 11 Jan 2022 17:49:25
Validated By          : MD5 Sum  SHA-256 Sum  Signature

@Mirdarthos I installed nvidia-dkms using pamac.

sudo pamac install nvidia-dkms

it pulled in the dkms depend, but no linux-header package
as this is a fairly fresh install, there were no headers and i ended up with error output following installation.

seeing it fail this way, I simply installed the headers manually and the dkms triggers compiled the module without issue. just seems a little odd that pamac didn’t even suggest to install kerenel headers at the same time

That is odd, yes.

Y’know what? I think it’s kind of because for drivers, in particular Nvidia I think, it’s better to use mhwd as per the wiki:

https://wiki.manjaro.org/index.php/Configure_NVIDIA_(non-free)_settings_and_load_them_on_Startup/en

I had done this already, I was installing nvidia-dkms to try and resolve another issue i’m having which i’m about to make another post about.
This just seemed like a bug which i wasn’t too sure where to post

And now I also don’t know.

:man_shrugging:

A very good explanation is given here as to why the linux-headers package for a particular kernel isn’t installed automatically while installing a dkms package:

On Manjaro this kernel dependency must be resolved manually - and you need to know which kernel you are using - otherwise pacman defaults to the first header package listed linux414-headers which of course won’t work unless you actually are using 4.14 as the primary kernel.

1 Like

Thanks for that @ishaanbhimwal

I guess I’ve been a bit spoiled by the debian ecosystem for the last year, which I escaped because of excessive dependency draw down (xorg depending on gnome-session??? wtf ubuntu).
I understand why this is the case for Arch specifically, it makes sense.
seemed like a bug in manjaro due to how easy it’s been to use so far.
but i’m fine with installing my own headers.

cheers for explaining.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.