DistributionNotFound error after update


Recently I updated my system and a python application has stopped working, throwing the following error:

Traceback (most recent call last):
  File "/usr/bin/wallpaper-reddit", line 6, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 3243, in <module>
    def _initialize_master_working_set():
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 3226, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 3255, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 568, in _build_master
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 886, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 772, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'wallpaper-reddit==3.1.1' distribution was not found and is required by the application´

I know that I have solved this issue in the past, but I can’t remember how or even why is happening. Can anyone help me please?

Thanks in advance.

Have you tried rebuilding the “offending” AUR package? That usually helps.

System Python has been updated to 3.9 - when your homebuild packages fails after an update - the recipe is to rebuild the package(s) just as @Strit recommends.

Thanks for your answers!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.