Displaylink does not see connected devices after Recent Update

After the recent updates (this weekend) my System stopped recognizing Displays connected to the Computer. It did work before that.

System is a T570 with an Intel Graphics card

What I tried so far:
Using Kernel 5.10.131-1

  1. evdi 1.12.0-1 with displaylink 5.6.1 (AUR)
  2. evdi-git 1.9.1 (AUR) with displaylink 5.6.1 (AUR)
  3. evdi-git 1.9.1 (AUR) with displaylink-beta 5.5.0-1 (AUR)
  4. evdi-git 1.9.1 (AUR) with displaylink 5.6.1 (AUR) and displaylink-connect 3.2.1-1 (AUR)
  5. for fun i did a Kernel 5.15. test with evdi 1.12.0-1 with displaylink 5.6.1 (AUR) but that failed miserably (aka journalctl -u displaylink told me that modprobe does not find evdi module - which i was anticipating so lets not talk about that issue)

all in common have that:

  • no monitors are shown which means: xrandr --listmonitors only shows the laptops monitor

Monitors: 1
0: +*eDP1 1920/340x1080/190+0+0 eDP1

  • evdi does not show up
    on bootup or when Displaylink device is plugged in journalctl -u displaylink:

    systemd[1]: Starting DisplayLink Manager Service…
    systemd[1]: Started DisplayLink Manager Service.

When Displaylink device is unplugged:

systemd[1]: Stopping DisplayLink Manager Service…
systemd[1]: displaylink.service: Deactivated successfully.

Other parts of the doking station (aka the usb port and network) do work, so it should not be a usb issue (i guess)
I have the problem with two different usb-doking stations (i have more of the same, but non other stuff) so it is not an hardware issue on the docking stations side

for 1) this installation was the one, that stopped working - so there migtht have been a update on evdi - but i am not shure - i just did the update without thinking much about it
for 2-4) no changes - just does not work - same as the rest
for 5) i know that 5.15 is not supported - tried it just in case i missed that it now is supported

I am aware of the displaylink wiki page and did everything that is recommended there. (especially the stuff for intel gpu)
If anyone could help me I would be rather thankfull

Have you installed your kernel headers? That could help out a bit.

Kernel headers are installed and had been all along.

Same issue here. I just tried getting it working today after the recent updates, so I can’t confirm whether or not it worked before, but the docking station doesn’t display onto external monitors. USB seems to be ok.


I am also seeing this issue.
Was up until now using kernel 5.10 och updated to kernel 5.15 moments ago.
Installed new headers as well, and making sure evdi, displaylink and displaylink-connect were all up to date.

It responds to the dock, giving me ports for audio and microphone, but the displays remains turned off, not responding at all.

evdi or evdi-git did not make a difference.
evdi-git 1.12.0.r1.gb884877-1
displaylink 5.6-1
displaylink-connect 3.2.1-1

Also having this problem.

Edit: Can be solved by downgrading to evdi 1.11

# Maintainer: mwawrzyniak <arch at cmstactical dot net>
# Contributor: PlusMinus

pkgdesc="A Linux® kernel module that enables management of multiple screens."
arch=('i686' 'x86_64')
depends=(glibc dkms libdrm)

prepare() {
  cd "$pkgname-$pkgver"
  local src
  for src in "${source[@]}"; do
    [[ $src = *.patch ]] || continue
    patch -Np1 -i "../$src"

build() {
  # We only need to build the library in this step, dkms will build the module
  cd "$pkgname-$pkgver/library"

package() {
  cd "$pkgname-$pkgver"

  install -Dm0755 library/lib$pkgname.so "$pkgdir/usr/lib/lib$pkgname.so"

  SRCDIR="$pkgdir/usr/src/$pkgname-$pkgver"	# This one is needed for dkms
  install -d "$SRCDIR"
  install -Dm0755 module/* "$SRCDIR"

I don’t have have the prior version in my package cache. Can anyone give me a quick explainer on how to use the code given by @monoanji to install the 1.11 release? I’m relatively new to Manjaro and Arch.

** 5 minutes later **

Maybe I should have waited to post. In case it helps anyone, or if someone has a suggestion of a better method, here’s what I did: I added monoanji’s code to a PKGBUILD file and then ran makepkg in that folder. Then I moved the tar.zst file to /var/cache/pacman/pkg. Then I could downgrade.

Oops, sorry for the very late reply: makepkg -si would also have worked and you wouldn’t have needed to copy the file to /var/cache/pacman/pkg. -s being “also install dependencies (synchronize)”, -i being install.